Page MenuHomePhabricator

Fatal exception of type Flow\Exception\InvalidDataException
Closed, ResolvedPublic

Description

At https://fr.wikipedia.org/wiki/Discussion_utilisateur:VeldinG there is currently
[Wzv96gpAICIAAAY@74cAAADI] 2018-07-03 22:51:22: Fatal exception of type "Flow\Exception\InvalidDataException"
after the beta feature was accidentally disabled and then re-enabled.

@VeldinG wrote:

Hi! Since I switched to beta features including Flow structured discussion on my user talk, everything was well until I turned off it by inadvertence. I toggled again but its triggered into displayed "Fatal exception of type "Flow\Exception\InvalidDataException"" error. Therefore I can not do anything to fix it. Since then neither users nor myself are able to write on my user talk.
Thus, I ask you for help to fix that issue. Thank you very much in advance.


I tried a purge but nothing changed.
I skimmed search results, and this task might contain relevant notes for the devs: T184670: [wmf.16-regression] Fatal exception of type "Flow\Exception\InvalidDataException" for opting out from "Structured Discussions on user talk"

Event Timeline

Quiddity created this task.Jul 3 2018, 11:11 PM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptJul 3 2018, 11:11 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
SBisson added a subscriber: SBisson.Jul 4 2018, 3:25 PM

I fixed the page manually but it is blank and it has pretty much no history.

@VeldinG did you have any topics on that page prior to disabling the beta feature?

For reference, I think this is the exception that broke the page

#0 /srv/mediawiki/php-1.32.0-wmf.10/extensions/Flow/includes/WorkflowLoaderFactory.php(103): Flow\WorkflowLoaderFactory->loadWorkflowById(Title, Flow\Model\UUID)
#1 /srv/mediawiki/php-1.32.0-wmf.10/extensions/Flow/includes/Content/BoardContent.php(245): Flow\WorkflowLoaderFactory->createWorkflowLoader(Title, Flow\Model\UUID)
#2 /srv/mediawiki/php-1.32.0-wmf.10/extensions/Flow/includes/Content/BoardContent.php(223): Flow\Content\BoardContent->getWorkflowLoader(Title)
#3 /srv/mediawiki/php-1.32.0-wmf.10/extensions/Flow/includes/Content/BoardContent.php(173): Flow\Content\BoardContent->generateHtml(Title, User)
#4 /srv/mediawiki/php-1.32.0-wmf.10/includes/jobqueue/jobs/CategoryMembershipChangeJob.php(240): Flow\Content\BoardContent->getParserOutput(Title, integer, ParserOptions)
#5 /srv/mediawiki/php-1.32.0-wmf.10/includes/jobqueue/jobs/CategoryMembershipChangeJob.php(216): CategoryMembershipChangeJob->getCategoriesAtRev(Title, Revision, string)
#6 /srv/mediawiki/php-1.32.0-wmf.10/includes/jobqueue/jobs/CategoryMembershipChangeJob.php(176): CategoryMembershipChangeJob->getExplicitCategoriesChanges(Title, Revision, Revision)
#7 /srv/mediawiki/php-1.32.0-wmf.10/includes/jobqueue/jobs/CategoryMembershipChangeJob.php(142): CategoryMembershipChangeJob->notifyUpdatesForRevision(Wikimedia\Rdbms\LBFactoryMulti, WikiPage, Revision)
#8 /srv/mediawiki/php-1.32.0-wmf.10/extensions/EventBus/includes/JobExecutor.php(67): CategoryMembershipChangeJob->run()
#9 /srv/mediawiki/rpc/RunSingleJob.php(80): JobExecutor->execute(array)
#10 {main}
VeldinG added a comment.EditedJul 4 2018, 8:35 PM

Thank you for fixing that bug. Now, everything is fine on my user talk.
@SBisson No, I didn't. I freshly turned on the feature before.

kostajh removed kostajh as the assignee of this task.Jul 16 2018, 5:51 PM
kostajh added a subscriber: kostajh.
Lnnocentius added a subscriber: Lnnocentius.EditedJul 17 2018, 1:36 PM

An extremely similar problem happened earlier today on zh-wiki. The related page is https://zh.wikipedia.org/wiki/User_talk:DW_YoungDLS

The user claimed to have closed and tried to re-open flow on his talk page, resulting in this error.

No fix attempted on this page yet, we thought it might be better to keep the page in place for you guys to find a fix.

An extremely similar problem happened earlier today on zh-wiki. The related page is https://zh.wikipedia.org/wiki/User_talk:DW_YoungDLS

The user claimed to have closed and tried to re-open flow on his talk page, resulting in this error.

No fix attempted on this page yet, we thought it might be better to keep the page in place for you guys to find a fix.

I have fixed this page, and a few others on zh-wiki, manually. No need to leave those pages broken. We're able to reproduce this problem on a test wiki.

Can't reproduce this error by opting out of the beta feature on wmf.13

Etonkovidova closed this task as Resolved.Jul 25 2018, 8:45 PM
Etonkovidova added a subscriber: Etonkovidova.

Yes, it seems that testwiki and cawiki (wmf.14 and wmf.13) are fine with turning on/off ' Structured Discussions on user talk" beta feature.