Page MenuHomePhabricator

Regression: colours not accessible (not conforming to WCAG 2 AA)
Closed, ResolvedPublic

Event Timeline

Nemo_bis created this task.Aug 2 2018, 4:47 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 2 2018, 4:47 PM
Isarra added a subscriber: Isarra.Aug 2 2018, 6:01 PM

White on black (footer) and pink/green on blue (header and other parts of the site), for text or other elements, are also problematic and make some parts of the site quite painful to look at.

JMinor awarded a token.Aug 8 2018, 2:36 AM
JMinor added a subscriber: JMinor.

@TheDJ : Colors is one part of WCAG, I mentioned T201682 that for example there is no alt and some other non-compliance of WCAG that are not related to colors, We can either make this subtask of T201682 or broaden scope of this task to fix all of WCAG issues. Either way is fine for me.

@TheDJ @Ladsgroup On a short look, there are several different topics to tackle, so @Ladsgroup's input is what I had in mind, when first looking at the source code as well. Let's collect them as subtasks, including the current one.

Izno moved this task from Unsorted to Colors on the Accessibility board.Sep 22 2018, 6:05 PM

For a range of reasons, like range of available colors, minimum color contrast within colors in such limited palette (think 3:1 contrast requirement of UI components to surrounding text, both in WCAG 2.0 & 2.1) it is not feasible to aim for AAA conformance in product design for most inclusive, biggest possible user group. In our recent Foundation web product launches we were aiming for AA conformance in balancing well-supporting majority of our users while deferring further needs to special software.

Volker_E renamed this task from Regression: colours not accessible (not compliant with WCAG 2 AAA) to Regression: colours not accessible (not conforming to WCAG 2 AA).Oct 5 2018, 8:35 PM
Volker_E added a comment.EditedOct 5 2018, 8:39 PM

Please note that various of our other resources have been finding this balance as well. For example Meta Wiki's top link colors are only conforming to AA (#069 to #fff with 6.25:1).

Varnent closed this task as Resolved.Jul 11 2019, 11:42 PM
Varnent claimed this task.
Varnent added a subscriber: Varnent.

Hello - I believe this ticket has been resolved with the updated design we released this week - which I invite you to checkout at: https://wikimediafoundation.org/
I am closing the ticket, but please let me know if it is not resolved on your end. Thank you!

stjn reopened this task as Open.Jul 12 2019, 11:44 AM
stjn added a subscriber: stjn.

Testing with tota11y:

Haven’t touched other pages since I don’t really want to do a full accessibility audit :-) Tools such as tota11y, aXe and Accessibility Insights can catch these errors pretty easily anyway.

JMinor removed a subscriber: JMinor.Jul 12 2019, 3:56 PM
Volker_E closed this task as Resolved.Tue, Oct 8, 2:50 AM
Volker_E claimed this task.

With the latest updates of today, wikimediafoundation.org website features only level AA conforming colors.