Page MenuHomePhabricator

Wikia only supports TLS 1.2
Closed, ResolvedPublic

Description

Wikimedia does TLS 1.0 and TLS 1.2.... Wikia only does TLS 1.2

We're going to need to look at doing something conditional based on .NET version... Or maybe it's time we just bump the version completely? We need to go to .NET 4.5

Event Timeline

Reedy created this task.Aug 17 2018, 1:05 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 17 2018, 1:05 AM
Reedy updated the task description. (Show Details)Aug 17 2018, 1:07 AM
Reedy added subscribers: Rjwilmsi, Magioladitis.

So... @Magioladitis @Rjwilmsi we're pretty much going to have to jump to .NET 4.5

Thoughts? Complaints? Do your IDE's support that?

Reedy added a comment.Aug 17 2018, 1:09 AM

I'm guessing I need to do the overdue release, and then look at bumping .NET versions

Reedy added a comment.Aug 17 2018, 1:12 AM

Wikimedia are going to be dropping TLS 1.0 soon... So yes, we basically have to do this

https://phabricator.wikimedia.org/phame/post/view/111/wikipedia_goes_100_forward_secret/

Reedy triaged this task as High priority.Aug 17 2018, 1:13 AM

OK, @Reedy so as suggested let's please do next release on existing .NET 3.5 then a second release on .NET 4.5. If we leave both as enabled then that will give users some time to sort out any required .NET upgrades (Wikimedia has already dropped support for XP users as I understand it so this 3.5 to 4.5 bump should not affect any newer Windows versions).

For me personally, I know that mono 5.10 and .NET 4.0 work together for AWB (MonoDevelop compile with one local patch for the webbrowser refactor that mono doesn't like, run under wine). And a .NET 4.0 little project of mine runs under wine using .NET 4.0 features. And .NET 4.5 does install under wine 1.8.1 and runs current AWB (.NET 3.5) fine. .NET 4.5 install failed on wine 2.0.1, haven't retested newer wine versions yet. So overall .NET 4.5 should already work but haven't actually tested the combination, and I'll have to make it work once WikiMedia require TLS 1.2.

Reedy added a comment.EditedAug 17 2018, 10:41 PM

Ok. 5.10.0.0 released.

5.10.0.1 supports TLS 1.1 and TLS 1.2 by using .NET 4.5

Need to do a bit more testing and poking..

We should disable some older versions (making people use 5.10.0.0, so we get tagging and stuff), and then at possibly releasing 6.0.0.0 as a .NET 4.5 release in the next couple of weeks

Reedy added a comment.Aug 21 2018, 5:14 PM

I'm going to get a 6.0.0.0 release out later this week

Any luck with this?

TyA added a subscriber: TyA.Sep 4 2018, 9:42 AM

any updates on this new update?

Reedy added a comment.Sep 9 2018, 1:39 PM

any updates on this new update?

See above. It's committed, working. Not released yet as I'm waiting on other bug reports in the software to die down a little

Izno added a subscriber: Izno.Sep 13 2018, 1:31 PM
Izno added a comment.Sep 13 2018, 2:38 PM

any updates on this new update?

See above. It's committed, working. Not released yet as I'm waiting on other bug reports in the software to die down a little

Since it's a question of release (you committed the changes) and not implementation at this point (for which I opened a task), would it be reasonable to close this one resolved?

Reedy closed this task as Resolved.Sep 15 2018, 1:15 PM
Reedy claimed this task.

But the problem is still,perhaps it's none of TLS 1.2 problem.

Reedy added a comment.Sep 15 2018, 4:56 PM

But the problem is still,perhaps it's none of TLS 1.2 problem.

It is. Because less than .NET 4.5 doesn’t support TLS 1.1 and 1.2. Wikia only supports TLS 1.2

I tested it working

It’s working fine for other people who have upgraded