Page MenuHomePhabricator

Apertium fails to translate a quote template
Closed, ResolvedPublic

Description

Translating en:Užican_dialect to Spanish. Under "History" section, there is one quote that starts with "The Turkish influence...".

Trying to translate that quote silently fails and empty section is added instead, while using Apertium.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 28 2018, 11:23 AM
santhosh triaged this task as Normal priority.Sep 28 2018, 11:24 AM
santhosh edited projects, added CX-cxserver; removed ContentTranslation.

Change 463454 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/services/cxserver@master] Do not pass blank textblocks to machine translation services

https://gerrit.wikimedia.org/r/463454

Before the patch, trying to translate the quote resulted in empty section. With the patch, template is adapted, although author is not mapped well: you can see "24px24px" being used in the author field.
As far as the main piece of text goes, the source is applied, not translated via Apertium.

santhosh added a comment.EditedOct 1 2018, 4:51 AM

No plans to translate the content of template params. We don't do it for any templates.

Parameter mapping depends so many details. And not 100% guranteed. In this case the template params are numbered params and order differs in source and target language. This will require editor intervention.

Change 463454 merged by jenkins-bot:
[mediawiki/services/cxserver@master] Do not pass blank textblocks to machine translation services

https://gerrit.wikimedia.org/r/463454

Petar.petkovic moved this task from In Review to QA on the Language-2018-Oct-December board.
Petar.petkovic removed a subscriber: gerritbot.

Waiting for cxserver deployment.

@KartikMistry - has cxserver been deployed? The issue is still present in testwiki (wmf.24) although Apertium handles the translation as per @Petar.petkovic comment's screenshot. The translation of quote template still silently fails in cx2 (both for Apertium and Yandex(of course)).

Stashbot added a subscriber: Stashbot.

Mentioned in SAL (#wikimedia-operations) [2018-10-15T03:14:02Z] <kartik@deploy1001> Started deploy [cxserver/deploy@5a70ef1]: Update cxserver to 47a864b (T205420, T203077, T205700, T205616)

Mentioned in SAL (#wikimedia-operations) [2018-10-15T03:18:46Z] <kartik@deploy1001> Finished deploy [cxserver/deploy@5a70ef1]: Update cxserver to 47a864b (T205420, T203077, T205700, T205616) (duration: 04m 44s)

Verified. It doesn't silently fail now.

Re-checked in wmf.26 - Apertium doesn't silently fails, but doesn't translate the quote template either:

Since the title of this task was about actually translating the content of the quote template - "Apertium fails to translate a quote template" - I'm moving the task back to Priority Backlog.

Pginer-WMF added a subscriber: Pginer-WMF.

Since the title of this task was about actually translating the content of the quote template - "Apertium fails to translate a quote template" - I'm moving the task back to Priority Backlog.

Moving to general backlog since it was not in priority backlog before.

No plans to translate the content of template params. We don't do it for any templates.

Moving back to QA, because the reason the ticket got moved to Backlog is the template params not being translated.

Etonkovidova closed this task as Resolved.Oct 24 2018, 11:45 PM

@Petar.petkovic translating quote template in cx2 strangely regressed Apertium silently failing.

In production (wmf.26)

  • the quote is displayed in English as before (see the screenshot in my comment above)
  • a user is correctly informed that "Template unavailable"

Given the current behavior for translating quote template in production in production and @santhosh comment

No plans to translate the content of template params. We don't do it for any templates.

I am closing the issue as resolved.