Page MenuHomePhabricator

Text in Sidebar on mw.org does no longer show message text, only message name (for some cached versions)
Closed, InvalidPublic

Description

Seen on MediaWiki.org: The messages in the sidebar do no longer show their message text, but instead, show the message names. On MediaWiki-Vagrant, this shows the following notice, with stacktrace:

Notice: MediaWiki\Revision\RevisionStore::newRevisionFromRow: MediaWiki:Sidebar: Cannot create a user with no name, no ID, and no actor ID [Called from MediaWiki\Revision\RevisionStore::newRevisionFromRow in /vagrant/mediawiki/includes/Revision/RevisionStore.php at line 1784] in /vagrant/mediawiki/includes/debug/MWDebug.php on line 309
Call Stack
#	Time	Memory	Function	Location
1	0.0000	360408	{main}( )	.../index.php:0
2	0.0051	364280	require( '/vagrant/mediawiki/index.php' )	.../index.php:5
3	0.2787	2435864	MediaWiki->run( )	.../index.php:42
4	0.2788	2436120	MediaWiki->main( )	.../MediaWiki.php:517
5	0.2825	2447672	MediaWiki->getAction( )	.../MediaWiki.php:777
6	0.2835	2449328	Action::getActionName( )	.../MediaWiki.php:155
7	0.3188	2525640	Action::factory( )	.../Action.php:156
8	0.3188	2525640	WikiPage->getActionOverrides( )	.../Action.php:98
9	0.3188	2525640	WikiPage->getContentHandler( )	.../WikiPage.php:256
10	0.3199	2528568	WikiPage->getContentModel( )	.../WikiPage.php:269
11	0.3602	2679360	WANObjectCache->getWithSetCallback( )	.../WikiPage.php:647
12	0.3602	2679360	WANObjectCache->doGetWithSetCallback( )	.../WANObjectCache.php:1150
13	0.3602	2679504	WikiPage->{closure:/vagrant/mediawiki/includes/page/WikiPage.php:637-647}( )	.../WANObjectCache.php:1277
14	0.3602	2679504	WikiPage->getRevision( )	.../WikiPage.php:638
15	0.3602	2679504	WikiPage->loadLastEdit( )	.../WikiPage.php:766
16	0.3609	2688680	Revision::newKnownCurrent( )	.../WikiPage.php:744
17	0.3713	2779440	MediaWiki\Revision\RevisionStore->getKnownCurrentRevision( )	.../Revision.php:1308
18	0.3732	2786600	MediaWiki\Revision\RevisionStore->newRevisionFromRow( )	.../RevisionStore.php:2757
19	0.3733	2812056	wfWarn( )	.../RevisionStore.php:1784
20	0.3733	2812056	MWDebug::warning( )	.../GlobalFunctions.php:1133
21	0.3733	2812608	MWDebug::sendMessage( )	.../MWDebug.php:164
22	0.3733	2812928	trigger_error ( )	.../MWDebug.php:309

See for yourself: https://www.mediawiki.org/w/index.php?title=MediaWiki:Sidebar.

Event Timeline

Restricted Application removed a project: Patch-For-Review. · View Herald TranscriptOct 17 2018, 3:02 PM
Krenair removed mmodell as the assignee of this task.Oct 17 2018, 3:06 PM
Krenair added a project: MediaWiki-General.
Krenair added a subscriber: mmodell.
Krenair added a subscriber: Krenair.

(rm inherited assignment)

greg raised the priority of this task from Normal to Unbreak Now!.Oct 17 2018, 3:25 PM
Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptOct 17 2018, 3:25 PM

Related to the actor migration? Pinging @Anomie.

Related to the actor migration? Pinging @Anomie.

Seems unlikely at first glance.

I put mediawikiwiki onto wmf.26 on mwdebug1002 for testing and could not reproduce the issue. I also can't reproduce it locally.

Regarding the pasted trace, I find that both the data in the getKnownCurrentRevision() cache and the data it would fetch from the database look valid (and in particular do have rev_user and rev_user_text set), for both the top revision of [[mw:MediaWiki:Sidebar]] and the revision previous.

Further, the warning listed seems unlikely to result in the sidebar messages going missing.

Oh, that stack trace is probably bogus. My local vagrant instance is messed up, as the issue only pops up when literally visiting MediaWiki:Sidebar. I've intermittently had problems with the actor migration process for a while now. I'm sorry for putting everyone on a false track here.

Mentioned in SAL (#wikimedia-operations) [2018-10-17T19:23:06Z] <twentyafterfour> Mediawiki train is still blocked by T207288

@Anomie: does this need to be closed as invalid?

Mainframe98 added a comment.EditedOct 17 2018, 7:25 PM

The stack trace I've provided is not relevant to this issue, but please do check https://www.mediawiki.org/wiki/MediaWiki, and observe that the sidebar still doesn't show the expected text.

The stack trace I've provided is not relevant to this issue, but please do check https://www.mediawiki.org/wiki/MediaWiki, and observe that the sidebar still doesn't show the expected text.

... If it's happening for you now even though we're rolled back to wmf.24, does this actually need to block the train?

@Mainframe98: I'm not seeing what you mean? The sidebar looks normal for me.

I can only reproduce this on a few devices, I suspect whatever it is, is slowly disappearing with wmf.24. If you think it is safe to proceed, please do so.

please do check https://www.mediawiki.org/wiki/MediaWiki, and observe that the sidebar still doesn't show the expected text.

I cannot reproduce this problem.
@Mainframe98: Do you also see the problem when using a private browser window? Have you already tried bypassing your browser cache? Does this also happen with another browser? Which browser(s) did you try this with? Are you logged in or logged out on mediawiki.org?

This is really strange. So when in Incognito mode, the expected sidebar shows. When logging off, the expected sidebar shows. When logging back on, the sidebar with the incorrect messages is shown again. It's not a script either, using ?safemode=1 has the same issue.

I can reproduce this across three devices, and it absolutely baffles me. Is there any cache that somehow only affects logged-in users?

Mainframe98 added a comment.EditedOct 17 2018, 7:46 PM

@Aklapper I've done some investigating in the comment above. Additionally, the same behaviour occurs in Microsoft Edge, Internet Explorer 11 and Google Chrome (70). Also on Google Chrome on an iPad, and Android Phone, all latest versions of them.

Hmm. I see it when visiting https://www.mediawiki.org/wiki/Special:Version?uselang=nl. Checking caches, I see that the cached sidebar for language nl does have those incorrect texts.

When I execute the code that would be run when the cache entry expires it generates a correct sidebar, even on wmf.26.

@Anomie: how can we clear the cache?

Aklapper renamed this task from Text in the Sidebar does no longer show the message text, only the message name to Text in Sidebar on mw.org does no longer show message text, only message name (for some cached versions).Oct 17 2018, 11:13 PM

It appears that everything has returned to normal again. For me at least, as visiting the main page in Italian: https://www.mediawiki.org/wiki/MediaWiki?uselang=it, still shows the incorrect version. I can only imagine that there are incorrect versions for other languages.

@Anomie: how can we clear the cache?

From mwrepl, something like this should do it:

$languageCode = 'nl'; // Or whatever other language
$wanCache = MediaWiki\MediaWikiServices::getInstance()->getMainWANObjectCache();
$wanCache->delete( $wanCache->makeKey( 'sidebar', $languageCode ) );
mmodell added a comment.EditedOct 18 2018, 3:11 PM

I'm still not sure if this is a real blocker or just a spurious issue. I deployed wmf.26 to group0 last night and I'd like to get the train moving again if possible but I don't want to move forward with a bug that's going to break translations everywhere.

mmodell lowered the priority of this task from Unbreak Now! to Normal.Oct 18 2018, 3:28 PM
mmodell closed this task as Invalid.Oct 24 2018, 3:34 PM

I don't think this is currently reproducible. If someone is able to describe steps to reproduce that will lead to another conclusion, then please feel free to reopen.

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptOct 24 2018, 3:34 PM
mmodell changed the subtype of this task from "Task" to "Production Error".Wed, Aug 28, 11:08 PM