Page MenuHomePhabricator

Run English 2018 fundraising on apps
Closed, ResolvedPublic

Description

We'd like to run a fundraising announcement for the 2018 English fundraiser (en6C). Please place an announcement with the following properties:

Start Date: 11/29/2018 16:00:00 UTC
End Date: 12/19/2018 23:59:00 UTC


Destination URL (Android): https://donate.wikimedia.org/?uselang=en&utm_medium=WikipediaAppFeed&utm_campaign=Android&utm_source=app_201812_6C_control

Destination URL (iOS): https://donate.wikimedia.org/?uselang=en&utm_medium=WikipediaAppFeed&utm_campaign=iOS&utm_source=app_201812_6C_control


Image URL’s on Android: US, GB/IE/AU, NZ/CA
Image URL on iOS: No image


Body copy:

US
To all our readers in the U.S.,

It's a little awkward, so we'll get straight to the point: Today we humbly ask you to protect Wikipedia's independence. We depend on donations averaging about $16.36, but 99% of our readers don't give. If everyone reading this gave $3, we could keep Wikipedia thriving for years to come. The price of your coffee today is 
all we need.

Wikipedia is a place to learn, not a place for advertising. It unites all of us who love knowledge: contributors, readers and the donors who keep us thriving. Please take a minute to help us keep Wikipedia growing. Thank you.

GB
To all our readers in the UK,

It's a little awkward, so we'll get straight to the point: Today we humbly ask you to protect Wikipedia's independence. We depend on donations averaging about £10, but 99% of our readers don't give. If everyone reading this gave £2, we could keep Wikipedia thriving for years to come. The price of your coffee today is 
all we need.

Wikipedia is a place to learn, not a place for advertising. It unites all of us who love knowledge: contributors, readers and the donors who keep us thriving. Please take a minute to help us keep Wikipedia growing. Thank you.

IE
To all our readers in Ireland,

It's a little awkward, so we'll get straight to the point: Today we humbly ask you to protect Wikipedia's independence. We depend on donations averaging about €10, but 99% of our readers don't give. If everyone reading this gave €2, we could keep Wikipedia thriving for years to come. The price of your coffee today is 
all we need.

Wikipedia is a place to learn, not a place for advertising. It unites all of us who love knowledge: contributors, readers and the donors who keep us thriving. Please take a minute to help us keep Wikipedia growing. Thank you.

AU
To all our readers in Australia,

It's a little awkward, so we'll get straight to the point: Today we humbly ask you to protect Wikipedia's independence. We depend on donations averaging about $15, but 99% of our readers don't give. If everyone reading this gave $3, we could keep Wikipedia thriving for years to come. The price of your coffee today is 
all we need.

Wikipedia is a place to learn, not a place for advertising. It unites all of us who love knowledge: contributors, readers and the donors who keep us thriving. Please take a minute to help us keep Wikipedia growing. Thank you.

NZ
To all our readers in New Zealand,

It's a little awkward, so we'll get straight to the point: Today we humbly ask you to protect Wikipedia's independence. We depend on donations averaging about $15, but 99% of our readers don't give. If everyone reading this gave $3, we could keep Wikipedia thriving for years to come. The price of your coffee today is 
all we need.

Wikipedia is a place to learn, not a place for advertising. It unites all of us who love knowledge: contributors, readers and the donors who keep us thriving. Please take a minute to help us keep Wikipedia growing. Thank you.

CA
To all our readers in Canada,

It's a little awkward, so we'll get straight to the point: Today we humbly ask you to protect Wikipedia's independence. We depend on donations averaging about $15, but 99% of our readers don't give. If everyone reading this gave $3, we could keep Wikipedia thriving for years to come. The price of your coffee today is 
all we need.

Wikipedia is a place to learn, not a place for advertising. It unites all of us who love knowledge: contributors, readers and the donors who keep us thriving. Please take a minute to help us keep Wikipedia growing. Thank you.

Privacy disclaimer text:
 By submitting, you are agreeing to our donor privacy policy.


Button label: Donate now


Countries included: US, CA, GB, IE, AU, NZ


Latest reference visual on Android (border below payment methods has been added in the images above)

Latest reference visual on iOS

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 19 2018, 12:02 AM

Hey @bearND, I’ve asked my team (fundraising) to review this until tomorrow Monday, November 19, 1800 UTC. If you don’t hear anything from us until then, the announcement in the card’s description is going to be final. Let me know if you need more details or if anything is missing in the announcement. Thanks!

bearND reassigned this task from bearND to Mholloway.Nov 19 2018, 7:28 AM
bearND added subscribers: JoeWalsh, Mholloway, bearND.

Thanks, @schoenbaechler. I haven't diffed the various versions of the body texts but it looks to me that the only difference between the countries are the country names, coffee price, and average donations, like we had last year. Is this correct? Last year we used some server side templating to insert those variables. Also we'll change the text to be HTML (turn the formatting into HTML tags).

I think @Mholloway is going to handle most of the MCS parts since he's already made some updates to @JoeWalsh's patch[1] so changed the assignee accordingly.

[1] https://gerrit.wikimedia.org/r/c/mediawiki/services/mobileapps/+/473248

schoenbaechler added a comment.EditedNov 19 2018, 12:11 PM

(...) the only difference between the countries are the country names, coffee price, and average donations, like we had last year. Is this correct?

Yes, exactly @bearND, the only change in terms of variables compared to last year is the %AVERAGE% in the US: 16.36. Here’s the complete overview of the variables:

%COUNTRY%
US: in the U.S.
GB: in the UK
IE: in Ireland
AU: in Australia
NZ: in New Zealand
CA: in Canada

%CURRENCY%
US: $
GB: £
IE: €
AU: $
NZ: $
CA: $

%AVERAGE%
US: 16.36
GB: 10
IE: 10
AU: 15
NZ: 15
CA: 15

%COFFEE%
US: 3
GB: 2
IE: 2
AU: 3
NZ: 3
CA: 3


@Mholloway: Please keep in mind that we’re going to review the announcement until this evening (Monday), November 19, 1800 UTC.


Thanks all!

Hi all,

The design and copy looks great! Thanks all for your work on this.

A couple of questions re frequency and timing :

#1. how often will these banners show up to a reader, are they set to only show up once, presumably the first time the reader visits the app during the campaign window?
#2. In the case we are in a position to end the entire English campaign earlier than the expected 12/19, could we change the adjust the end date late of the app campaign later on as well?

Thank you!

Sure @Pcoombe, updated the card’s description with the links you suggested!

@Mholloway: Please keep in mind that we’re going to review the announcement until this evening (Monday), November 19, 1800 UTC.

OK!

A couple of questions re frequency and timing :
#1. how often will these banners show up to a reader, are they set to only show up once, presumably the first time the reader visits the app during the campaign window?

I believe this is correct but the app teams should confirm.

#2. In the case we are in a position to end the entire English campaign earlier than the expected 12/19, could we change the adjust the end date late of the app campaign later on as well?

Yes.

Mholloway triaged this task as High priority.Nov 19 2018, 8:11 PM
JoeWalsh added a comment.EditedNov 19 2018, 9:23 PM

#1. how often will these banners show up to a reader, are they set to only show up once, presumably the first time the reader visits the app during the campaign window?

On iOS the card appears at the top of the feed until the campaign ends, then it moves down the feed with the rest of the content for that last day. If it's dismissed it goes away entirely.

On Android the card appears at the top of the feed until it's dismissed or the campaign ends.

Thank you @JoeWalsh for these clarifications. Just to be sure, for iOS does this mean a reader sees a banner every time he visits the app, but in different positions depending on how many times he has visited in the past?

Also, do we have the what we need in order to track donations coming from the app?

Thanks all!

@jrobell for iOS the user sees the banner at the top of the explore feed every time they visit the app. I was incorrect in my previous comment about it moving down the feed. It disappears when the the campaign is over or the user dismisses it, same as the Android app.

For tracking, the donation links have the utm_medium, utm_campaign, and utm_source variables set.

Hey @Mholloway or @JoeWalsh, quickly checking in since it’s the campaign’s end today. 🍾
Will the banners automatically come down tonight after 23:59:00 UTC ? Thanks for a quick update.

@schoenbaechler confirmed, the banners will come down tonight after 23:59:00 UTC

Mholloway closed this task as Resolved.Jan 15 2019, 11:40 PM