Page MenuHomePhabricator

wbgetentities has stopped returning content on Beta Cluster Commons
Closed, ResolvedPublic

Description

Result we used to get, and I still do locally on master:

{"entities":{"M17":{"pageid":17,"ns":6,"title":"File:IRC is Silence.png","lastrevid":43,"modified":"2018-12-04T20:32:44Z","type":"mediainfo","id":"M17","labels":{"es":{"language":"es","value":"Boo!"},"en-gb":{"language":"en-gb","value":"Isn't this amazing?"}},"statements":[]}},"success":1}

However we now just get:

{"entities":{"M59928":{"id":"M59928","missing":""}},"success":1}

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 5 2018, 8:14 PM

https://wikidata.beta.wmflabs.org/w/api.php?action=wbgetentities&format=jsonfm&props=info%7Clabels&ids=Q31 works as before, so this is likely to be something fun to do with our recent federation related config, at a guess. @Addshore or @Ladsgroup ?

Change 477847 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/WikibaseMediaInfo@master] CaptionPanel.refreshDataFromApi: Bail if the server things the item is blank now

https://gerrit.wikimedia.org/r/477847

daniel added a subscriber: daniel.Dec 6 2018, 4:04 PM

In the light of T211052, maybe the problem is that Wikibase is trying to read from the Main slot, instead of the mediainfo slot.

The only place this is configured (I thought) is https://noc.wikimedia.org/conf/highlight.php?file=InitialiseSettings-labs.php where 'entityNamespaces' => [ 'mediainfo' => '6/mediainfo' ], is set for Commons; however it's also configured for baseUri to point to https://commons.wikimedia.beta.wmflabs.org/entity/ which doesn't currently dereference, so maybe that's it?

daniel added a comment.Dec 6 2018, 5:17 PM

The only place this is configured (I thought) is https://noc.wikimedia.org/conf/highlight.php?file=InitialiseSettings-labs.php where 'entityNamespaces' => [ 'mediainfo' => '6/mediainfo' ], is set for Commons;

That looks ok... maybe that's not actually being used, somehow lost in a code path I failed to spot when introducing the slot config? Hard to tell without a debugger.

however it's also configured for baseUri to point to https://commons.wikimedia.beta.wmflabs.org/entity/ which doesn't currently dereference, so maybe that's it?

No, the base URI is only used when outputting RDF.

If this becomes urgent, I could probably dig in. I'd need good justification to spend time on this, though. In theory, this should be handled by the Wikidata team. On the other hand, there's a non-zero chance that this is something I screwed up :)

If this becomes urgent, I could probably dig in. I'd need good justification to spend time on this, though. In theory, this should be handled by the Wikidata team. On the other hand, there's a non-zero chance that this is something I screwed up :)

This is UBN. WBMI on Beta Commons is useless (no edits possible at all).

This is UBN. WBMI on Beta Commons is useless (no edits possible at all).

So the prio is set to "needs triage", it's in the wikidata inbox, the MediaInfo backlog.... well, I'll just take your word for it :)

Has anyone been able to reproduce this locally?

Jdforrester-WMF triaged this task as Unbreak Now! priority.Dec 10 2018, 10:00 PM

Sorry, good point.

Cormac and I are each unable to reproduce locally; our WBMI/WB interactions on master/master seem to still work. :-(

Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptDec 10 2018, 10:00 PM

I know next to nothing about how the beta instances work, I'll probably need to hack around in them directly... I'll probably need some help with that.

daniel added a comment.EditedDec 11 2018, 4:55 PM

I have a suspicion about this, but I want to dig some more to confirm. But if I am correct, this never worked on beta, at least not with MediaInfo in slots, with the config that is there now.

@Jdforrester-WMF is it possible that you remember this working on the dedicated labs test instance, but not on beta? That would be consistent with my idea of what is going on.

I have a suspicion about this, but I want to dig some more to confirm. But if I am correct, this never worked on beta, at least not with MediaInfo in slots, with the config that is there now.
@Jdforrester-WMF is it possible that you remember this working on the dedicated labs test instance, but not on beta? That would be consistent with my idea of what is going on.

It stopped working around the same time as the "federated Wikibase config" stuff landed in Beta (T204748), and then there was SlotRoleHandler and other complexities that mean that loading or editing hasn't worked in Beta for a fortnight right now, but we definitely had fully working WBMI <-> WB editing through the Web interface and API on Beta using slots.

Change 479006 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[operations/mediawiki-config@master] Wikibase: Temporarily disable federation (Beta only)

https://gerrit.wikimedia.org/r/479006

Change 479006 merged by jenkins-bot:
[operations/mediawiki-config@master] Wikibase: Temporarily disable federation (Beta only)

https://gerrit.wikimedia.org/r/479006

Mentioned in SAL (#wikimedia-operations) [2018-12-11T18:00:31Z] <jforrester@deploy1001> Synchronized wmf-config/Wikibase.php: T211237 Hot-deploy disabling Wikibase federation, unused except in Beta Cluster (duration: 00m 52s)

Jdforrester-WMF closed this task as Resolved.Dec 11 2018, 7:25 PM

Marking as Resolved. Will re-open T204748 instead, pending on Daniel's comments about needing to change things in Wikibase. :-(

Change 479498 had a related patch set uploaded (by Daniel Kinzler; owner: Daniel Kinzler):
[mediawiki/extensions/Wikibase@master] Protect againbst a foreign repo being declared with the empty prefix.

https://gerrit.wikimedia.org/r/479498

Change 479498 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Protect against a foreign repo being declared with the empty prefix.

https://gerrit.wikimedia.org/r/479498

Change 477847 abandoned by Jforrester:
CaptionPanel.refreshDataFromApi: Bail if the server things the item is blank now

Reason:
Let's not do this for now.

https://gerrit.wikimedia.org/r/477847

greg added a project: Multimedia.Mar 7 2019, 10:59 PM