Page MenuHomePhabricator

Remove AMC Article/Talk tabs from Main page
Closed, ResolvedPublic2 Story Points

Description

Description

By default the AMC Article/Talk tabs are appearing on the Main page. While not technically a Special page, currently the main page serves as a distinct landing page experience, and is therefore treated somewhat differently from other article pages. For example, the main page does not have the article toolbar that other article pages do (with the language switcher, edit icon, etc). Following from this precedent, and assuming the need to visit the Talk page of the main page isn't significant, it makes sense to remove the AMC Article/Talk tabs from Main page.

main pagemain page talk
Main pageTalk:Main page

Design notes

@Jdlrobson mentioned being able to fix the extra-large gap between the greeting and the main page content in the process of doing this task. If we are able to address that, here is a corrected version for reference:

currentcorrected

QA

Test on reading web staging

  1. Verify that talk tabs are showing with AMC enabled on article pages e.g. Singapore
  2. Verify that talk tabs are showing with AMC enabled on talk pages e.g. Talk:Singapore
  3. Verify that talk tabs are not showing with AMC enabled on Main page
  4. Verify that talk tabs are not showing with AMC enabled on talk page of Main page (link)
  5. Verify that talk tabs are not showing with AMC disabled on Main page

QA Results

StepStatusDetails
1✅ PassedT214724#4962141
2✅ PassedT214724#4962141
3✅ PassedT214724#4962141
4✅ PassedT214724#4970372
5✅ PassedT214724#4962141

QA Results:Production (arwiki)

StepStatusDetails
1✅ PassedT214724#5065056
2✅ PassedT214724#5065056
3✅ PassedT214724#5065056
4✅ PassedT214724#5065056
5✅ PassedT214724#5065056

Event Timeline

alexhollender triaged this task as High priority.Jan 25 2019, 8:19 PM
alexhollender created this task.
Restricted Application removed a project: Patch-For-Review. · View Herald TranscriptJan 25 2019, 8:19 PM

rootpage_MainPage could be used to distinguish the main page in CSS. There is also a main page stylesheet.

phuedx added a comment.Feb 5 2019, 5:08 PM

There is also a main page stylesheet.

The mobile main page stylesheet is defined by MobileFrontend. It's a magic RL module that loads the MediaWiki:MobileMainPage.css page as a CSS asset.

Jdlrobson set the point value for this task to 2.Feb 5 2019, 5:11 PM

Also this is AMC only.. not main page. That might impact what we do here. We might prefer a server side HTML solution.

There's some discussion about whether it would be better to hide the tabs in CSS or never send the HTML in the first place. The benefit of the former is the change is made only to presentation. The benefit of the latter is no possible confusion for screen readers and improved bandwidth.

Change 488481 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/skins/MinervaNeue@master] Talk tabs disabled on main page

https://gerrit.wikimedia.org/r/488481

Change 488481 merged by jenkins-bot:
[mediawiki/skins/MinervaNeue@master] Talk tabs disabled on main page

https://gerrit.wikimedia.org/r/488481

Jdlrobson reassigned this task from Jdlrobson to Edtadros.Feb 13 2019, 8:16 PM
Jdlrobson updated the task description. (Show Details)
Edtadros updated the task description. (Show Details)Feb 18 2019, 5:25 PM
Edtadros updated the task description. (Show Details)
Edtadros added a comment.EditedFeb 18 2019, 5:35 PM

Test Result

Status:Not Complete
OS: macOS Mojave
Browser: Chrome DevTools Device Emulator (iPhone X)

Test Artifact(s):

  1. Verify that talk tabs are showing with AMC enabled on article pages e.g. Singapore Status: ✅ PASS

    AMC Disabled:


    AMC Enabled:
  1. Verify that talk tabs are showing with AMC enabled on talk pages e.g. Talk:Singapore Status: ✅ PASS

    AMC Disabled:


    AMC Enabled:
  1. Verify that talk tabs are not showing with AMC enabled on Main page Status: ✅ PASS

    AMC Enabled:
  1. Not Tested Yet
  1. Verify that talk tabs are not showing with AMC disabled on Main page Status: ✅ PASS (see T214724#4962164)

    AMC Disabled:
Edtadros updated the task description. (Show Details)Feb 18 2019, 5:36 PM
Edtadros updated the task description. (Show Details)
Edtadros reassigned this task from Edtadros to Jdlrobson.Feb 18 2019, 5:42 PM
Edtadros added a subscriber: Edtadros.

@Jdlrobson Can you take a look at the QA steps 3 and 4. When I toggle AMC off I see the Discussion button. When I toggle it on, I don't see it. It seems like a Fail, but I wanted to make sure the QA steps were correct.

@Jdlrobson Can you take a look at the QA steps 3 and 4. When I toggle AMC off I see the Discussion button. When I toggle it on, I don't see it. It seems like a Fail, but I wanted to make sure the QA steps were correct.

Good catch. I think this is okay (the discussion button is available on all pages when outside of AMC mode).

Edtadros updated the task description. (Show Details)Feb 19 2019, 12:01 AM
Edtadros reassigned this task from Jdlrobson to ovasileva.Feb 19 2019, 12:05 AM

I updated the QA comments in the description and the test artifacts in T214724#4962141 to reflect the clarification from T214724#4962164 for Step #4.

We're ready to resolve here. The questions remains that we do have a small inconsistency where there is a talk page button for non-AMC users and not one for AMC users. @alexhollender - are we okay with this or do we want to follow up with another task for adding the button back to the bottom of the page?

My apologies for not thinking about this earlier. I do think it's necessary to have some way to get to Talk page of the Main page, although I'm not sure where that falls in the priority of things. I assume it's relatively low, although a counter point I can think of is that since the Main page is so visible, editors might notice that in AMC mode there is no discussion button, and potentially take a less favorable opinion of the feature. One way or another I'm fine with moving this task along, given the current state. Thoughts @Jdlrobson @ovasileva?

This comment was removed by Jdlrobson.
ovasileva closed this task as Resolved.EditedFeb 19 2019, 3:28 PM

My apologies for not thinking about this earlier. I do think it's necessary to have some way to get to Talk page of the Main page, although I'm not sure where that falls in the priority of things. I assume it's relatively low, although a counter point I can think of is that since the Main page is so visible, editors might notice that in AMC mode there is no discussion button, and potentially take a less favorable opinion of the feature. One way or another I'm fine with moving this task along, given the current state. Thoughts @Jdlrobson @ovasileva?

Let's close this for now and follow up on adding the button in T216514: Add talk button to AMC main page

Change 491655 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/skins/MinervaNeue@master] Talk is at bottom of main page

https://gerrit.wikimedia.org/r/491655

Jdlrobson reopened this task as Open.EditedFeb 19 2019, 11:57 PM

Im still seeing tabs on the talk page of the main page in AMC mode:
https://reading-web-staging.wmflabs.org/w/index.php?title=Talk:Main_Page&mobileaction=toggle_view_mobile

Is this intended behaviour?

@Jdlrobson good catch...looks like we missed that as a QA step. Adding it now.

@Jdlrobson good catch...looks like we missed that as a QA step. Adding it now.

@alexhollender - although, is this such a bad thing given it's the talk page? The talk page also has the actions bar as well, so in terms of consistency it might make more sense for it to mirror other talk pages.

@Jdlrobson good catch...looks like we missed that as a QA step. Adding it now.

@alexhollender - although, is this such a bad thing given it's the talk page? The talk page also has the actions bar as well, so in terms of consistency it might make more sense for it to mirror other talk pages.

@ovasileva interesting point. I guess it could go either way. To have the tabs on the talk page but not the page itself is a bit inconsistent — it becomes kind of this hybrid of AMC and non-AMC, which might be harder to test and keep track of (?). I'm not opposed to leaving it though and revisiting this later if we feel we need to.

Change 491655 merged by jenkins-bot:
[mediawiki/skins/MinervaNeue@master] Talk is at bottom of main page

https://gerrit.wikimedia.org/r/491655

Jdlrobson reassigned this task from ovasileva to Edtadros.EditedFeb 20 2019, 9:21 PM

Back to you.
There are a few new QA instructions
See: https://phabricator.wikimedia.org/transactions/detail/PHID-XACT-TASK-yxcovnrdyniyvf4/
Please test on reading web staging (just updated)

Also note there is some overlap with T216514 so it might make sense to merge the QA instructions (and maybe that task) into this card.

Edtadros reassigned this task from Edtadros to ovasileva.Feb 21 2019, 12:16 AM

Test Result

Status:Not Complete
OS: macOS Mojave
Browser: Chrome DevTools Device Emulator (iPhone X)

Test Artifact(s):

  1. Verify that talk tabs are not showing with AMC enabled on talk page of Main page Status: ✅ PASS

    URL tested: http://reading-web-staging.wmflabs.org/wiki/Talk:Main_Page

    AMC Disabled:


    AMC Enabled:
  • This was tested both opted in and out of Beta.

THANKS @Jdlrobson! updating the AC, and QA results was very helpful!

Edtadros updated the task description. (Show Details)Feb 21 2019, 12:19 AM
ovasileva closed this task as Resolved.Feb 21 2019, 9:25 AM

all done

Test Result:Production

Status: ✅ PASS
OS: iOS
Browser: Chrome browser on (iPhone XS Max)

Test Artifact(s):

  1. Verify that talk tabs are showing with AMC enabled on article pages Status: ✅ PASS

  1. Verify that talk tabs are showing with AMC enabled on talk pages Status: ✅ PASS

  1. Verify that talk tabs are not showing with AMC enabled on Main page Status: ✅ PASS

  1. Verify that talk tabs are not showing with AMC enabled on talk page of Main page Status: ✅ PASS

  1. Verify that talk tabs are not showing with AMC disabled on Main page Status: ✅ PASS

Edtadros updated the task description. (Show Details)Mar 28 2019, 9:28 AM