Page MenuHomePhabricator

Excessive white space at the end of article/section on iOS
Closed, ResolvedPublic

Description

As described in T213429#4954219 and confirmed as an issue by @cmadeo in testing there's excess white space. Based on previous conversations, I don't know if this is something that we can remedy, however, I'm documenting here as a known issue.

Details

Related Gerrit Patches:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 6 2019, 1:48 PM

Quoting from the other task for context:

Tested this with iOS and Android on:

  • mobile Firefox (most up to date version)
  • mobile Safari (most up to date version)
  • mobile Chrome (most up to date version)

Everything is behaving as I'd expect.
One small tweak (that is really a nit) is that when you get into the editing view, and scroll to the bottom of the section, there's a large amount of extra white space. Is this avoidable?

@iamjessklein The whitespace is required to allowed you to scroll down far enough such that the last line of text can appear the above the onscreen keyboard (the height of which we cannot know, so must assume to be nearly as tall as the screen). If you have found a situation on a particular device where it appears there is too much whitespace we can look into that.

Okay, I just tried this with the keyboard up and it still looks a touch excessive to me ...

Testing on Chrome with user agent set to iPhone I get just enough whitespace to push the last line to the top of the screen, which is correct:

matmarex renamed this task from Excessive white space after article completes in section editing to Excessive white space at the end of article/section on iOS.Mar 19 2019, 1:28 PM
matmarex claimed this task.Mar 19 2019, 2:07 PM
matmarex edited projects, added VisualEditor (Current work); removed VisualEditor.

It appears that we no longer need this padding with the new approach to scrolling on iOS!

Change 497483 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/VisualEditor@master] MobileArticleTarget: Remove padding below the surface on iOS

https://gerrit.wikimedia.org/r/497483

Change 497483 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] MobileArticleTarget: Remove padding below the surface on iOS

https://gerrit.wikimedia.org/r/497483

Esanders moved this task from Inbox to Low Priority on the Editing QA board.Apr 9 2019, 12:45 PM
marcella edited projects, added Skipped QA; removed Editing QA.
ppelberg closed this task as Resolved.Aug 28 2019, 3:53 AM
Ryasmeen reopened this task as Open.EditedSep 5 2019, 11:44 PM
Ryasmeen added a subscriber: Ryasmeen.

I can still reproduce this issue on Beta. Showed it to @ppelberg today, so reopening it.

Looks like we regressed it with the toolbar changes. The existing code should check for whether the keyboard is active, but it actually checks for which toolbar is active – which was equivalent before, but now there is only a single toolbar, so the check does nothing.

Change 535253 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[VisualEditor/VisualEditor@master] ve.ui.Surface: Fix check for active virtual keyboard in #adjustVisiblePadding

https://gerrit.wikimedia.org/r/535253

Change 535253 merged by jenkins-bot:
[VisualEditor/VisualEditor@master] ve.ui.Surface: Fix check for active virtual keyboard in #adjustVisiblePadding

https://gerrit.wikimedia.org/r/535253

Change 537178 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (a9d533280)

https://gerrit.wikimedia.org/r/537178

Change 537178 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (81e2e57a5)

https://gerrit.wikimedia.org/r/537178

matmarex removed a project: Skipped QA.

Still reproduce on Beta when I tap at the end of the article, was testing on the same article.

Ryasmeen moved this task from QA to Stalled/Waiting on the VisualEditor (Current work) board.

@Ryasmeen If that's only when the keyboard is open, then that is unavoidable on iOS, IIRC we need it for the toolbar hacks (T218414). When the keyboard is closed, the issue should be fixed.

@Ryasmeen If that's only when the keyboard is open, then that is unavoidable on iOS, IIRC we need it for the toolbar hacks (T218414). When the keyboard is closed, the issue should be fixed.

Ok, in that case, it's fixed :) Moving to PM review column.

ppelberg closed this task as Resolved.Sat, Nov 23, 1:59 AM
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptSat, Nov 23, 1:59 AM