Page MenuHomePhabricator

Beta cluster: MassMessage fails with PHP fatal error because of Declaration of JobQueueEventBus::doAck() must be compatible with that of JobQueue::doAck()
Closed, ResolvedPublic

Description

When attempting to send a mass message on the english beta cluster, an error is returned:

PHP fatal error: Declaration of JobQueueEventBus::doAck() must be compatible with that of JobQueue::doAck()

Steps to reproduce

  • Go to Special:MassMessage
  • Attempt to send a message

Note: as of 18:09 10 April 2019 (UTC), MassMessage still works on the normal wikipedia (example)

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 10 2019, 9:26 PM
DannyS712 updated the task description. (Show Details)Apr 10 2019, 9:28 PM
Legoktm triaged this task as Unbreak Now! priority.Apr 10 2019, 11:58 PM
Legoktm edited projects, added EventBus; removed MassMessage.
Legoktm added a subscriber: Legoktm.

I haven't verified myself, but if this is an issue, it's UBN.

Restricted Application added a project: Analytics. · View Herald TranscriptApr 10 2019, 11:58 PM
Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald Transcript
Legoktm renamed this task from Beta cluster: MassMessage fails with PHP fatal error to Beta cluster: MassMessage fails with PHP fatal error because of Declaration of JobQueueEventBus::doAck() must be compatible with that of JobQueue::doAck().Apr 11 2019, 12:32 AM
kostajh lowered the priority of this task from Unbreak Now! to High.Apr 11 2019, 4:06 PM

Lowering priority, if it's still broken please change the priority again.

fdans moved this task from Incoming to Radar on the Analytics board.Apr 11 2019, 4:45 PM

@kostajh It appears to work now - See https://en.wikipedia.beta.wmflabs.org/w/index.php?title=Special:Log&logid=138535 for a test mass message that didn't have the error. But, it wasn't actually delivered, so there may still be an issue.

But, it wasn't actually delivered, so there may still be an issue.

That's probably because of T215339: No jobs running on beta cluster

@kostajh According to @mobrovac in T215339#5126319, the job was successfully executed. However, the mass message I tried to send still failed. Looking through the mass message log (https://en.wikipedia.beta.wmflabs.org/wiki/Special:Log/massmessage), the entry after my attempt to send a message is https://en.wikipedia.beta.wmflabs.org/w/index.php?title=Special:Log&logid=138722, which reports that the message wasn't sent to "Special:" because of the namespace. However, the only target that I specified was "User talk:DannyS712 test2". I no longer to an error message when trying to send a mass message, but the message is still not sent.

Krinkle closed this task as Resolved.EditedApr 20 2019, 12:02 AM
Krinkle claimed this task.
Krinkle added a subscriber: Krinkle.
  • The task description describes a fatal error with the general logic of running jobs. It was caused by fc5d51f1293 9 days ago, and was fixed the same day with 0091dde3b.
  • A later comment refers to a separate issue specific to Beta Cluster, where jobs were silently disabled for a while. Details at T215339, since then resolved.
  • Comment T220662#5126444 refers to another issue relating to title corruption. This was also reported at T221368 and fixed yesterday. Any jobs affected by the title corruption within Beta are lost. Production wikis (aside from test wikis and mw.org) were unaffected.