Page MenuHomePhabricator

MassMessage failing with "to Special: was skipped because target was in a namespace that cannot be posted in"
Closed, ResolvedPublic

Description

MassMessage is unable to deliver messages at all. It interprets all delivery targets as just Special:

All logs contain Delivery of "[Subject line]" to Special: was skipped because target was in a namespace that cannot be posted in
and Special: is redlinked.

Example Logs:

Other newsletters are encountering this too, per

I also tried with 2 formats of delivery-target lists, and delivering one locally just from/to Mediawiki.org, but all tests had the same problem.

Details

Related Gerrit Patches:
mediawiki/extensions/MassMessage : wmf/1.34.0-wmf.1MassMessageJob: Set '$this->title' after constructor call
mediawiki/extensions/MassMessage : masterMassMessageJob: Set '$this->title' after constructor call

Event Timeline

Quiddity created this task.Apr 23 2019, 2:30 AM
Restricted Application added subscribers: Liuxinyu970226, Aklapper. · View Herald TranscriptApr 23 2019, 2:30 AM
Quiddity triaged this task as Unbreak Now! priority.Apr 23 2019, 2:38 AM
Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptApr 23 2019, 2:38 AM
DannyS712 added subscribers: Krinkle, DannyS712.

See also T220662#5126444 (failing in the beta cluster 3 days ago) and T220662#5126459, where @Krinkle reported that the issue had been solved in T221368.

Elitre added a subscriber: Elitre.Apr 23 2019, 6:06 AM

@Krinkle can you please LMK who should be looking into this? I need to send mass messages for the upcoming Board selection and UBN doesn't even begin to reflect the urgency :p Thanks for your understanding!

Stryn added a subscriber: Stryn.Apr 23 2019, 1:48 PM
Krinkle claimed this task.Apr 23 2019, 3:53 PM
Krinkle added a subscriber: Legoktm.

@Esanders Feedback needed please and thank you!

Given the time of day, I couldn't find either Aaron or Lego to look into this yet. So I've started investigating now.

This appears to be an unfortunate coincidence due to the MassMessage extension using the title parameter internally for Job serialisation for something different than what JobQueue now uses it for.

The good news is that this means the issue is isolated fully to MassMessage and that we know how to fix it.

The bad news is, it means we didn't catch it as part of general testing as the extension's jobs are fired far too infrequently for that to have shown up during train deployments. This is particularly unfortunate because, despite being a separate issue technically, this chain of JobQueue issues actually started with a report from the Beta Cluster about the MassMessage extension. And after 3 unrelated general JobQueue issues, there is now a fourth one specific to it.

Change 505806 had a related patch set uploaded (by Krinkle; owner: Krinkle):
[mediawiki/extensions/MassMessage@master] MassMessageJob: Set '$this->title' after constructor call

https://gerrit.wikimedia.org/r/505806

@Esanders Feedback needed please and thank you!

I don't remember working on MassMessage recently?

@Esanders (Sorry, I'd noted it in IRC, but should've repeated here) Editing team is official code stewards per https://www.mediawiki.org/wiki/Developers/Maintainers

@Esanders (Sorry, I'd noted it in IRC, but should've repeated here) Editing team is official code stewards per https://www.mediawiki.org/wiki/Developers/Maintainers

See also T93110#4576684, and revision, and revision, and revision. It appears James gave the previously un-stewarded extension a home in the Editing team during FY2015-2016. See also Code stewardship reviews.

Change 505846 had a related patch set uploaded (by Krinkle; owner: Krinkle):
[mediawiki/extensions/MassMessage@wmf/1.34.0-wmf.1] MassMessageJob: Set '$this->title' after constructor call

https://gerrit.wikimedia.org/r/505846

Change 505806 merged by jenkins-bot:
[mediawiki/extensions/MassMessage@master] MassMessageJob: Set '$this->title' after constructor call

https://gerrit.wikimedia.org/r/505806

Change 505846 merged by jenkins-bot:
[mediawiki/extensions/MassMessage@wmf/1.34.0-wmf.1] MassMessageJob: Set '$this->title' after constructor call

https://gerrit.wikimedia.org/r/505846

Krinkle closed this task as Resolved.Apr 23 2019, 7:01 PM
Krinkle reopened this task as Open.
Krinkle edited projects, added Performance-Team; removed Patch-For-Review.
Quiddity lowered the priority of this task from Unbreak Now! to Needs Triage.Apr 23 2019, 7:11 PM

Huge thanks to Krinkle for fixing this. :-) Tech News has now been delivered. I've unset the priority, accordingly.

Krinkle closed this task as Resolved.Apr 23 2019, 7:38 PM

Thanks, Krinkle. I owe you a bucket of ice cream or something.