Page MenuHomePhabricator

[Bug] Infobox in "Iraq war" article on enwiki not full width on mobile-html
Closed, ResolvedPublic

Description

Steps to Reproduce

  1. Open https://en.wikipedia.org/api/rest_v1/page/mobile-html/Iraq_War
  2. Collapse the infobox in the paragraph starting with "In October 2002"
  3. Resize the window to be about 500pt wide

Expected Results

Collapsed infobox is full width

Actual Results

Collapsed infobox is floating to the right

Event Timeline

JoeWalsh created this task.Apr 23 2019, 8:18 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 23 2019, 8:18 PM

Is this about Page Content Service , or which codebase should be associated?

Aklapper renamed this task from [Bug] Infobox in "Iraq war" aricle on enwiki not full width on mobile-html to [Bug] Infobox in "Iraq war" article on enwiki not full width on mobile-html.Apr 23 2019, 8:41 PM
LGoto triaged this task as Normal priority.Apr 24 2019, 3:34 PM
LGoto moved this task from Needs triage to Backlog on the Product-Infrastructure-Team-Backlog board.
JoeWalsh reopened this task as Open.May 3 2019, 6:40 PM
JoeWalsh added a subscriber: bearND.

@bearND this problem still exists after the fix for T217417

I see now. I forgot to close the table earlier.

Mhurd added a subscriber: Mhurd.EditedMay 17 2019, 10:20 PM

This is happening on mobile web as well. PageLib/PCS may not be the best places to fix this.

I agree with @Mhurd that the table doesn't look right on mobile web when using any of the iPhone resolutions. Not sure if the solution is to make the table full screen in mobile web, though.

@Jdlrobson it looks like this change https://en.wikipedia.org/w/index.php?title=MediaWiki:Mobile.css&diff=865253065&oldid=864403077 leads to this issue on mobile web

Without that override for mobile-float-reset there's an inline style of float: right on the div inserted by the template around the infobox, conflicting with

@media all and (max-width:720px) {
    .content table {
        display: block;
        width: 100% !important
    }
}

from minerva. It looks like the solution proposed there is to request that the template be updated to use TemplateStyles. Is that the suggested fix in this case as well?

Jdlrobson added a subscriber: phuedx.

The correct solution is to remove those inline styles and move the floats into classes. I've made an edit request here: https://en.wikipedia.org/wiki/Module_talk:Infobox_military_conflict#Edit_request%3A_Mobile_friendly_version_of_this_template

@phuedx @JoeWalsh it would be great if we could determine some kind of process for making these change requests with support from community liasons to get them to the correct people.

Jdlrobson closed this task as Resolved.Jul 1 2019, 10:00 PM
Jdlrobson claimed this task.

The edit has been made and this should now be fixed now (Thanks to @Frietjes). MCS is still caching old HTML so you may need to invalidate.

@phuedx @JoeWalsh it would be great if we could determine some kind of process for making these change requests with support from community liasons to get them to the correct people.

Also see (non-public) https://office.wikimedia.org/wiki/Community_Relations#Support

phuedx added a comment.Jul 2 2019, 8:45 AM

💪

@phuedx @JoeWalsh it would be great if we could determine some kind of process for making these change requests with support from community liasons to get them to the correct people.

Is there a list of such requests available? If so, we could go through them with CR and see if there are parts of the process that could be streamlined.