Page MenuHomePhabricator

sticky Save button bar on Special:Preferences is jumping in Firefox
Closed, InvalidPublic

Description

Editing preferences:

  • In firefox using the mouse scroll wheel the save button is scrolled which the page. Every time the cursor hits an input field the save button bar jumps to the bottom of the page.
  • Using the scrollbar on the right the save button bar jumps up and down in a random way while scrolling and holding the mouse button down. The bar jumps to the bottom of the page (where it should be sticky) only when the mouse button is released.

Upstream ticket: https://bugzilla.mozilla.org/show_bug.cgi?id=1564071

Screenshots:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 4 2019, 12:23 PM
Aklapper renamed this task from sticky save button bar in preferences is jumping in firefox to sticky Save button bar on Special:Preferences is jumping in Firefox.Jun 5 2019, 10:26 AM

I faced the same problem in Mozilla Firefox v67.0.4 x64.
Try the follow CSS:

.mw-prefs-buttons {
    position: absolute;
}

Also, you can to consider using of window.onscroll event.

Aklapper updated the task description. (Show Details)
Aklapper moved this task from Backlog to Reported Upstream on the Upstream board.
Aklapper updated the task description. (Show Details)
Aklapper added subscribers: Schnark, Wargo.

Should be fixed in Firefox 70: https://hg.mozilla.org/mozilla-central/rev/67d64b7bb76b

Proposing to close this task as invalid, as the problem is nothing to fix in code that is controlled by Wikimedia.

Aklapper closed this task as Invalid.Jul 31 2019, 10:31 PM
awight added a comment.Nov 1 2019, 9:20 AM

Should be fixed in Firefox 70: https://hg.mozilla.org/mozilla-central/rev/67d64b7bb76b
Proposing to close this task as invalid, as the problem is nothing to fix in code that is controlled by Wikimedia.

I see the logic behind this, but with at least 8 releases of Firefox affected by the bug, maybe we should consider a workaround? I suspect that the current CSS is faulty in other ways, because Chrome-based browser tests also run into an issue where the save bar obscures buttons, meaning that Chrome is not correctly calculating the visible content area.

awight updated the task description. (Show Details)Nov 1 2019, 9:20 AM