Page MenuHomePhabricator

Moved Wikidata Item link to Other Projects might break gadgets
Closed, ResolvedPublic

Description

In T66315: Move "Data item" link outside of sidebar toolbox, the Wikidata Item link has been moved from Toolbox to In Other Projects section in the side bar.

That move currently misses 2 things that might cause undesirable effects in different wikis:

  1. missing accessKey binding
  2. missing id='t-wikibase'. Check this list for gadgets that are binding to that element.

We might either:

  1. revert (and backport) that change and have more time to prepare for it
  2. find a way to retain the same attributes previously were available to users and gadgets on that link

If we don't manage to do the 2nd option until tomorrow, we go with the 1st option.

Event Timeline

alaa_wmde triaged this task as High priority.Aug 21 2019, 1:23 PM
alaa_wmde created this task.
alaa_wmde updated the task description. (Show Details)Aug 21 2019, 1:29 PM

@alaa_wmde - if you're blocking the train then this should be UBN

@zeljkofilipin: thoughts seen as you're conducting this week

Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptAug 21 2019, 1:29 PM

https://gerrit.wikimedia.org/r/c/mediawiki/extensions/Wikibase/+/531479 backporting this would fix most cases. I don't think we should care for the rest. @alaa_wmde and @WMDE-leszek what do you think?

@Ladsgroup yeah probably.. There might still some that might break because the id now is on the a tag and not a wrapper element like it used to be.

If there's a way to put the id on a wrapper span (might not exist yet) it might avoid those cases too. Not sure if there are more cases, and probably won't have enough time to check for them before tomorrow's train.

@sarhan.alaa actually the ID is still on the wrapping <li> element, see the HTML snippet copied from beta: https://en.wikipedia.beta.wmflabs.org/wiki/Dog:

<li id="t-wikibase" class="wb-otherproject-link wb-otherproject-wikibase-item">
    <a href="https://wikidata.beta.wmflabs.org/wiki/Special:EntityPage/Q500973" title="Link to connected data repository item [Alt+Shift+g]" accesskey="g">Wikidata item</a>
</li>

so in this regard that should be okay?

lowering the priority as the expected fixed landed on group1 wikis. This should no longer block the train. The task will be closed once we've confirmed there are no issues discovered as the train proceeds.

WMDE-leszek lowered the priority of this task from Unbreak Now! to High.Aug 21 2019, 6:16 PM
sarhan.alaa added a comment.EditedAug 21 2019, 6:51 PM

@WMDE-leszek that's great! I remember seeing it differently locally when I tested adding the id back a while back, or maybe I just assumed it will land on the a tag from the code (that seems to do some magic there). Either way, I should've waited and checked on beta :)

We should then be fine.. thanks for patching it up quickly!

FYI T66315#5430357 " the "t-wikibase" id is not only used in style sheets but in JavaScript scripts, too. Maybe the new wb-otherproject-wikibase-item class has to be added to other style sheets"

Revert patch (sorry forgot to tag this ticket and want to avoid restarting CI again now):
https://gerrit.wikimedia.org/r/c/mediawiki/extensions/Wikibase/+/531659

We are going to revert and backport to wmf.19 today https://wikitech.wikimedia.org/wiki/Deployments#deploycal-item-20190822T1100

alaa_wmde raised the priority of this task from High to Unbreak Now!.Aug 22 2019, 11:46 AM

We are backporting the revert in today's mid-day swat, now

Is this resolved? Train window is in 30 minutes.

Is this resolved? Train window is in 30 minutes.

No, it isn't.

Tarrow closed this task as Resolved.Aug 22 2019, 1:30 PM
Tarrow claimed this task.

@Lea_Lacroix_WMDE @WMDE-leszek We have, after some delay (sorry), merged the revert patch.