Page MenuHomePhabricator

[ICONS] editor-loading header
Closed, ResolvedPublic

Description

There are two issues with the editor-loading header:

  1. The word loading is not vertically centered in the header
  2. There is a gap at the bottom of the header (maybe related to T215426?)

Developer notes

Seems to be caused by a line-height applying to the icon that should be removed:

.ve-mobile-fakeToolbar .mw-ui-icon-mf-spinner {
    /* line-height: 3em; */

Event Timeline

Jdlrobson updated the task description. (Show Details)
ovasileva triaged this task as Normal priority.Sep 18 2019, 9:41 AM

The word loading is not centered in the header

This is as designed.

There is a gap at the bottom of the header (maybe related to T215426?)

This is working fine for me, could be an iOS issue? Or maybe already fixed?

The word loading is not centered in the header

This is as designed.

It is not vertically centered with the X. I assume that is not intended?

waiting on some feedback from Ed.

ppelberg moved this task from To Triage to Up next on the VisualEditor board.Tue, Sep 24, 3:29 PM

Change 538934 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/MobileFrontend@master] mobile.init/fakeToolbar: Tweak vertical centering

https://gerrit.wikimedia.org/r/538934

Change 538934 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] mobile.init/fakeToolbar: Tweak vertical centering

https://gerrit.wikimedia.org/r/538934

This patch should fix vertical centering (issue 2), but I don't know if it does anything about the gap in the border (issue 1), because I found no way to reproduce that one.

Patch is on beta cluster. Does this resolve the issue you reported @alexhollender ?

Patch is on beta cluster. Does this resolve the issue you reported @alexhollender ?

It appears to be fixed:

Jdlrobson moved this task from Needs triage to MinervaNeue on the Mobile board.Thu, Sep 26, 12:11 AM
ovasileva closed this task as Resolved.Thu, Sep 26, 4:37 PM

Looks good, resolving

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptThu, Sep 26, 4:37 PM