Page MenuHomePhabricator

Stop using PHP5 versions of ruflin/elastica and elasticsearch/elasticsearch
Closed, ResolvedPublic

Description

We no longer need HHVM support, so we shouldn't need those special versions of the libraries :)

Event Timeline

Reedy created this task.Oct 10 2019, 11:33 PM
Restricted Application added a project: Discovery-Search. · View Herald TranscriptOct 10 2019, 11:33 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Change 542259 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/extensions/Elastica@master] Stop using PHP5 versions of ruflin/elastica and elasticsearch/elasticsearch

https://gerrit.wikimedia.org/r/542259

Change 542263 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/vendor@master] Stop using PHP5 versions of ruflin/elastica and elasticsearch/elasticsearch

https://gerrit.wikimedia.org/r/542263

Change 542263 abandoned by Reedy:
Stop using PHP5 versions of ruflin/elastica and elasticsearch/elasticsearch

Reason:
Dupe change-id

https://gerrit.wikimedia.org/r/542263

Change 542264 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/vendor@master] Stop using PHP5 versions of ruflin/elastica and elasticsearch/elasticsearch

https://gerrit.wikimedia.org/r/542264

Change 542264 merged by jenkins-bot:
[mediawiki/vendor@master] Stop using PHP5 versions of ruflin/elastica and elasticsearch/elasticsearch

https://gerrit.wikimedia.org/r/542264

Change 542259 merged by jenkins-bot:
[mediawiki/extensions/Elastica@master] Stop using PHP5 versions of ruflin/elastica and elasticsearch/elasticsearch

https://gerrit.wikimedia.org/r/542259

Change 542283 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/extensions/Elastica@REL1_34] Stop using PHP5 versions of ruflin/elastica and elasticsearch/elasticsearch

https://gerrit.wikimedia.org/r/542283

Change 542283 merged by jenkins-bot:
[mediawiki/extensions/Elastica@REL1_34] Stop using PHP5 versions of ruflin/elastica and elasticsearch/elasticsearch

https://gerrit.wikimedia.org/r/542283

Reedy added a comment.Oct 11 2019, 1:34 AM

I think the only thing that is outstanding, but not tagged to this task is the commit to bump CirrusSearch to use the Elastica version with the versions of the libraries that don't require >= 5.6.99 - https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/CirrusSearch/+/542270/ but Cindy doesn't like it, for reasons I don't quite understand

If anyone on Discovery-Search can help, that'd be appreciated (or do we just ignore cindy?)

Reedy closed this task as Resolved.Oct 11 2019, 1:44 AM
Reedy claimed this task.

Version bump reverted, as it's tracking ruflin/elastica versions

Reedy reopened this task as Open.Oct 11 2019, 2:19 AM

Except, it still clung onto the old versions...

Change 542306 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/vendor@master] Actually force elasticsearch/elasticsearch and ruflin/elastica back to release versions, not PHP5-ified versions

https://gerrit.wikimedia.org/r/542306

Change 542306 merged by jenkins-bot:
[mediawiki/vendor@master] Actually force elasticsearch/elasticsearch and ruflin/elastica back to release versions, not PHP5-ified versions

https://gerrit.wikimedia.org/r/542306

Mentioned in SAL (#wikimedia-releng) [2019-10-11T17:57:59Z] <Krinkle> Click "Disable Publishing" on extension-Elastica Phab mirror, T235233, T143162

Reedy closed this task as Resolved.Oct 11 2019, 7:55 PM

Sorted now. Some possible bumps to be done, but that’s a different problem