Page MenuHomePhabricator

Disable mobile beta mode (for now)
Closed, ResolvedPublic3 Estimate Story Points

Description

We should disable the beta mode and its features via a config change to simplify the mobile site going into desktop refresh.

Motivation

The mobile beta mode currently has 2 features enabled:

  1. jump to top (added Sept 2015 Bug: T98701, Change-Id: I11a8ccb1e701644dcb328bfec9fe346f75ae1b71)
  2. categories (added January 2015, Bug:T86496) available only to logged in users

The last time features were promoted from beta to stable was an addition of the contributions button to the main menu in August 2016 T141787). On top of this a share feature was added in Oct 2018 but never enabled for users.

We should disable the beta for the time being for the following reasons:

  • The addition of the share feature (and it's lack of enabling in production) suggests that the beta is not well understood.
  • The fact two features added in 2015 have not been promoted to stable in 4 years yet are subject to bugs is concerning
  • It's hard to justify maintaining the code for this feature given its lack of use and in particular the addition of the new AMC mode.
  • About 100 people are added to beta a day: https://grafana.wikimedia.org/d/000000566/overview?panelId=2&fullscreen&orgId=1
  • We continue to maintain this code and have to take it into account in all bug reports and QA steps.
  • It's not clear when opting into Advanced mobile contributions mode what a user is getting.
  • It's not clear to developers/QA testers how advanced mobile contributions mode differs from stable.
  • We are about to start desktop refresh and potentially freeze the mobile site. Keeping it as simplified as possible going into that project seems sensible.

acceptance criteria

  • Remove back to top code and the associated feature flag wgMinervaEnableBackToTop (it's useful but doesn't really fit AMC and doesn't fit in with our long term plan)
  • Put the categories feature in AMC mode.
  • Disable the beta mode

QA steps

Using the beta cluster....

  • Visit https://en.m.wikipedia.beta.wmflabs.org/wiki/Barack%20Obama and click settings. Make sure there is no beta toggle on the settings page.
  • Opt into AMC and ensure that a categories button shows at the bottom of the Barack Obama page. Clicking it opens an overlay that shows the categories on the page. When AMC is disabled it shouldn't show
  • Disable JS and log out and confirm that there should be no settings link in the main menu.

Developer notes

This is a config only change

wgMFEnableBeta = false;
wgMinervaShowCategoriesButton['amc'] = true;

Additional notes

  • If we don't want to put the back to top feature in AMC mode, we might want to turn it into a gadget.
  • If wanted, we could later simplify the categories feature to work like desktop (a link of plain links)

Sign off steps

Make sure beta is disabled in production (en.wikipedia.org) on Thursday 16th January.

QA Results

ACStatusDetails
1T237290#5801003
2T237290#5801003
3T237290#5801003

Details

Related Gerrit Patches:
mediawiki/extensions/MobileFrontend : masterDisable BETA mode
mediawiki/skins/MinervaNeue : masterCategories browser test only runs if the feature is enabled
operations/mediawiki-config : masterDrop beta setting.
mediawiki/skins/MinervaNeue : masterDiscontinue back-to-top feature
mediawiki/skins/MinervaNeue : masterEnable Categories button in AMC

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes
Restricted Application added subscribers: Masumrezarock100, Aklapper. · View Herald TranscriptNov 4 2019, 6:00 PM
ovasileva triaged this task as Medium priority.Nov 4 2019, 7:16 PM
ovasileva updated the task description. (Show Details)
Krenair renamed this task from Disable beta (for now) to Disable mobile beta mode (for now).Nov 4 2019, 7:28 PM
Krenair added a subscriber: Krenair.

Change 548573 had a related patch set uploaded (by Ammarpad; owner: Ammarpad):
[mediawiki/skins/MinervaNeue@master] Enable Back-to-top and Categories button in AMC

https://gerrit.wikimedia.org/r/548573

Ammarpad added a subscriber: Ammarpad.

I started working on it

If we don't want to put the back to top feature in AMC mode, we might want to turn it into a gadget.

That would mean we would need to deploy the gadget across all Wikimedia projects. Adding definitions and creating JS pages, too much work, don't you think? Besides gadgets don't work without JS (except CSS only gadgets).

Masumrezarock100 added a subscriber: Johan.

This will likely affect most of the mobile users. @Johan should we announce this in the next Tech news?

Johan added a comment.Nov 5 2019, 11:07 AM

When would this happen?

Made a note in the task description as well. I'm not sure back to top makes sense as a part of AMC (as it's not an editing-focused workflow). That, given the bugs with it overlapping other things make me think that it's best to remove it for now. We'll have a better version of navigation once we get to making the sticky headers work(T151115: [EPIC] Improve in-article navigation), although admittedly that won't be in the near future.

@Ammarpad, @Masumrezarock100 it sounds like the core web team need to chat about this and make some decisions before pushing forward with the change. @Johan I'll let you know when that's happened and move this out the "upcoming" column which allows us to have that discussion.

Jdlrobson moved this task from Inbox to Next up on the User-Jdlrobson board.
Jdlrobson updated the task description. (Show Details)Nov 5 2019, 6:31 PM
ovasileva set the point value for this task to 3.Nov 5 2019, 6:32 PM

@Johan we've had the chat: looks like we will be aiming for the week of 18th November (no train up until then). The user notice should be something along these lines.
"The mobile beta mode has been disabled for the forseeable future, to reduce the maintenance burden of the mobile site, in preparation for the team's focus on the desktop improvements project. Disruption should be minimal - users wanting the categories feature should enable the AMC mode. A jump back to top feature has been removed and should be replaced with [[ https://en.m.wikipedia.org/wiki/User:Jdlrobson/scripts/backtotop.js | a gadget/user script ]]if necessary."

@Ammarpad the plan is now to remove the back to top code and associated feature flag. You should feel free to continue your patch!

@Ammarpad the plan is now to remove the back to top code and associated feature flag. You should feel free to continue your patch!

Noted. Thanks

Johan added a comment.Nov 7 2019, 1:25 PM

@Jdlrobson Thank you. Simplified the sentence structure and added it to https://meta.wikimedia.org/wiki/Tech/News/2019/47 which will be delivered to the wikis on Monday November 18.

Change 549698 had a related patch set uploaded (by Ammarpad; owner: Ammarpad):
[mediawiki/skins/MinervaNeue@master] Discontinue back-to-top feature

https://gerrit.wikimedia.org/r/549698

Change 548573 merged by jenkins-bot:
[mediawiki/skins/MinervaNeue@master] Enable Categories button in AMC

https://gerrit.wikimedia.org/r/548573

Change 549698 merged by jenkins-bot:
[mediawiki/skins/MinervaNeue@master] Discontinue back-to-top feature

https://gerrit.wikimedia.org/r/549698

When we disable beta we run into the issue described in T198265. However given T233741 that might be another way to resolve this. For now I suggest making the settings link JS-only and only revealing it if settings are available. I can work on this..

Change 556473 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/extensions/MobileFrontend@master] Disable BETA mode

https://gerrit.wikimedia.org/r/556473

When we disable beta we run into the issue described in T198265. However given T233741 that might be another way to resolve this. For now I suggest making the settings link JS-only and only revealing it if settings are available. I can work on this..

Thank you Jon.

Jdlrobson moved this task from Next up to Blocked on the User-Jdlrobson board.Dec 12 2019, 9:16 PM
Jdlrobson moved this task from Blocked to Doing on the User-Jdlrobson board.Dec 20 2019, 3:54 PM
Jdlrobson added a comment.EditedJan 7 2020, 8:02 PM

Options are:

  1. Settings link redirects to login link.
  2. Settings is hidden for non-JavaScript
  3. Settings page shows some text that prompts the user to login.
  4. do nothing.

We're leaning towards option 2 as it's the most straightforward (we do this already for the Nearby page) . @ovasileva does that work for you?

Edit: "but this will remove AMC for users with JavaScript disabled or old browsers (likely a small and maybe even empty group of people)" < this is not true. I've realised we can keep it for those users, so this seems like a no brainer?

Change 562607 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[operations/mediawiki-config@master] Disable beta (for now)

https://gerrit.wikimedia.org/r/562607

Options are:

  1. Settings link redirects to login link.
  2. Settings is hidden for non-JavaScript
  3. Settings page shows some text that prompts the user to login.
  4. do nothing.

We're leaning towards option 2 as it's the most straightforward (we do this already for the Nearby page) . @ovasileva does that work for you?
Edit: "but this will remove AMC for users with JavaScript disabled or old browsers (likely a small and maybe even empty group of people)" < this is not true. I've realised we can keep it for those users, so this seems like a no brainer?

Yay, okay, in that case hiding it makes the most sense. So no settings but if they've already turned it on it will stay on?

SWAT scheduled for 11am PST tomorrow.
Review needed on https://gerrit.wikimedia.org/r/c/556473

phuedx added a subscriber: phuedx.Jan 9 2020, 2:29 PM

I've moved this to Needs More Work as the patch that @Jdlrobson posted above (which disables mobile beta by default) causes tests to fail. One possibility would be to alter the tests so that they skip if mobile beta is disabled, e.g.

tests/selenium/features/category.feature
@categories
Feature: Categories

...
tests/selenium/features/support/hooks.js
Before( { tags: '@categories' }, () => {
  const IP = path.resolve( __dirname, '../../../../../' );
  const config = require( path.resolve( IP, 'extensions/MobileFrontend/extension.js' ).config;

  // See https://github.com/cucumber/cucumber-js/blob/master/docs/support_files/hooks.md#skipping-in-a-before-hook
  return !!config.MFBeta ? 'skipped' : null;
} );

Change 562607 merged by jenkins-bot:
[operations/mediawiki-config@master] Drop beta setting.

https://gerrit.wikimedia.org/r/562607

Mentioned in SAL (#wikimedia-operations) [2020-01-09T19:13:04Z] <urbanecm@deploy1001> Synchronized wmf-config/mobile.php: SWAT: 2f9ee90: Drop beta setting (T237290) (duration: 01m 06s)

Change 563268 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/skins/MinervaNeue@master] Categories browser test only runs if the feature is enabled

https://gerrit.wikimedia.org/r/563268

Jdlrobson updated the task description. (Show Details)Jan 10 2020, 6:00 PM
Jdlrobson reassigned this task from Ammarpad to Edtadros.Jan 13 2020, 10:01 PM
Jdlrobson updated the task description. (Show Details)

Change 563268 merged by jenkins-bot:
[mediawiki/skins/MinervaNeue@master] Categories browser test only runs if the feature is enabled

https://gerrit.wikimedia.org/r/563268

Change 556473 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Disable BETA mode

https://gerrit.wikimedia.org/r/556473

Edtadros reassigned this task from Edtadros to ovasileva.Jan 14 2020, 9:25 AM
Edtadros added a subscriber: Edtadros.

Test Result

Status: ✅ PASS
OS: macOS Catalina
Browser: Chrome
Device: MBP
Emulated Device: iPhoneX

Test Artifact(s):

QA steps

Using the beta cluster....

✅ AC1: Visit https://en.m.wikipedia.beta.wmflabs.org/wiki/Barack%20Obama and click settings. Make sure there is no beta toggle on the settings page.

✅ AC2: Opt into AMC and ensure that a categories button shows at the bottom of the Barack Obama page. Clicking it opens an overlay that shows the categories on the page. When AMC is disabled it shouldn't show

✅ AC3: Disable JS and log out and confirm that there should be no settings link in the main menu.

Edtadros updated the task description. (Show Details)Jan 14 2020, 9:26 AM
ovasileva closed this task as Resolved.Jan 17 2020, 1:01 PM

Confirmed it's no longer available in production. Resolving.