Page MenuHomePhabricator

[Regression 1.35.0-wmf.19] i/p/IndexPager.php:* PHP Warning: implode(): Invalid arguments passed
Closed, ResolvedPublic

Description

Error message
Impact
Notes

Provisionally blaming 36ed224b8f40394507a64311eacda7302225a058 or 6786aa5d8e2e87f00a3b1f81d9684ff4eac676ef.

Event Timeline

Restricted Application removed a project: Patch-For-Review. · View Herald TranscriptFeb 11 2020, 10:54 PM

This is a regression from rMW6786aa5d8e2e: Support pagination on multiple columns in the IndexPager, caused by the fact that ImageHistoryPseudoPager completely reimplements doQuery(), including code that lives in IndexPager::extractResultInfo(), which was modified in an incompatible way.

Jdforrester-WMF triaged this task as Unbreak Now! priority.Feb 11 2020, 10:57 PM
Jdforrester-WMF edited projects, added Anti-Harassment; removed Release, Train Deployments.
Jdforrester-WMF added a subscriber: Tchanders.

Train blocker.

Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptFeb 11 2020, 10:57 PM

Change 571595 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/core@master] ImageHistoryPseudoPager: Update doQuery() for IndexPager changes

https://gerrit.wikimedia.org/r/571595

Change 571595 merged by jenkins-bot:
[mediawiki/core@master] ImageHistoryPseudoPager: Update doQuery() for IndexPager changes

https://gerrit.wikimedia.org/r/571595

Change 571605 had a related patch set uploaded (by Jforrester; owner: Catrope):
[mediawiki/core@wmf/1.35.0-wmf.19] ImageHistoryPseudoPager: Update doQuery() for IndexPager changes

https://gerrit.wikimedia.org/r/571605

As @dmaza points out, Flow's HistoryPager is another case, slightly more fiddly to fix since the property needs to not be an array when passed to UUID::create(). While we work this out, we can fix it by doing T244941.

@Jdforrester-WMF presumably that's a train blocker too.

As @dmaza points out, Flow's HistoryPager is another case, slightly more fiddly to fix since the property needs to not be an array when passed to UUID::create(). While we work this out, we can fix it by doing T244941.

@Jdforrester-WMF presumably that's a train blocker too.

Yes. :-(

Change 571605 merged by jenkins-bot:
[mediawiki/core@wmf/1.35.0-wmf.19] ImageHistoryPseudoPager: Update doQuery() for IndexPager changes

https://gerrit.wikimedia.org/r/571605

Mentioned in SAL (#wikimedia-operations) [2020-02-12T00:44:43Z] <jforrester@deploy1001> Synchronized php-1.35.0-wmf.19/includes/page/ImageHistoryPseudoPager.php: T244937 ImageHistoryPseudoPager: Update doQuery() for IndexPager changes (duration: 01m 03s)

dbarratt closed this task as Resolved.Feb 12 2020, 4:05 PM
dbarratt claimed this task.
dbarratt added a subscriber: dbarratt.

Boldly closing as it appears to have been merged... thanks @Tchanders !