Page MenuHomePhabricator

Add target filter for the Timeline tab in Special:Investigate
Closed, ResolvedPublic3 Estimated Story PointsJun 16 2020

Description

A filter form on the Compare tab allows filters to be added for targets.

Acceptance criteria

  • The same form (filters box) should be added to the Timeline tab.
  • Move the filters box above the tabs
  • Keep the filters box open by default
  • The filters should be kept in sync across tabs: if a target is filtered out using the form on the Compare tab, the target should also be filtered out of the Timeline results, and the form on the Timeline tab should be pre-filled accordingly.

Mocks

CompareTimeline

Technical Details

  • Update the Queries in the Timeline Tab to support target

Event Timeline

Restricted Application added a subscriber: Aklapper. ยท View Herald TranscriptMay 21 2020, 4:53 PM
Niharika added subscribers: Prtksxna, Niharika.

@Prtksxna Forgot to talk about this in our meeting today. More context for this here: T251459#6156958.
We can talk about it in our future meeting. Keeping this in your column for now.

Prtksxna updated the task description. (Show Details)Jun 3 2020, 4:31 AM

We can talk about it in our future meeting. Keeping this in your column for now.

We decided to keep fewer filters for now because of performance concerns. Keeping only the Duration and Targets filter means that the filters box could be common for both tabs, and so we can move it above the tabs. We'll keep the box open by default.

The Duration filter will reflect what was chosen in the initial Special:Investigate form and will apply to all tabs.


@Tchanders The user agents filter could be common across both tabs too. I don't recall what you had said about the performance hit because of adding a UA agent. We can decide whether or not to add it based on your advice.

Niharika triaged this task as Medium priority.Jun 3 2020, 4:34 PM
ARamirez_WMF set the point value for this task to 3.Jun 3 2020, 4:37 PM
dbarratt renamed this task from Add target and timestamp filters for the Timeline tab in Special:Investigate to Add target filter for the Timeline tab in Special:Investigate.Jun 3 2020, 4:40 PM
dbarratt updated the task description. (Show Details)
dbarratt updated the task description. (Show Details)

@Prtksxna Moving the filters above the tabs means that the tabs will vertically "jump" moving between Preliminary Check and one of the other tabs. Is this ok?

@Prtksxna Moving the filters above the tabs means that the tabs will vertically "jump" moving between Preliminary Check and one of the other tabs. Is this ok?

Yep, we're ok with this.

Change 602519 had a related patch set uploaded (by Dbarratt; owner: Dbarratt):
[mediawiki/extensions/CheckUser@master] Move filters above tabs and add exclude targets filter to timeline tab.

https://gerrit.wikimedia.org/r/602519

ARamirez_WMF set Due Date to Jun 17 2020, 4:00 AM.Jun 9 2020, 3:29 PM
ARamirez_WMF changed the subtype of this task from "Task" to "Deadline".
ARamirez_WMF changed Due Date from Jun 17 2020, 4:00 AM to Jun 16 2020, 4:00 AM.Jun 9 2020, 8:26 PM

Change 602519 merged by jenkins-bot:
[mediawiki/extensions/CheckUser@master] Move filters above tabs and add exclude targets filter to timeline tab.

https://gerrit.wikimedia.org/r/602519

dom_walden added a subscriber: dom_walden.
  • The same form (filters box) should be added to the Timeline tab.
  • Move the filters box above the tabs
  • Keep the filters box open by default

It is closed by default.

  • The filters should be kept in sync across tabs: if a target is filtered out using the form on the Compare tab, the target should also be filtered out of the Timeline results, and the form on the Timeline tab should be pre-filled accordingly.

It persists across the different tabs and pagination.

I have been keeping an eye on the SQL in the logs while I perform investigations. I have not seen any problems in the SQL produced by TimelinePager (i.e. it reflects the current filters).

For a couple of investigations, I compared the output of the SQL for the TimelinePager with output from my own scripts, and got the same results.

I also did this for the Compare tab just in case of regressions (we appear to have combined some of the code which was separated between the Timeline and Compare tabs).

dbarratt closed this task as Resolved.Jun 24 2020, 3:50 PM