Page MenuHomePhabricator

Missing Wikidata sitelinks on Commons categories
Closed, ResolvedPublic

Description

User:Ixdf64 reported on project chat (permanent link) that commons:Category:Kyburz, California was missing interwiki links from Wikidata. Through Special:Random/Category I also found Category:West Virginia Route 259, also missing sitelinks despite them existing on Wikipedia, and Category:Siedliska, powiat raciborski, which had sitelinks when I first loaded it but lost them when I purged it (?action=purge). Based on the last category, I fear the issue may spread.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 6 2020, 10:16 PM
Lucas_Werkmeister_WMDE triaged this task as High priority.Jul 6 2020, 10:16 PM

There is also a similar-sounding report on Commons’ village pump (section, permalink), not yet sure if it’s the same issue or not.

Based purely on the timing in SAL, the recent config changes related to T254315 and T241975 may be related, but that’s just a guess so far.

A very basic idea, this is only reported on commons so far, it's very likely federation and entity source changes: T241975#6282927

This is borderline UBN

Suggestion:

  • On the deployment host, revert those three Wikibase config changes. Do not scap.
  • On one of the debug hosts, scap pull.
  • With X-Wikimedia-Debug, purge one of the affected categories and see if that fixes the issue.
  • If yes, revert the three config changes properly through Gerrit and deploy them separately in reverse order.

However, it’s too late at night, and I judge this issue to be not severe enough, for me to do this now.

This is causing every use of Wikidata Infobox on Commons to fail and break the automatically populated categories for humans to be broke. As cache expires it's only going to get worst. I'd categorize this as UBN.

IagoQnsi raised the priority of this task from High to Unbreak Now!.Jul 7 2020, 2:41 AM
IagoQnsi added a subscriber: IagoQnsi.

{{Wikidata Infobox}} is transcluded 3,081,892 times on Commons. Currently, the template is completely failing, and the infobox contents are replaced with a "NO WIKIDATA ID FOUND!" error message. I'm going to set this to UBN.

That’s very strange, because I’m sure at least Kyburz, California still had a working Wikidata infobox yesterday, and the other two categories linked in the task description still have a working Wikidata infobox. (I don’t want to try purging them right now.) This might be two different but related issues, but for now it probably makes sense to track them together here.

Suggestion:

  • On the deployment host, revert those three Wikibase config changes. Do not scap.
  • On one of the debug hosts, scap pull.
  • With X-Wikimedia-Debug, purge one of the affected categories and see if that fixes the issue.
  • If yes, revert the three config changes properly through Gerrit and deploy them separately in reverse order.

However, it’s too late at night, and I judge this issue to be not severe enough, for me to do this now.

Okay, with four config changes reverted on mwdebug1001, Kyburz looks fine again after a purge – has its infobox and sitelinks/languagelinks. Let’s push those reverts to Gerrit and then sync them properly.

Change 609641 had a related patch set uploaded (by Lucas Werkmeister (WMDE); owner: Lucas Werkmeister (WMDE)):
[operations/mediawiki-config@master] Revert "Wikibase: Remove config option wmgUseEntitySourceBasedFederation"

https://gerrit.wikimedia.org/r/609641

Change 609641 merged by jenkins-bot:
[operations/mediawiki-config@master] Revert "Wikibase: Remove config option wmgUseEntitySourceBasedFederation"

https://gerrit.wikimedia.org/r/609641

Mentioned in SAL (#wikimedia-operations) [2020-07-07T07:15:01Z] <lucaswerkmeister-wmde@deploy1001> Synchronized wmf-config/InitialiseSettings.php: Config: [[gerrit:609641|Revert "Wikibase: Remove config option wmgUseEntitySourceBasedFederation" (T241975, T257266)]] (duration: 00m 57s)

Change 609642 had a related patch set uploaded (by Lucas Werkmeister (WMDE); owner: Lucas Werkmeister (WMDE)):
[operations/mediawiki-config@master] Revert "Wikibase: stop using wmgUseEntitySourceBasedFederation"

https://gerrit.wikimedia.org/r/609642

Change 609642 merged by jenkins-bot:
[operations/mediawiki-config@master] Revert "Wikibase: stop using wmgUseEntitySourceBasedFederation"

https://gerrit.wikimedia.org/r/609642

Mentioned in SAL (#wikimedia-operations) [2020-07-07T07:19:10Z] <lucaswerkmeister-wmde@deploy1001> Synchronized wmf-config/Wikibase.php: Config: [[gerrit:609642|Revert "Wikibase: stop using wmgUseEntitySourceBasedFederation" (T241975, T257266)]] (duration: 00m 55s)

Change 609643 had a related patch set uploaded (by Lucas Werkmeister (WMDE); owner: Lucas Werkmeister (WMDE)):
[operations/mediawiki-config@master] Revert "Wikidata client wikis: Define entity sources configuration (take 2)"

https://gerrit.wikimedia.org/r/609643

Change 609643 merged by jenkins-bot:
[operations/mediawiki-config@master] Revert "Wikidata client wikis: Define entity sources configuration (take 2)"

https://gerrit.wikimedia.org/r/609643

Mentioned in SAL (#wikimedia-operations) [2020-07-07T07:23:13Z] <lucaswerkmeister-wmde@deploy1001> Synchronized dblists/wikidataclient.dblist: Config: [[gerrit:609643|Revert "Wikidata client wikis: Define entity sources configuration (take 2)" (T254315, T257266)]] (duration: 00m 56s)

Mentioned in SAL (#wikimedia-operations) [2020-07-07T07:24:23Z] <lucaswerkmeister-wmde@deploy1001> Synchronized wmf-config/: Config: [[gerrit:609643|Revert "Wikidata client wikis: Define entity sources configuration (take 2)" (T254315, T257266)]] (duration: 00m 56s)

Change 609644 had a related patch set uploaded (by Lucas Werkmeister (WMDE); owner: Lucas Werkmeister (WMDE)):
[operations/mediawiki-config@master] Revert "Commons: Define entity sources configuration"

https://gerrit.wikimedia.org/r/609644

Change 609644 merged by jenkins-bot:
[operations/mediawiki-config@master] Revert "Commons: Define entity sources configuration"

https://gerrit.wikimedia.org/r/609644

Mentioned in SAL (#wikimedia-operations) [2020-07-07T07:27:45Z] <lucaswerkmeister-wmde@deploy1001> Synchronized wmf-config/InitialiseSettings.php: Config: [[gerrit:609644|Revert "Commons: Define entity sources configuration" (T256906, T256907, T256909, T254315, T257266)]] (duration: 00m 53s)

Mentioned in SAL (#wikimedia-operations) [2020-07-07T07:31:05Z] <lucaswerkmeister-wmde@deploy1001> Synchronized wmf-config/InitialiseSettings.php: Config: [[gerrit:609644|Revert "Commons: Define entity sources configuration" (T256906, T256907, T256909, T254315, T257266)]] (forgot to git rebase so the last sync was a no-op) (duration: 00m 56s)

Lucas_Werkmeister_WMDE lowered the priority of this task from Unbreak Now! to High.Jul 7 2020, 7:32 AM

Alright, all config changes have been reverted and, after a purge, the three categories linked in the task description all have their sitelinks and infoboxes again.

Task stays open for investigating what the issue was and figuring out the correct solution.

Also, since those config changes were meant to remove one kind of config from production (if I’m not mistaken), it would probably be good to verify that we haven’t yet removed support for that config from Wikibase, so that we don’t get a nasty surprise with the next train because support for the config was removed on master and then I reinstated the production config which needs that support. (I don’t see anything relevant in the git log, but I’m not sure if I know all the right terms to look for.)

Change 609987 had a related patch set uploaded (by Addshore; owner: Addshore):
[operations/mediawiki-config@master] Commons: Define entity sources configuration (take 2)

https://gerrit.wikimedia.org/r/609987

Change 609986 had a related patch set uploaded (by Addshore; owner: Addshore):
[operations/mediawiki-config@master] Wikibase: Remove config option wmgUseEntitySourceBasedFederation (take 2)

https://gerrit.wikimedia.org/r/609986

Change 609645 had a related patch set uploaded (by Addshore; owner: Addshore):
[operations/mediawiki-config@master] Wikibase: stop using wmgUseEntitySourceBasedFederation (take 2)

https://gerrit.wikimedia.org/r/609645

Change 609988 had a related patch set uploaded (by Addshore; owner: Addshore):
[operations/mediawiki-config@master] Wikidata client wikis: Define entity sources configuration (take 3)

https://gerrit.wikimedia.org/r/609988

Addshore claimed this task.Jul 7 2020, 7:59 AM

Going to assign to myself as I'll be redeploying these config changes (hopefully with fixes)

Restricted Application added a project: User-Addshore. · View Herald TranscriptJul 7 2020, 7:59 AM

Change 609971 had a related patch set uploaded (by Addshore; owner: Addshore):
[operations/mediawiki-config@master] Enable sitelinks to testcommons from test wikidata sites

https://gerrit.wikimedia.org/r/609971

Maintenance_bot moved this task from incoming to in progress on the Wikidata board.Jul 7 2020, 8:15 AM

Change 609645 merged by jenkins-bot:
[operations/mediawiki-config@master] Wikibase: stop using wmgUseEntitySourceBasedFederation (take 2)

https://gerrit.wikimedia.org/r/609645

Mentioned in SAL (#wikimedia-operations) [2020-07-07T09:33:55Z] <addshore@deploy1001> Synchronized wmf-config/Wikibase.php: [[gerrit:609645]] T257266 T241975 Wikibase: stop using wmgUseEntitySourceBasedFederation (take2) (duration: 00m 59s)

Change 609986 merged by jenkins-bot:
[operations/mediawiki-config@master] Wikibase: Remove config option wmgUseEntitySourceBasedFederation (take 2)

https://gerrit.wikimedia.org/r/609986

Mentioned in SAL (#wikimedia-operations) [2020-07-07T09:37:15Z] <addshore@deploy1001> Synchronized wmf-config: [[gerrit:609986]] T257266 T241975 Wikibase: Remove config option wmgUseEntitySourceBasedFederation (take2) (duration: 00m 57s)

Change 609971 merged by jenkins-bot:
[operations/mediawiki-config@master] Enable sitelinks to testcommons from test wikidata sites

https://gerrit.wikimedia.org/r/609971

Mentioned in SAL (#wikimedia-operations) [2020-07-07T09:42:50Z] <addshore@deploy1001> Synchronized wmf-config/InitialiseSettings.php: [[gerrit:609971]] T257266 Enable sitelinks to testcommons from test wikidata sites (duration: 00m 56s)

Change 609985 had a related patch set uploaded (by Addshore; owner: Addshore):
[operations/mediawiki-config@master] Make testcommonswiki a testwikidata client

https://gerrit.wikimedia.org/r/609985

Change 609985 merged by jenkins-bot:
[operations/mediawiki-config@master] Make testcommonswiki a testwikidata client

https://gerrit.wikimedia.org/r/609985

Mentioned in SAL (#wikimedia-operations) [2020-07-07T10:08:12Z] <addshore@deploy1001> sync-file aborted: [[gerrit:609985]] Make testcommonswiki a testwikidata client T257266 PT1/2 (duration: 00m 36s)

Mentioned in SAL (#wikimedia-operations) [2020-07-07T10:10:34Z] <addshore@deploy1001> Synchronized dblists/wikidataclient-test.dblist: [[gerrit:609985]] Make testcommonswiki a testwikidata client T257266 PT1/2 (duration: 00m 56s)

Mentioned in SAL (#wikimedia-operations) [2020-07-07T10:11:05Z] <addshore@deploy1001> sync-file aborted: [[gerrit:609985]] Make testcommonswiki a testwikidata client T257266 PT1/2 (duration: 00m 00s)

Mentioned in SAL (#wikimedia-operations) [2020-07-07T10:12:04Z] <addshore@deploy1001> Synchronized wmf-config/config/testcommonswiki.yaml: [[gerrit:609985]] Make testcommonswiki a testwikidata client T257266 PT2/2 (duration: 00m 55s)

Addshore closed this task as Resolved.Jul 9 2020, 8:45 AM

Going to go ahead and close this as the issue is resolved now and we will continue trying to poke the config in the ot

Change 609987 merged by jenkins-bot:
[operations/mediawiki-config@master] Commons: Define entity sources configuration (take 2)

https://gerrit.wikimedia.org/r/609987

Change 609988 merged by jenkins-bot:
[operations/mediawiki-config@master] Wikidata client wikis: Define entity sources configuration (take 3)

https://gerrit.wikimedia.org/r/609988

Mentioned in SAL (#wikimedia-operations) [2020-07-16T11:18:11Z] <addshore@deploy1001> Synchronized wmf-config/InitialiseSettings.php: T254315 T257266 [[gerrit:609988]] Wikidata client wikis: Define entity sources configuration (take 3) (duration: 01m 08s)