Review PDBHandler extension
Open, Stalled, LowestPublic

Description

Author: emw.wiki

Description:
PDBHandler is an extension to enable interactive 3D models using WebGL, intended for Wikipedia deployment. I've got it working with MediaWiki 1.21 and would like to have the code reviewed. It's had a design review; the current implementation reflects comments from that.

Code: https://gerrit.wikimedia.org/r/#/q/status:open+project:mediawiki/extensions/PDBHandler,n,z
Test deployment: http://pdbhandler.wmflabs.org
More information: http://www.mediawiki.org/wiki/Extension:PDBHandler

(Some initial review comments have been made, but I thought it'd make sense to also track the review status here.)


Version: unspecified
Severity: enhancement
URL: http://pdbhandler.wmflabs.org

bzimport set Reference to bz44660.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Feb 5 2013, 2:10 AM
Reedy added a comment.Feb 5 2013, 2:50 AM

FYI, you could've amended the first commit to bring in those extra changes. I guess you could still squash it..

$ curl -Is "http://pdbhandler.wmflabs.org/wiki/Main_Page"
HTTP/1.0 500 Internal Server Error
Date: Tue, 05 Feb 2013 03:06:18 GMT
Server: Apache/2.2.22 (Ubuntu)
X-Powered-By: PHP/5.3.10-1ubuntu3.4+wmf1
X-Content-Type-Options: nosniff
Vary: Accept-Encoding
Connection: close
Content-Type: text/html

(In reply to comment #2)

$ curl -Is "http://pdbhandler.wmflabs.org/wiki/Main_Page"
HTTP/1.0 500 Internal Server Error

I can't reproduce that.

$ curl -Is "http://pdbhandler.wmflabs.org/wiki/Main_Page"
HTTP/1.1 200 OK
Date: Tue, 05 Feb 2013 03:16:41 GMT
Server: Apache/2.2.22 (Ubuntu)
X-Powered-By: PHP/5.3.10-1ubuntu3.4+wmf1
X-Content-Type-Options: nosniff
Content-language: en
Vary: Accept-Encoding,Cookie
Expires: Thu, 01 Jan 1970 00:00:00 GMT
Cache-Control: private, must-revalidate, max-age=0
Last-Modified: Sat, 02 Feb 2013 13:14:06 GMT
Content-Type: text/html; charset=UTF-8

(In reply to comment #3)

(In reply to comment #2)

$ curl -Is "http://pdbhandler.wmflabs.org/wiki/Main_Page"
HTTP/1.0 500 Internal Server Error

I can't reproduce that.

$ curl -Is "http://pdbhandler.wmflabs.org/wiki/Main_Page"
HTTP/1.1 200 OK

Yeah, looks like it's better now. :-)

General info on code review of extensions: https://www.mediawiki.org/wiki/Writing_an_extension_for_deployment#Code_review

Emw: Would you like to have a separate Bugzilla component for bug reports? See https://www.mediawiki.org/wiki/Bug_management/Project_Maintainers#To_add_a_project_or_component for needed data.

emw.wiki wrote:

Andre: thanks for the pointer, I've requested a separate Bugzilla component for PDBHandler -- https://bugzilla.wikimedia.org/show_bug.cgi?id=44698.

Reedy added a comment.Apr 22 2013, 8:12 PM

https://gerrit.wikimedia.org/r/#/q/status:open+project:mediawiki/extensions/PDBHandler,n,z

Looks like that needs tidying up somewhat. I suspect 2 of the initial commits can be abandoned

greg added a comment.Sep 5 2013, 10:50 PM

The test install on wmflabs doesn't allow me to create an account (needed to test).

Also:

Hello, this is a quasi-automated-but-not-really message:

I am reviewing all tracking bugs for extensions to review and deploy to WMF servers. See the list here:
https://bugzilla.wikimedia.org/showdependencytree.cgi?id=31235&hide_resolved=1

The [[mw:Review queue]] page lists the steps necessary to complete the review. I have copied them below and done some initial filling out based on what I can easily gleen from this bug and any linked to sources that are obvious. If I miss something/state something false, please do correct me.

Also, if you haven't yet done so, please review the information on and linked to from:
https://www.mediawiki.org/wiki/Writing_an_extension_for_deployment

TODO/Check list

Extension page on mediawiki.org: yes
Bugzilla component: yes
Extension in Gerrit: yes
Design Review: no
Archeticecture/Performance Review: no
Security Review: no
Screencast (if applicable): no
Community support: no?

What is the current status of this? I see that all change set have been abandoned on Gerrit…

(In reply to Jean-Fred from comment #9)

What is the current status of this? I see that all change set have been
abandoned on Gerrit…

There was some issues with the extension. Nobody fixed the issues so the patch got ambandoned. To move forward would require someone interested in fixing the spotted issue.

On a related note, there is ongoing work by Rillke to add support for the mol file format

Paladox set Security to None.Sep 17 2015, 9:05 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 17 2015, 9:05 PM

I see @Bawolff. So this should be closed as Declined I suppose?

Reedy changed the task status from "Open" to "Stalled".Oct 19 2015, 9:21 PM
Reedy added a subscriber: Reedy.
Aklapper lowered the priority of this task from "Normal" to "Lowest".Dec 12 2015, 8:20 PM

So this should be closed as Declined I suppose?

Not really, this task is about identifying the urgent next steps for the extension (and fixing them). Usually it takes many years to deploy an extension.

Add Comment