Page MenuHomePhabricator

[TUX] Implement used X times
Closed, ResolvedPublic

Description

The Used X times for TM suggestions looks like interactive element. Currently it is not. It should work or perhaps temporarily made to look non-interactive.


Version: master
Severity: enhancement
URL: http://commons.wikimedia.org/w/index.php?title=File:Translate-workflow-spec.pdf&page=14

Details

Reference
bz45686
Related Gerrit Patches:

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 1:16 AM
bzimport set Reference to bz45686.
bzimport added a subscriber: Unknown Object (MLST).

Related suggestion: "For TM suggestions, show source string on hover"

(In reply to comment #1)

Related suggestion: "For TM suggestions, show source string on hover"

Please make this a separate issue and link it from "See Also:".

Perhaps it would make more sense to expose this information via the implementation of this feature. However if you think it should be separate, I can file it as "disclose the source text of translation suggestions" to have it problem oriented.

With the updated specification, designs for this issue are now on page 14:
http://commons.wikimedia.org/w/index.php?title=File:Translate-workflow-spec.pdf&page=14

  • Bug 47088 has been marked as a duplicate of this bug. ***

(In reply to comment #0)

The Used X times for TM suggestions looks like interactive element. Currently
it is not.

This is now incorrect, the link has the same effect as the "Use this translation" button.

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 28 2015, 11:49 AM

Change 544398 had a related patch set uploaded (by Nikerabbit; owner: Nikerabbit):
[mediawiki/extensions/Translate@master] Implemented used X times in translation memory suggestions

https://gerrit.wikimedia.org/r/544398

Change 544398 merged by jenkins-bot:
[mediawiki/extensions/Translate@master] Implemented used X times in translation memory suggestions

https://gerrit.wikimedia.org/r/544398

I was bored during the weekend, so I implemented this feature. I created a follow-up T236179: [TUX] Implement used X times, where X = 1.
Screenshot:

Change 545310 had a related patch set uploaded (by Nikerabbit; owner: Nikerabbit):
[mediawiki/extensions/Translate@master] Fix translation memory suggestions that were duplicated or missing

https://gerrit.wikimedia.org/r/545310

Change 545310 merged by jenkins-bot:
[mediawiki/extensions/Translate@master] Fix translation memory suggestions that were duplicated or missing

https://gerrit.wikimedia.org/r/545310

abi_ closed this task as Resolved.Wed, Nov 6, 9:08 PM
abi_ added a subscriber: abi_.

Tested this on translatewiki.net today after deployment, and it seems to be working well.