Page MenuHomePhabricator

Upon completed translation you end up at api
Closed, DeclinedPublic

Description

Screencast of bug

(On Translatewiki.net) Editing a message from the "Suggestions from translation memories" takes you to https://translatewiki.net/w/api.php upon completion.

To reproduce (or see attached screencast):

  1. Go to a message with similar messages in the translation memory (e.g. https://translatewiki.net/wiki/MediaWiki:Timezoneselector-show-temp/sv )
  2. Display the similar message (i.e. klicking on the blue dot).
  3. Edit the message in the pop-up
  4. Click Save

Version: unspecified
Severity: minor
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=52541

Attached:

Details

Reference
bz67292

Event Timeline

bzimport raised the priority of this task from to Lowest.Nov 22 2014, 3:36 AM
bzimport set Reference to bz67292.
bzimport added a subscriber: Unknown Object (MLST).

Are there any JavaScript errors in your browser's javascript console?

(In reply to Lokal_Profil from comment #2)

Ah. Good catch:
TypeError: mw.translateHooks is undefined
Line 164 of ext.translate.quickedit.js
https://git.wikimedia.org/blob/mediawiki%2Fextensions%2FTranslate.git/
adf54138c1e2a734b045aeb7b70ce5cfd28248a5/resources%2Fext.translate.quickedit.
js#L164

Actually it's in there several times and defined in ext.translate.hooks.js so I'm guessing it's more involved.

And since I had the console up...

quickedit.js also seems to include the deprecated tooltipAccessKeyPrefix-call

The non-TUX ui is not getting any maintenance anymore.

Formerly known as bug 52541.

  • Bug 57148 has been marked as a duplicate of this bug. ***
Nikerabbit closed this task as Declined.Jan 28 2015, 5:11 AM
Nikerabbit claimed this task.

:( No supported way to edit qqq. Perhaps it should be stated somewhere in the docs.

This is not about message documentation and deals with the deprecated non-TUX ui. Nothing to update in docs.

I confirm it happens with qqq as T54541. I can't confirm the part

Editing a message from the "Suggestions from translation memories"

because the "used X times" links don't do anything for me in TUX.

As the "used X times" link is still broken the only way of correcting similar messages is by leaving TUX, thus me encountering the bug. If that link is unbroken then I have no issue with marking this as invalid.

We will fix "used X times" (T47686) as well as improving translation search. It will take months though.

This comment was removed by Kaganer.