Page MenuHomePhabricator

Merge "Recent changes" and "Watchlist" preferences tabs
Closed, DeclinedPublic

Description

"Recent changes" and "Watchlist" tabs of preferences are hard to
understand and use.

  • Some prefs and parts of the UI are exactly the same on both.
    • The entire "Display options" menu on both tabs
    • "Show Wikidata edits" (the text is subtly different, no idea about the behavior)
    • "Hide minor edits"
  • Some don't even belong to either.
    • "Number of edits to show in recent changes, page histories, and in logs, by default:"
    • "Watchlist token:" (bug 21912)
  • Some apply to both watchlist and RC despite being shown only on one tab.
    • "Group changes by page in recent changes and watchlist"
  • Some are only shown in one even though they could apply to both.
    • All of the "Hide edits" checkboxes; only "Hide minor edits" is available on both for some reason

The only solution I see is to merge them, just like the code for the two should be merged (bug 48641).

The hiding checkboxes could use the new HTMLCheckMatrix class (used by Echo for settings of its notifications, with two columns for web and e-mail – we'd use columns for watchlist and RC here).

Old request for something a little similar: bug 18524.


Version: 1.22.0
Severity: normal

Details

Reference
bz51941

Related Objects

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 2:07 AM
bzimport set Reference to bz51941.
bzimport added a subscriber: Unknown Object (MLST).
matmarex created this task.Jul 24 2013, 9:43 AM

I'd like to start with a simple merge of the two [[Special:Preferences]] tabs ("Recent changes" and "Watchlist") into a single "Feeds" tab. Thoughts on this?

Sounds like a good idea, but "Feeds" doesn't sound descriptive enough to me. If anything, I'd prefer simply "Watchlist and recent changes".

(In reply to Bartosz Dziewoński from comment #2)

Sounds like a good idea, but "Feeds" doesn't sound descriptive enough to me.
If anything, I'd prefer simply "Watchlist and recent changes".

+1. The longer label is worth it.
(Also, using "Feeds" would overlap or be ambiguous with: LQT, and Notifications, and any future Flow preferences)

Boldly changing this bug's summary to be more focused. If anyone thinks we should split out to a separate bug report for some reason, please let me know (or just do it!).

Sumit added a subscriber: Sumit.Jan 11 2015, 7:05 PM

I'd like to work on this,I read SpecialPreferences.php,but where exactly can I exactly find the tabs and info given on the preferences page?

I'd like to work on this,I read SpecialPreferences.php,but where exactly can I exactly find the tabs and info given on the preferences page?

See https://gerrit.wikimedia.org/r/#/c/125762/ for an example

Sumit added a comment.EditedJan 15 2015, 6:09 PM

I get the idea of how to merge, but only one question, suppose I add the 'hide checkboxes' for both rc and watchlist using Htmlcheckmatrix, will the functionality for each new checkbox also be required to handle? like we're adding new preference fields so a database change might be required?

I get the idea of how to merge, but only one question, suppose I add the 'hide checkboxes' for both rc and watchlist using Htmlcheckmatrix,

In the first patch, you should not change functionality. Only the position of checkboxes in Special:Preferences.

01tonythomas added a subscriber: 01tonythomas.
gerritbot added a subscriber: gerritbot.

Change 186575 had a related patch set uploaded (by Sumit):
Preferences:Watchlist And Recent Changes merged

https://gerrit.wikimedia.org/r/186575

Patch-For-Review

Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptAug 22 2017, 8:20 PM
Framawiki moved this task from Backlog to Doing on the good first bug board.Dec 2 2017, 1:40 PM
jmatazzoni added a subscriber: jmatazzoni.EditedDec 7 2017, 9:47 PM

We have made some improvements to these tabs since @matmarex wrote this task. But at this time we have not schedule the wholesale refactoring that we envisioned at one point in T172350 and its sub-tasks.

jmatazzoni closed this task as Declined.Sep 24 2018, 6:03 PM

I want to say that @MGChecker is correct in removing the Easy designation from this. I'll go further and say that back in 2013 when this was written, it may have been a good idea. But at this point I'm pretty sure it no longer is. There are quite a few features where users will want to differentiate between Watchlist behavior and RC page behavior. E.g., the Revision Scoring features, or even something simple like the number of changes shown. So keeping these pages separate is a feature, not a bug IMHO.

I'm going to be bold and Decline this task as something that I think is not advisable and almost certainly not going to get worked on. If I have done so in error and someone wants to reopen it, they are more than welcome to and to restate the case.