Selecting nodes (references/images/templates) on iOS < 8 causes the on-screen keyboard to close, so they cannot be deleted
Closed, ResolvedPublic8 Story Points

Description

Intention:
Delete a template.

Steps to Reproduce:

  1. Open an article containing a template.
  2. Select the template.
  3. Try to press the delete key on the now-non-existent keyboard.

Actual Results:
The keyboard closes, so you can't delete them.

Reproducible: Didn't try


Version: unspecified
Severity: major
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=67390

Did you mean the cursor instead of the keyboard? Surely VisualEditor didn't make your physical keyboard dissolve into a pool of molten plastic?

No, I mean the keyboard. It's an iPad without an attached physical keyboard. The keyboard is displayed on the screen, like the one shown in the picture at https://commons.wikimedia.org/wiki/File:Apple_iPad_Event03.jpg

(Presumably the same problem happens on any mobile device.)

Aaaah, OK. Updating summary to reflect that.

Can this be rechecked?

Yes, for all block items such as image, reference note, template ,math function: selecting it hides the keyboard.

brion added a comment.Jul 2 2014, 8:00 PM

I've noticed a few bugs coming through related to certain operations hiding the keyboard and then that killing focus and causing selections and menus to disappear. Is there a general problem where losing keyboard focus causes VE to lose state?

(In reply to Brion Vibber from comment #6)

I've noticed a few bugs coming through related to certain operations hiding
the keyboard and then that killing focus and causing selections and menus to
disappear. Is there a general problem where losing keyboard focus causes VE
to lose state?

Quite possibly; escalating.

  • Bug 67257 has been marked as a duplicate of this bug. ***

This seems to be because we programmatically move focus from the surface to the pasteTarget, and iOS Safari is very picky about when it allows a programmatic focus move to open the keyboard. Something like, it only works if you do it in direct response to a mouse/touch event. I tried a few solutions I found on the internet but I haven't gotten any of them to work yet.

Change 163662 had a related patch set uploaded by Jforrester:
Add a "Remove" context button to all Focussable nodes

https://gerrit.wikimedia.org/r/163662

Of course this behaves completely differently in iOS 8 (the keyboard stays up). *sigh*

(In reply to Ed Sanders from comment #11)

Of course this behaves completely differently in iOS 8 (the keyboard stays
up). *sigh*

Re-prioritising.

Change 163662 had a related patch set uploaded (by Jforrester):
[WIP] Add a "Remove" context button to all Focusable nodes

https://gerrit.wikimedia.org/r/163662

Jdforrester-WMF raised the priority of this task from "Low" to "Normal".Jun 9 2015, 6:45 PM
Jdforrester-WMF removed Jdforrester-WMF as the assignee of this task.
Jdforrester-WMF removed a project: Patch-For-Review.
Jdforrester-WMF changed the title from "VisualEditor: Selecting templates on iOS < 8 causes the on-screen keyboard to close, so they cannot be deleted" to "Selecting nodes (references/images/templates) on iOS < 8 causes the on-screen keyboard to close, so they cannot be deleted".Jun 16 2015, 8:49 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 21 2015, 6:20 PM

I have a patch which adds a delete action. The only question is should we hide it on desktop, because it looks okay and could be useful:

Change 230592 had a related patch set uploaded (by Esanders):
[WIP] Delete button for node context items

https://gerrit.wikimedia.org/r/230592

Change 163662 abandoned by Esanders:
[WIP] Add a "Remove" context button to all Focusable nodes

Reason:
Context items have moved on a fair bit. See I41109537d for latest attempt.

https://gerrit.wikimedia.org/r/163662

Mobile styling:

Change 230592 merged by jenkins-bot:
MobileContext: Provide a delete button for nodes' context

https://gerrit.wikimedia.org/r/230592

Jdforrester-WMF closed this task as "Resolved".Aug 11 2015, 6:45 PM
Jdforrester-WMF assigned this task to Esanders.

Add Comment