Page MenuHomePhabricator

VisualEditor: Console shows "Permission denied" on IE9 when VE is first initiated
Closed, ResolvedPublic8 Story Points

Description

From the console:

SCRIPT70: Permission denied
Main_Page, line 1 character 1

Filing to track this.


Version: unspecified
Severity: major

Details

Reference
bz63039

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 2:59 AM
bzimport set Reference to bz63039.

So after poking around for a bit I was able to get past this error with the following registry key set to "1":

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Internet Explorer\MAIN
\FeatureControl\FEATURE_PROTOCOL_LOCKDOWN\iexplore.exe

Isn't IE support fun?

Now the save button (bug #63043) changes color but clicking it results in "SCRIPT70: Permission denied" that IE's debugger says comes from the following line in jquery.js:

proxy=function(){
    return fn.apply(context,args.concat(core_slice.call(arguments)));
};

Hints on registry keys from http://stackoverflow.com/questions/5352057/script70-permission-denied-ie9

Looks like there may be some help in the newer versions of jquery: http://bugs.jquery.com/ticket/13936

  • Bug 63043 has been marked as a duplicate of this bug. ***

Got past part of the permission problem without messing with the registry (yay!) by looking at newer jQuery code and seeing how it avoided use of iframe. It is now stopping in setUpSurface.

Created attachment 14910
diff of changes to update jquery

Attached:

Updated to latest VE (which shares MW's JQuery?) and saw the problem again. Clicked IE's "Start debugging" in IE9 and wasn't able to reproduce it.

Returned to page, clicked IE's "Stop debugging" and then clicked VE's "Edit". Spinner went into infinite loop.

Now, what are the dev tools setting up to cause this behavior?

For the record, I haven't experienced this problem in weeks of messing around with VE in IE in either IE10 or IE11.

Jdforrester-WMF lowered the priority of this task from High to Low.Jan 9 2015, 10:33 PM
Jdforrester-WMF removed Catrope as the assignee of this task.Apr 17 2015, 5:54 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 14 2016, 5:25 PM

The iframe which is used to create the document is discarded and IE9 garbage collects it and wipes the document, even though we keep a pointer to the document.

Change 283427 had a related patch set uploaded (by Esanders):
Fix access of iframe-created document in IE9

https://gerrit.wikimedia.org/r/283427

Jdforrester-WMF closed this task as Resolved.Apr 18 2016, 3:40 PM
Jdforrester-WMF assigned this task to Esanders.
Jdforrester-WMF set the point value for this task to 8.
Jdforrester-WMF set Security to None.

Change 283427 merged by jenkins-bot:
Fix access of iframe-created document in IE9

https://gerrit.wikimedia.org/r/283427

Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptApr 20 2016, 12:02 AM