Page MenuHomePhabricator

Remove last edited pageimage from Special:Userprofile
Closed, ResolvedPublic

Description

Some of the most commonly vandalized pages on Wikipedia have to do with (you guessed it) sex. Unfortunately, that means that active vandal-fighters' last edits tend to be to those pages, so their mobile profiles (in Special:Mobileprofile) will show some pretty NSFW stuff a lot of the time.

The easy fix is just to remove the last edited pageimage. A longer-term fix might be to create a way to flag/blacklist pageimages on certain pages somehow, since they'll also be the problematic ones in the app, in search, etc.

Event Timeline

Maryana created this task.Feb 25 2015, 10:22 PM
Maryana raised the priority of this task from to Needs Triage.
Maryana updated the task description. (Show Details)
Maryana added a project: Readers-Web-Backlog.
Maryana added subscribers: Maryana, Deskana.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 25 2015, 10:22 PM

Change 193017 had a related patch set uploaded (by Deskana):
Remove all images and recent uploads from UserProfile

https://gerrit.wikimedia.org/r/193017

Change 193017 had a related patch set uploaded (by Deskana):
Remove all images and recent uploads from UserProfile
https://gerrit.wikimedia.org/r/193017

Why not just kill Special:UserProfile altogether? If it's gutted of the very little value it currently has, I don't see what sense there is in preserving what's left.

Elitre added a subscriber: Elitre.Feb 26 2015, 8:09 AM

The same problem applies to the last uploaded picture. What if I upload a "problematic" picture? This will be displayed accordingly in my mobile profile, until I upload something other … Whereas the last edited page will in most cases merely consist of a temporary problem (unless I mostly do edits on problematic pages or a problematic page edit is the last edit before going to sleep—or on a three weeks vacation without doing any further edits), the last uploaded picture could be displayed forever, if I don’t upload another picture afterwards … so unless you remove the display of the last uploaded picture as well, everybody will be forced to subsequently upload a dummy picture every time he uploads anything that he doesn’t want to be associated with in his mobile profile "forever" …

Change 193017 had a related patch set uploaded (by Deskana):
Remove all images and recent uploads from UserProfile
https://gerrit.wikimedia.org/r/193017

Why not just kill Special:UserProfile altogether? If it's gutted of the very little value it currently has, I don't see what sense there is in preserving what's left.

Can you please enlighten me on this "little value" of this "feature"?
I fail to see any value at all, and the naming is completely wrong, as it has nothing to do with a users profile.

Se4598 added a subscriber: Se4598.Feb 26 2015, 2:52 PM

Can you please enlighten me on this "little value" of this "feature"?
I fail to see any value at all, and the naming is completely wrong, as it has nothing to do with a users profile.

Most users don't have a user page. There is some value in outputting information about a user instead of a "no page exists here" error message, I think.

The problem is that the current implementation of a user profile (i.e., Special:UserProfile) is really weak and may be doing more harm than good.

I'd suggest being a little less rude and I'd suggest building consensus to kill this feature, which typically requires making strong arguments in a respectful manner. While I completely understand your frustration here (Special:UserProfile is just one example among many of bad ideas from the Wikimedia Foundation mobile team), I don't think your current tactics will be successful. That said, I've had very little progress in reining in the mobile team, so perhaps I'm not the best person to speak about strategy. :-)

I agree that Special:UserProfile sucks right now. I don't like where it's living, I don't like how it was implemented and deployed, and I don't like its functionality. It probably needs to be thrown out, but then the question becomes: what would we do next?

I don't think we want to break existing links to Special:UserProfile/<user>. One option might be to make Special:UserProfile an alias of Special:Contributions, at least temporarily. This is a constructive and actionable idea. What are your thoughts?

I don't think we want to break existing links to Special:UserProfile/<user>. One option might be to make Special:UserProfile an alias of Special:Contributions, at least temporarily. This is a constructive and actionable idea. What are your thoughts?

I agree. I don't know how long this feature has existed, but it is plausible that there are some links out there. Special:Contributions/<user> is the logical place for it to go.

A related point -- if there is a desire to create a nice-looking presentation of what a user has done recently, why would it be developed as a new feature? I would think this should have been conceived as a redesign of Special:Contributions from the beginning. Creating new features and new pages, on top of old ones, is one of the things that makes Wikimedia the incomprehensible labyrinth that keeps many new contributors away.

I agree the last edited page image is problematic, and also the last uploaded image doesn't necessarily provide a good representation of the user. For example, my last uploaded image has been a photograph of Brandon Harris for the last month. Clearly, that could be confusing.

Special:UserProfile/<user> suggests a user profile page, which it is not currently.
If the linking to this (imho completely futile) page should not be broken, the only valid alias is the real profile page, that's User:<user>.

Alsee added a subscriber: Alsee.EditedFeb 26 2015, 7:44 PM

The entire page is unhelpful at best, and the dick-pics demonstrate just how bad it is at worst. The dick-pics aren't the problem, the entire page is the problem. We have user pages where people can create their own profiles, and we have purely functional pages like Contributions to look up information on a user. Trying to impose software-generated "profile" pages is a big mistake. I'm guessing this was an attempt to enhance the "social networking", Facebook style. But editors don't use Wiki like they use Facebook, this sort of stuff is way off base.

This task is about removing the last edited pageimage from Special:Userprofile. This task is not about Special:Userprofile in general. I ask everybody to please stay on-topic.

Why not just kill Special:UserProfile altogether?

That's now covered by T90753.

This task is about removing the last edited pageimage from Special:Userprofile. This task is not about Special:Userprofile in general. I ask everybody to please stay on-topic.

But this here is just cosmetics on a completely useless non-feature. Don't put any effort in it.

@Saenger: Please see https://www.mediawiki.org/wiki/Bug_management/Phabricator_etiquette. It has been brought up before in T90632. If you continue to ignore it and add off-topic comments to tasks, your Phabricator account might get disabled. Thanks for your understanding.

@Saenger: Please see https://www.mediawiki.org/wiki/Bug_management/Phabricator_etiquette. It has been brought up before in T90632. If you continue to ignore it and add off-topic comments to tasks, your Phabricator account might get disabled. Thanks for your understanding.

OK, so can you tell me the page where this "feature" was/is discussed with the communities so I can talk at the right place? There should be a dedicated page at least in all the big wikipedias like deWP, enWP, nlWP and frWP, as well as in meta, the devs of this "feature" shoud know this places off-hand so I don't have to search for too long. I'll talk there further.

Ah, don't come to me with with mailing lists, that's off-wiki and doesn't count as proper discussion with the communities.

P.S.: I know, this is perhaps again against this strange phabiquette page, but as long as those in the ivory tower in Frisco don't come to the communities, they will have to live with community members coming here.

Snowolf added a subscriber: Snowolf.Mar 4 2015, 4:01 AM

Change 194451 had a related patch set uploaded (by Legoktm):
Remove Special:UserProfile functionality

https://gerrit.wikimedia.org/r/194451

Deskana removed a subscriber: Deskana.Mar 7 2015, 1:44 AM

@Maryana, your description above includes this suggestion: "A longer-term fix might be to create a way to flag/blacklist pageimages on certain pages somehow, since they'll also be the problematic ones in the app, in search, etc."

This has been tried:
http://wikimediafoundation.org/wiki/Resolution:Controversial_content

And rejected:
http://wikimediafoundation.org/wiki/Resolution:Personal_image_hiding_feature

Quoting from that second Board resolution:
"We affirm our support for better user choice and user preferences, but do not want to prescribe a specific mechanism for offering that choice."

That resolution, as far as I know, is still in effect. As I read it, the Board is on record specifically advising against features like Special:UserProfile.

Change 193017 merged by jenkins-bot:
Remove all images and recent uploads from UserProfile

https://gerrit.wikimedia.org/r/193017

Florian closed this task as Resolved.Mar 9 2015, 4:57 PM
Florian claimed this task.

Change was merged, so the original task description is resolved
-> closed