Page MenuHomePhabricator

FlaggedRevs edit notices don't render properly in VisualEditor
Closed, ResolvedPublic1 Story Points

Description

I try to edit any article in VE in https://ru.wikipedia.org/
and a pop-up window "edit notices" is empty, but there is a text "1 2 3...n notices"

Details

Related Gerrit Patches:

Event Timeline

Sunpriat created this task.Apr 14 2015, 3:25 AM
Sunpriat raised the priority of this task from to Needs Triage.
Sunpriat updated the task description. (Show Details)
Sunpriat added a project: VisualEditor.
Sunpriat added a subscriber: Sunpriat.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 14 2015, 3:25 AM

Thanks for taking the time to report this!
Could you please provide a specific example link to reproduce, and the steps how to trigger such a popup window?

Krinkle added a subscriber: Krinkle.EditedApr 14 2015, 11:18 AM

Not all pages are affected. I can reproduce the issue on those two pages, but the majority of other pages are unaffected.

These pages have in common that they're protected with FlaggedRevs. Compare to the wikitext editor:

{"visualeditor":{"result":"success","notices":{"revreview-locked":
<b>Note:</b>
Edits to this page are subject to review (<a href="/wiki/Wikipedia:Pending_changes" title="Wikipedia:Pending changes">help</a>).
<div id="mw-fr-logexcerpt"><ul> .. </ul> </div>

Only the first node (the bold word) shows up in VisualEditor.

Krinkle renamed this task from VE: in ru.wiki does not show the edit notices to FlaggedRevs edit notices don't render properly in VisualEditor.Apr 14 2015, 11:23 AM
Krinkle claimed this task.
Krinkle set Security to None.

Change 204038 had a related patch set uploaded (by Krinkle):
MWPopupTool: Don't assume editnotice html has a single wrapping element

https://gerrit.wikimedia.org/r/204038

That is a separate issue. The problem there is that ru.wikipedia.org has a global edit notice at MediaWiki:Editnotice-0 but is invisible to most users (only visible to sysops). See also T91715. I've converted it to use MediaWiki:Editnotice-notext. Fixed!

Change 204038 merged by jenkins-bot:
MWPopupTool: Don't assume editnotice html has a single wrapping element

https://gerrit.wikimedia.org/r/204038

Same issue as T95822?

Since those don't show anything at all, it's likely not the FlaggedRevs issue but the Editnotice-notext issue. Which is discussed at T91715 and T45013. Though doesn't have a proper task yet. Let's use T95822 for that.

Jdforrester-WMF closed this task as Resolved.Apr 14 2015, 3:41 PM
Jdforrester-WMF triaged this task as Normal priority.
Jdforrester-WMF edited projects, added OOUI, OOjs-UI-next-release; removed Patch-For-Review.
Jdforrester-WMF edited a custom field.
Jdforrester-WMF raised the priority of this task from Normal to High.Apr 14 2015, 5:53 PM
Jdforrester-WMF moved this task from Nominated to Done on the VisualEditor 2014/15 Q4 blockers board.

Change 204167 had a related patch set uploaded (by Catrope):
MWPopupTool: Don't assume editnotice html has a single wrapping element

https://gerrit.wikimedia.org/r/204167

Change 204168 had a related patch set uploaded (by Catrope):
MWPopupTool: Don't assume editnotice html has a single wrapping element

https://gerrit.wikimedia.org/r/204168

Change 204167 merged by jenkins-bot:
MWPopupTool: Don't assume editnotice html has a single wrapping element

https://gerrit.wikimedia.org/r/204167

Change 204168 merged by jenkins-bot:
MWPopupTool: Don't assume editnotice html has a single wrapping element

https://gerrit.wikimedia.org/r/204168

Neil_P._Quinn_WMF moved this task from To Triage to Q4 on the VisualEditor board.Apr 17 2015, 7:39 PM
Jdforrester-WMF moved this task from Backlog to Reviewing on the OOUI board.Apr 29 2015, 9:35 PM