Page MenuHomePhabricator

ContentTranslation adds several references with different name parameters, but the same content or same name and different content
Closed, ResolvedPublic1 Story Points

Description

In this edit, CX produced completely messed up references:

  • Several references with the same content but different names. Example with the first 2 references, named IDB and F1 with exactly the same content
  • Several references with the same name but different content. Example with reference named F1

Please, deactivate this tool until the many major bugs are fixed...

Details

Related Gerrit Patches:
mediawiki/extensions/ContentTranslation : wmf/1.26wmf21Fix: References are adapted with same content
mediawiki/extensions/ContentTranslation : wmf/1.26wmf20Fix: References are adapted with same content
mediawiki/extensions/ContentTranslation : masterFix: References are adapted with same content

Event Timeline

NicoV created this task.Aug 24 2015, 6:41 AM
NicoV raised the priority of this task from to Needs Triage.
NicoV updated the task description. (Show Details)
NicoV added a project: ContentTranslation.
NicoV added a subscriber: NicoV.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 24 2015, 6:41 AM
NicoV added a comment.Aug 24 2015, 6:57 AM

Other example

This tool is producing completely messed up articles, that requires a lot of human work to clean up.
Example of an article produced with many, many problems, none of them fixed by the contributor using CX.

Amire80 renamed this task from ContentTranslation messing up references to ContentTranslation adds several references with different name parameters, but the same content.Aug 24 2015, 7:26 AM
Amire80 triaged this task as High priority.
Amire80 set Security to None.
NicoV added a subscriber: Amire80.Aug 24 2015, 8:57 AM

@Amire80

The new title for this task hides the most important bug: that several references are added with the same name parameter, but with different content... which means that it's not the correct references that are visible in the article...

Amire80 renamed this task from ContentTranslation adds several references with different name parameters, but the same content to ContentTranslation adds several references with different name parameters, but the same content or same name and different content.Aug 24 2015, 9:23 AM

Very curious.

I am able to reproduce this problem when I translate from English to French - https://fr.wikipedia.org/w/index.php?title=Utilisateur:Amire80/Factorio_01&oldid=118019658 . I couldn't reproduce it in other languages. Could be something special about French Wikipedia or its {{Cite web}} template. I'm trying to debug this.

Amire80 moved this task from Needs Triage to CX6 on the ContentTranslation board.Aug 24 2015, 6:36 PM
Arrbee added a subscriber: Arrbee.Aug 25 2015, 7:05 AM

Timeboxed for investigation: 25 Aug. Candidate for LE-CX6-Sprint 3

Amire80 moved this task from Backlog to In Progress on the LE-CX6-Sprint 3 board.Aug 27 2015, 8:24 AM
Amire80 claimed this task.Aug 28 2015, 6:34 AM
Amire80 edited a custom field.

Yesterday I saw that it happens in Hebrew as well: https://he.wikipedia.org/w/index.php?title=%D7%91%D7%A0%D7%99_%D7%95%D7%92%27%D7%95%D7%9F&oldid=17427789

The regression probably started at https://gerrit.wikimedia.org/r/#/c/230485/ , but some odd things happen when I am trying to debug. That function runs at least twice (probably because of T104066), the first time with an empty paragraph, which is pointless. It's also very unclear to me when templates is it supposed to add to the templates array. Help will be appreciated - this is pretty urgent.

(I can consistently reproduce this by translating [[Factorio]] from English to French on my local wiki.)

santhosh claimed this task.Sep 2 2015, 6:18 AM

Change 235413 had a related patch set uploaded (by Santhosh):
Fix: References are adapted with same content

https://gerrit.wikimedia.org/r/235413

Change 235413 merged by jenkins-bot:
Fix: References are adapted with same content

https://gerrit.wikimedia.org/r/235413

Change 235441 had a related patch set uploaded (by KartikMistry):
Fix: References are adapted with same content

https://gerrit.wikimedia.org/r/235441

Change 235442 had a related patch set uploaded (by KartikMistry):
Fix: References are adapted with same content

https://gerrit.wikimedia.org/r/235442

Change 235441 merged by jenkins-bot:
Fix: References are adapted with same content

https://gerrit.wikimedia.org/r/235441

Change 235442 merged by jenkins-bot:
Fix: References are adapted with same content

https://gerrit.wikimedia.org/r/235442

KartikMistry moved this task from In Review to Done on the LE-CX6-Sprint 3 board.Sep 3 2015, 3:22 AM
Amire80 closed this task as Resolved.Sep 3 2015, 6:59 AM
Amire80 removed a project: Patch-For-Review.

Resolved, deployed, tested.

Johan moved this task from To Triage to Archive on the User-notice board.Sep 17 2015, 4:07 PM