Page MenuHomePhabricator

beta cluster missing vips command needed to render tiffs and pngs, pnmtojpeg for DjVus
Closed, ResolvedPublic

Description

From http://upload.beta.wmflabs.org/wikipedia/commons/thumb/8/83/Tracing_of_Field_Sheet_9_%28WOOS-18-3%29.tif/lossy-page1-472px-Tracing_of_Field_Sheet_9_%28WOOS-18-3%29.tif.jpg

Error creating thumbnail: /bin/bash: vips: command not found


This file should have thumbnails like its copy on Commons.

Instead, the following error message is shown:

Error generating thumbnail

Error creating thumbnail: /bin/bash: pnmtojpeg: command not found
ddjvu: writing pnm file: Broken pipe

Related Objects

Event Timeline

Bawolff created this task.Oct 27 2015, 7:49 PM
Bawolff raised the priority of this task from to Needs Triage.
Bawolff updated the task description. (Show Details)
Bawolff added a subscriber: Bawolff.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 27 2015, 7:49 PM

According to random production imagescaler mw1153 this is supposed to come from package libvips-tools

Hinote added a subscriber: Hinote.Oct 30 2015, 10:03 AM
Rillke renamed this task from beta cluster missing vips command needed to render tiffs and pngs to beta cluster missing vips command needed to render tiffs and pngs, pnmtojpeg for DjVus.Oct 30 2015, 11:32 AM
Rillke updated the task description. (Show Details)
Rillke set Security to None.
thcipriani triaged this task as Normal priority.Nov 2 2015, 8:30 PM

You can see it in action now on Beta Cluster, though it doesn't look very impressive as DjVu file rendering is currently broken there.

Do we have a task about this?

I think it's T116816: beta cluster missing vips command needed to render tiffs and pngs, pnmtojpeg for DjVus. Apparently it's been broken for a while. We've just worked around it in ProofreadPage code, though, so it doesn't matter much for this use case.

I installed the package needed for pnmtojpeg on the deployment-mediawiki* servers yesterday.

That would explain why it suddenly worked at all zoom levels!

Yeah I imagine we'll get a proper imagescaler set up in T84950 which will fix this properly. Right now we use any MW appserver, which don't necessarily have all the packages that puppetised imagescalers get

pnmtojpeg: command not found

that package is provided by https://packages.debian.org/sid/netpbm