Add the visual editor to Wikisource
Closed, ResolvedPublic8 Story Points

Description

It would be great to have the visual editor to edit books in Wikisource.

Kelson created this task.Mar 22 2015, 5:39 PM
Kelson updated the task description. (Show Details)
Kelson raised the priority of this task from to Needs Triage.
Kelson added subscribers: Kelson, Aubrey, CristianCantoro and 2 others.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 22 2015, 5:39 PM
GOIII added a subscriber: GOIII.Mar 22 2015, 5:55 PM
GOIII moved this task from Backlog to Next-up on the Wikisource board.Mar 22 2015, 6:14 PM

Has there been community discussion (link) about this or is this a personal request?

I'm at least aware about this:
https://lists.wikimedia.org/pipermail/wikisource-l/2015-March/002197.html

This is also a topic for offline because it's impossible to provide a good ZIM file of Wikisource as long as Parsoid is not able to deal correctly with it.

Two years ago we did a survey within the international Wikisource community: http://meta.wikimedia.org/wiki/Wikisource_Community_User_Group/Wikisource_survey_report#Visual_Editor

In the wikisource-l ml, we discussed about this a few times. It is definitely not me alone :-)

Gerardduenas added a subscriber: Gerardduenas.

It would be great if you reached a consensus in the village pump and provided the link to it

Tpt added a comment.Mar 23 2015, 3:29 PM

It would be great if you reached a consensus in the village pump and provided the link to it

I believe that the consensus about it is fairly clear. No need for discussions on different languages Scriptoriums.

Tpt set Security to None.
Tpt added a project: ProofreadPage.

Is this task asking for VisualEditor to be enabled for opt-in to edit the main and user namespaces right now, or to wait until T48580: Create a VisualEditor plugin to integrate with ProofreadPage is complete? If the second, that is a lot of work and won't happen soon.

Ankry added a subscriber: Ankry.Mar 23 2015, 4:59 PM
Ankry added a comment.EditedMar 23 2015, 6:00 PM
This comment has been deleted.
Elitre added a subscriber: Elitre.Mar 23 2015, 7:19 PM

Is this task asking for VisualEditor to be enabled for opt-in to edit the main and user namespaces right now, or to wait until T48580: Create a VisualEditor plugin to integrate with ProofreadPage is complete? If the second, that is a lot of work and won't happen soon.

As you can see, the task you mentioned is in this task's "Blocked By" field.

Jdforrester-WMF triaged this task as Low priority.Mar 26 2015, 5:28 PM

Is this task asking for VisualEditor to be enabled for opt-in to edit the main and user namespaces right now, or to wait until T48580: Create a VisualEditor plugin to integrate with ProofreadPage is complete? If the second, that is a lot of work and won't happen soon.

As you can see, the task you mentioned is in this task's "Blocked By" field.

Sure, but it was also written as a Site Request, so I assumed that the person doing that understood. I've removed that project as this request isn't actionable until then.

Hi James,
for many Wikisource, implementation of the VE in the ns0 is not-so important. As you are maybe aware, we have a Page: namespace that is the place where the transcription really happens, with the scan of the page of the book. I was aware of the owrk of Tpt and Rohit (if'm not mistaken), who tried to refactor the Proofread Page extension.

Hi James,
for many Wikisource, implementation of the VE in the ns0 is not-so important. As you are maybe aware, we have a Page: namespace that is the place where the transcription really happens, with the scan of the page of the book. I was aware of the owrk of Tpt and Rohit (if'm not mistaken), who tried to refactor the Proofread Page extension.

Yes, that is T48580: Create a VisualEditor plugin to integrate with ProofreadPage.

jayvdb added a subscriber: jayvdb.May 24 2015, 7:10 AM
Micru added a subscriber: Micru.May 30 2015, 2:49 PM
KRLS added a subscriber: KRLS.May 31 2015, 4:17 PM
Jdforrester-WMF renamed this task from Add Visual Editor to Wikisource to Add the visual editor to Wikisource.Apr 1 2016, 10:14 AM

Some notes from Wikimedia-Hackathon-2016 concerning WS Mainspace and proofreading system using VE: https://etherpad.wikimedia.org/p/ve-wikisource

Jdforrester-WMF closed this task as Resolved.Jun 22 2016, 1:23 PM
Jdforrester-WMF set the point value for this task to 8.
Jdforrester-WMF assigned this task to Tpt.

So, with T48580: Create a VisualEditor plugin to integrate with ProofreadPage closed, as of next Wednesday there will be a (basic) VisualEditor integration on Page: pages too. You can see it in action now on Beta Cluster, though it doesn't look very impressive as DjVu file rendering is currently broken there.

There are several improvements we will make, but for now I'm declaring this done. Great work, everyone! Next up will be real-world final testing, and then we can set about making it available by default for users on each of the Wikisources, in T138391.

It seems really nice!
Thanks everyone for making this happen.

Ankry added a comment.Jun 22 2016, 1:59 PM

So, with T48580: Create a VisualEditor plugin to integrate with ProofreadPage closed, as of next Wednesday there will be a (basic) VisualEditor integration on Page: pages too. You can see it in action now on Beta Cluster, though it doesn't look very impressive as DjVu file rendering is currently broken there.

This version does not seem to be functional yet:

Is there a working version elsewhere? I do not think it is ready for integration.

You can see it in action now on Beta Cluster, though it doesn't look very impressive as DjVu file rendering is currently broken there.

Do we have a task about this?

You can see it in action now on Beta Cluster, though it doesn't look very impressive as DjVu file rendering is currently broken there.

Do we have a task about this?

I think it's T116816: beta cluster missing vips command needed to render tiffs and pngs, pnmtojpeg for DjVus. Apparently it's been broken for a while. We've just worked around it in ProofreadPage code, though, so it doesn't matter much for this use case.

I couldn't reproduce – http://en.wikisource.beta.wmflabs.org/w/index.php?diff=721&oldid=720 – perhaps an intermittent bug?

You can see it in action now on Beta Cluster, though it doesn't look very impressive as DjVu file rendering is currently broken there.

Do we have a task about this?

I think it's T116816: beta cluster missing vips command needed to render tiffs and pngs, pnmtojpeg for DjVus. Apparently it's been broken for a while. We've just worked around it in ProofreadPage code, though, so it doesn't matter much for this use case.

I installed the package needed for pnmtojpeg on the deployment-mediawiki* servers yesterday.

I couldn't reproduce – http://en.wikisource.beta.wmflabs.org/w/index.php?diff=721&oldid=720 – perhaps an intermittent bug?

@Jdforrester-WMF: I agree with @Ankry - This version does not seem to be functional yet (...) Any attempt to edit header/footer seems to break them both...
It is easy to reproduce:

  1. step: Editing header and footer (added <div style="color:blue;"> in header and </div> in footer- see image
  2. step: Save Page -> Review your changes see image

editions of a header disappeared and been replaced with "</ div>"; editions of the footer have been transferred and mixed with the contents of the page...

Z.

I couldn't reproduce – http://en.wikisource.beta.wmflabs.org/w/index.php?diff=721&oldid=720 – perhaps an intermittent bug?

@Jdforrester-WMF: I agree with @Ankry - This version does not seem to be functional yet (...) Any attempt to edit header/footer seems to break them both...
It is easy to reproduce:

  1. step: Editing header and footer (added <div style="color:blue;"> in header and </div> in footer- see image
  2. step: Save Page -> Review your changes see image

    editions of a header disappeared and been replaced with "</ div>"; editions of the footer have been transferred and mixed with the contents of the page...

Can you file a new task, please?