Page MenuHomePhabricator

Create role for testing/developing LDAPAuth
Closed, ResolvedPublic

Description

Add a new role that will provision a wiki that uses LDAPAuth and an ldap server to interact with.

Related Objects

StatusAssignedTask
ResolvedDeskana
ResolvedAnomie
OpenNone
ResolvedAnomie
OpenNone
ResolvedTgr
ResolvedAnomie
OpenNone
OpenNone
OpenNone
ResolvedTgr
Resolveddemon
ResolvedTgr
ResolvedNone
Resolved Mattflaschen-WMF
ResolvedTgr
ResolvedAnomie
ResolvedAnomie
ResolvedAnomie
ResolvedDbrant
ResolvedMholloway
Resolvedbd808
Resolvedbd808

Event Timeline

bd808 created this task.Mar 1 2016, 7:00 PM
Restricted Application added a project: User-bd808. · View Herald TranscriptMar 1 2016, 7:00 PM
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald Transcript
bd808 triaged this task as Normal priority.Mar 1 2016, 7:00 PM

This might be as simple as extracting some things from ::role::wikitech.

bd808 moved this task from To Do to In Dev/Progress on the User-bd808 board.Mar 10 2016, 4:32 PM
bd808 moved this task from Backlog to In Progress on the MediaWiki-Vagrant board.Mar 10 2016, 8:26 PM

Change 277701 had a related patch set uploaded (by BryanDavis):
Allow global extension to be disabled per-wiki

https://gerrit.wikimedia.org/r/277701

Change 277702 had a related patch set uploaded (by BryanDavis):
[WIP] Add LdapAuthentication role

https://gerrit.wikimedia.org/r/277702

bd808 added a comment.Mar 16 2016, 1:06 AM

This might be as simple as extracting some things from ::role::wikitech.

I totally jinxed myself with that statement. :/

Change 277701 merged by jenkins-bot:
Allow global extension to be disabled per-wiki

https://gerrit.wikimedia.org/r/277701

bd808 added a comment.EditedMar 17 2016, 5:09 PM

The patch *almost* works. It turns out that there is a conflict with the bootstrapping of role::centralauth which was masked in my local testing due to CA being enabled on my local ldapauth wiki initially. The problem is that role::centralauth runs Mediawiki::Maintenance['Pass 0 of CentralAuth'] for all wikis (using the alldbs generated dblist). It really should use a dblist that only includes wikis where CA is installed.

Change 278536 had a related patch set uploaded (by BryanDavis):
Introduce foreachwikiwithextension

https://gerrit.wikimedia.org/r/278536

Change 278536 merged by jenkins-bot:
Introduce foreachwikiwithextension

https://gerrit.wikimedia.org/r/278536

Change 277702 merged by jenkins-bot:
Add LdapAuthentication role

https://gerrit.wikimedia.org/r/277702

bd808 closed this task as Resolved.Apr 2 2016, 6:11 PM
bd808 removed a project: Patch-For-Review.
bd808 moved this task from Needs Review/Feedback to Done on the User-bd808 board.
bd808 moved this task from Done to Archive on the User-bd808 board.Apr 13 2016, 4:08 PM
bd808 moved this task from In Progress to Done on the MediaWiki-Vagrant board.Jan 23 2017, 4:08 PM