Page MenuHomePhabricator

Update extensions which are deployed on the Wikimedia cluster to use AuthManager
Closed, ResolvedPublic

Description

See AuthManager RfC (for now) and T91105: RfC: AuthManager. Some implementation details are still pending so consider all subtasks blocked on T91699 and T110278. List based on T91303 and T110414.

Related Objects

StatusAssignedTask
ResolvedDeskana
ResolvedAnomie
OpenNone
ResolvedAnomie
OpenNone
ResolvedTgr
ResolvedAnomie
OpenNone
OpenNone
OpenNone
Resolveddemon
ResolvedTgr
ResolvedNone
Resolved Mattflaschen-WMF
ResolvedTgr
ResolvedAnomie
ResolvedAnomie
ResolvedJoe
ResolvedJoe
Resolvedhashar
Resolvedbd808
ResolvedAnomie
ResolvedKrinkle
OpenNone
ResolvedJanZerebecki
ResolvedKrinkle
ResolvedTgr
DuplicateNone
ResolvedAnomie
ResolvedAnomie
ResolvedAnomie
ResolvedAnomie
ResolvedAnomie
ResolvedAnomie
Resolvedbd808
ResolvedAnomie
ResolvedTgr
ResolvedTgr
ResolvedTgr
ResolvedTgr
ResolvedDereckson
ResolvedAnomie
ResolvedTgr
ResolvedTgr
ResolvedAnomie
ResolvedNikerabbit
ResolvedAnomie
ResolvedTgr
ResolvedAnomie
ResolvedTgr
Resolveddemon
ResolvedAnomie
ResolvedAnomie
ResolvedJdforrester-WMF
ResolvedYurik
ResolvedYurik
ResolvedMilimetric

Event Timeline

Tgr created this task.Aug 26 2015, 6:21 AM
Tgr raised the priority of this task from to Needs Triage.
Tgr updated the task description. (Show Details)
Tgr added a subscriber: Tgr.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 26 2015, 6:21 AM
Tgr updated the task description. (Show Details)Aug 26 2015, 6:27 AM
Tgr updated the task description. (Show Details)Aug 26 2015, 6:41 AM
Quiddity updated the task description. (Show Details)Aug 26 2015, 11:18 PM
Tgr updated the task description. (Show Details)Aug 27 2015, 5:56 AM
bd808 triaged this task as Normal priority.Aug 28 2015, 5:40 PM
bd808 added a subscriber: bd808.
Nikerabbit changed the status of subtask T111486: Update Translate to use AuthManager from Open to Stalled.Sep 9 2015, 7:19 AM
Anomie added a subscriber: Anomie.

I removed T110461 because it was closed as a duplicate of T110288 and still having it in the list keeps confusing me.

Restricted Application added a subscriber: Luke081515. · View Herald TranscriptMay 23 2016, 6:57 PM
greg awarded a token.May 31 2016, 4:57 PM
greg added a subscriber: greg.
demon added a subscriber: demon.Jun 1 2016, 4:01 PM
Anomie closed this task as Resolved.Jun 13 2016, 3:55 PM
Anomie claimed this task.

Let's call this done, since AuthManager has been enabled with no known ill effect. T137174 isn't really a blocker, just an external followup.