Page MenuHomePhabricator

Update ConfirmEdit to use AuthManager
Closed, ResolvedPublic

Description

Should be a PreAuthenticationProvider.

Details

Related Gerrit Patches:

Related Objects

StatusAssignedTask
ResolvedDeskana
ResolvedAnomie
OpenNone
ResolvedAnomie
OpenNone
ResolvedTgr
ResolvedAnomie
OpenNone
OpenNone
OpenNone
ResolvedTgr
Resolveddemon
ResolvedTgr
ResolvedNone
Resolved Mattflaschen-WMF
ResolvedTgr
ResolvedAnomie
ResolvedDbrant
ResolvedMholloway
ResolvedTgr

Event Timeline

Tgr created this task.Aug 26 2015, 7:03 AM
Tgr raised the priority of this task from to Needs Triage.
Tgr updated the task description. (Show Details)
Tgr added subscribers: Aklapper, Tgr.
Restricted Application added a subscriber: Florian. · View Herald TranscriptAug 26 2015, 7:03 AM
Restricted Application added a subscriber: StudiesWorld. · View Herald TranscriptNov 16 2015, 8:52 AM
Anomie added a subscriber: Anomie.Mar 17 2016, 4:33 PM

Note ConfirmEdit currently really doesn't play nice with the AuthManager WIP code, because the new ApiAMCreateAccount (and probably ApiClientLogin too) isn't recognized by ConfirmEdit to do its parameters but still is going to hit its hooks on AbortNewAccount (and probably AbortLogin too).

Change 285350 had a related patch set uploaded (by Gergő Tisza):
[WIP] Add AuthManager support

https://gerrit.wikimedia.org/r/285350

Tgr added a comment.May 2 2016, 4:58 PM

ReCaptcha (both versions) does not seem to work with AuthManager's compatibility hacks; the others are OK.

Anomie added a comment.May 2 2016, 5:27 PM

the others are OK.

Is that after you AuthManagerized the others in https://gerrit.wikimedia.org/r/285350?

Tgr added a comment.May 2 2016, 5:42 PM

AuthManager-enabled core + ReCaptcha does not work, with or without that patch. Non-AuthManager-enabled core + any captcha with the patch should work, although I only tested a few combinations.

Not a blocker for WMF deployment but it's bundled with the tarball so it needs to be done before the final 1.27 release. I have a half-baked patch for ReCaptcha but I figured it makes more sense to work on the WMF-deployed extensions first, since that blocks testing in production.

Change 286682 had a related patch set uploaded (by Gergő Tisza):
[WIP] Add AuthManager support for ReCaptcha, ReCaptchaNoCaptcha

https://gerrit.wikimedia.org/r/286682

Change 285350 merged by jenkins-bot:
Add AuthManager support to SimpleCaptcha, QuestyCaptcha, FancyCaptcha, MathCaptcha

https://gerrit.wikimedia.org/r/285350

Change 286682 merged by jenkins-bot:
Add AuthManager support for ReCaptcha, ReCaptchaNoCaptcha

https://gerrit.wikimedia.org/r/286682

Anomie closed this task as Resolved.May 16 2016, 7:35 PM
Anomie assigned this task to Tgr.

Change 289167 had a related patch set uploaded (by Gergő Tisza):
Add AuthManager support to SimpleCaptcha, QuestyCaptcha, FancyCaptcha, MathCaptcha

https://gerrit.wikimedia.org/r/289167

Change 289167 merged by jenkins-bot:
Add AuthManager support to SimpleCaptcha, QuestyCaptcha, FancyCaptcha, MathCaptcha

https://gerrit.wikimedia.org/r/289167

Change 289172 had a related patch set uploaded (by Gergő Tisza):
Add AuthManager support for ReCaptcha, ReCaptchaNoCaptcha

https://gerrit.wikimedia.org/r/289172

Change 289172 merged by jenkins-bot:
Add AuthManager support for ReCaptcha, ReCaptchaNoCaptcha

https://gerrit.wikimedia.org/r/289172