Page MenuHomePhabricator

Use keyboards arrows with an inline template produces an unexpected behavior on VE.
Closed, ResolvedPublic8 Story Points

Description

Description on actions:

  1. Go to that article for example
  2. put your cursor at the left of "—We Also Walk Dogs" (setup by a template)
  3. hit right arrow on keyboard, the template is selected
  4. hit right arrow on the keyboard :
    1. expectation: the cursor moves to the right of the template
    2. reality: the cursor stays on the left.

Feedback, tested on Firefox ESR 31.2, XP and Chromium 48.0.2564.82 Ubuntu 14.04.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 4 2016, 1:55 PM
Aklapper renamed this task from Use keyboards arriows with an inline template produces an unexpected behavior on VE. to Use keyboards arrows with an inline template produces an unexpected behavior on VE..Mar 4 2016, 2:23 PM
Pols12 added a subscriber: Pols12.Mar 5 2016, 3:31 PM

This problem occurs with combination of a template and a formatting markup (bold, italic...).

Probably a duplicate of T123608

I think it's actually fixed by @dchan's recent patch on T124318 -- it's a cursoring-right-off-a-focused-block bug, after all.

Indeed, it now seems to work well on test.wp.

DLynch closed this task as Resolved.Apr 4 2016, 3:56 PM
DLynch assigned this task to dchan.
Jdforrester-WMF triaged this task as Normal priority.Apr 8 2016, 4:46 PM
Jdforrester-WMF set the point value for this task to 8.
Jdforrester-WMF moved this task from To Triage to TR3: Language support on the VisualEditor board.