Don't hide categories with 0 current members from Special:Categories
Closed, ResolvedPublic

Description

Special:Categories hides existing categories currently having 0 members.

This has has several drawbacks:

  1. When Special:Categories is used to find an appropriate category for a new article, and a category page has already been set up explicitly for this article type, it is not found. → Authors 'invent' their own categories. → Goodbye orderly development of a wiki!
  2. Categories meant for QA purposes tend to be temporarily empty, when all pending work is done. While it may be nice to see to-do-lists shrink, it is counterproductive, when you do not see where to place a new QA job.
  3. In wikies using multiple languages, authors very often insert category tags in the language they actually use, resulting in various duplications of categories. (Same applies to misspelled, and variant-spelled category names) During cleanup of such situations, it is vital that one gets a complete and comprehensive list of all there is, most specifically already created category pages.

    (Currently, you need to have several windows of Special:Categories open (in chunks of 5000s sorted top down) and even more Special:Allpages (in chunks of 200, sorted 3 per row left to right) → finding related entries, or dupliates, is a real pain in the ass. Excuse me. I want to say, it's frustrating, and consuming much too much time)
  4. There are likely more problems, which I just did not enocounter up to now.

Suggestion: include all existing category pages in Special:Categories, even if there are 0 members to the category.

Enhancement suggestion: If there is a justification for the current behaviour of Special:Categories, make it selectable by user input. In this case, I'd suggest to add a "show only categories with more than [ ... ] members" selection, which likely comes handy to avoid the disturbing 5000 limit sometimes, too. If you want to make it more comfortable, add another selection and make it: "show only categories with more than/less than [ N ] members"

Hint: If the 0 members problem, at least, is avoidable with the upcoming report extension, and we will be able to use the report extension in the Wikipedia installations, I for one would not mind waiting for it, and not pursue this bug any further.


Version: 1.11.x
Severity: major
URL: http://ksh.wikipedia.org/w/index.php?title=Spezial:Categories&limit=5555&offset=0

Details

Reference
bz10915
bzimport raised the priority of this task from to Low.
bzimport set Reference to bz10915.
bzimport added a subscriber: Unknown Object (MLST).

robchur wrote:

This might be doable with a UNION, or some other trick if that's too expensive.

ayg wrote:

This is working as designed at present. Categories are considered not to exist if they contain no members, and whether there happens to be page content corresponding to their name is ignored going in both directions: they exist if they contain members and have no page, they don't exist if they contain no members but have a page. When a category table is introduced, this change would come free if desired, although I had been thinking I would preserve existing functionality and not display categories with zero entries.

How are categories supposed to be deleted, if we do this? Removing all members *plus* deleting the page? That possibly makes more sense than being able to "delete" a category by just removing all members.

vvv added a comment.Mar 20 2008, 7:18 PM

(In reply to comment #2)

How are categories supposed to be deleted, if we do this? Removing all members
*plus* deleting the page? That possibly makes more sense than being able to
"delete" a category by just removing all members.

And what about categories like [[en:CAT:CSD]]?

ayg wrote:

Well, what about them? Should they show on Special:Categories or not?

This could currently be implemented by deleting one line from the file, by the way, so it's only a question of whether to do it.

vvv added a comment.Apr 29 2008, 7:40 AM

(In reply to comment #4)

Well, what about them? Should they show on Special:Categories or not?

This could currently be implemented by deleting one line from the file, by the
way, so it's only a question of whether to do it.

I'm sure we need it to clean up empty categories.

ayg wrote:

How would empty categories be "cleaned up"? Note that in this sense, "categories" may or may not have associated category pages, so an "empty category" really has no existence at all except a historical one. (Well, if the category member count is accurate, anyway.)

aaron added a comment.Dec 30 2008, 4:35 PM

(In reply to comment #5)

(In reply to comment #4)
> Well, what about them? Should they show on Special:Categories or not?
>
> This could currently be implemented by deleting one line from the file, by the
> way, so it's only a question of whether to do it.
>

I'm sure we need it to clean up empty categories.

You mean to find and delete pages?

related: bug 26411

matmarex updated the task description. (Show Details)Nov 30 2016, 4:34 PM
matmarex set Security to None.

Now that a 'category' table exists (since MW 1.13, heh), and now that the definition of category existence has been changed to "has any members, or has a description page" (T28411 / https://gerrit.wikimedia.org/r/#/c/298791/), I think we could easily do this by just removing the condition.

matmarex claimed this task.Nov 30 2016, 4:43 PM

Change 324486 had a related patch set uploaded (by Bartosz Dziewoński):
CategoryPager: Allow categories with no members to be shown

https://gerrit.wikimedia.org/r/324486

Jdforrester-WMF renamed this task from Special:Categories hides categories having 0 current members to Don't hide categories with 0 current members from Special:Categories.Nov 30 2016, 7:22 PM
Jdforrester-WMF closed this task as Resolved.
Jdforrester-WMF edited projects, added User-notice; removed Patch-For-Review.

Change 324486 merged by jenkins-bot:
CategoryPager: Allow categories with no members to be shown

https://gerrit.wikimedia.org/r/324486