Page MenuHomePhabricator

Ingenico: iDEAL 'no valid providers' error from one unavailable bank
Closed, ResolvedPublic2 Story Points

Description

The donor in ZD #215861 received an error using iDEAL: "the ideal form doesn't seem to be working (instantly redirects back to form instead of going to payment provider)". They're using Firefox 44.0.2 on windows 7 and entered the form at this url: https://payments.wikimedia.org/index.php/Special:GlobalCollectGateway?title=Special%3AGlobalCollectGateway&ffname=rtbt-ideal&language=en&country=NL&frequency=onetime&amountGiven=&uselang=en&bannerhistlog=d45364f1b2d607fb

I am able to locate their attempts at the Ingenico portal, where they received a Status 100 error: NO VALID PROVIDERS FOUND FOR COMBINATION MERCHANTID: XXXX, PAYMENTPRODUCT: 809, COUNTRYCODE: NL, CURRENCYCODE: EUR .

@Ppena has suggested this may be caused by the donor using the back button on the browser to change the selected bank. I'm unable to replicate this error (using the donor's url or the back button), so I will follow up with the donor to see if the back button is related. If we see more instances/get more feedback I will update here.

Details

Related Gerrit Patches:
mediawiki/extensions/DonationInterface : masterRemove Knab from iDEAL options

Event Timeline

MBeat33 created this task.Mar 29 2016, 6:21 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 29 2016, 6:21 PM
MBeat33 triaged this task as Medium priority.Mar 29 2016, 6:48 PM
MBeat33 raised the priority of this task from Medium to High.Mar 29 2016, 7:35 PM

So it turns out that one of the banks, Knab, yields this error - donors get an unresponsive form and I'm able to replicate it. Can we remove this bank from the options listed? I'm bumping this up in priority as we're likely to see lots more of this error when fundraising emails go out in NL this week.

What is the best process for updating the bank listings on the iDEAL form? We've run into similar things in T125470: 'continue' button on the iDeal donation form not working and it would be good to have a quick way to respond to these outages.

MBeat33 renamed this task from Ingenico: iDEAL 'no valid providers' error to Ingenico: iDEAL 'no valid providers' error from one unavailable bank.Mar 29 2016, 7:55 PM
AndyRussG claimed this task.Apr 4 2016, 5:31 PM
AndyRussG moved this task from Backlog to Doing on the Fundraising Sprint Ghostbusting board.
awight updated the task description. (Show Details)Apr 4 2016, 11:27 PM
DStrine moved this task from Inbox to Data issues/requests on the Wikimedia-Fundraising board.
DStrine added a subscriber: DStrine.

note: we have take Ideal down until this can be sorted out

note: we have take Ideal down until this can be sorted out

Would be great if this could be communicated to the community and the willing people to donate. iDeal is by far the most popular way to pay online in the Netherlands.

DStrine added a comment.EditedApr 5 2016, 9:24 PM

@Sjoerddebruin

We're working with the payment processor and hope to have a fix soon.

We update banners as quickly as possible for available donation options. Donors and the community are always welcome to email donate@wikimedia.org for current options & availability of any payment method.

Change 281866 had a related patch set uploaded (by Awight):
Remove Knab from iDEAL options

https://gerrit.wikimedia.org/r/281866

awight added a subscriber: awight.Apr 6 2016, 1:34 AM

There is a workaround submitted for review, which is worth review and merge while we wait for a longer-term fix.

However, the points made in comments above are well taken--the first aid kit for iDEAL needs to be much more readily available, and for everyone with production access if possible. We should build the bank list using dynamic configuration, please see T128693 for a forms refactor that blocks swift action on this and other annoyances. It would be extra saucy if parameters sent with the original paymentswiki request could also be used to override even the dynamic configuration, so a bank could be omitted almost instantly by anyone with meta or donate access.

awight added a comment.Apr 6 2016, 1:54 AM

TODO: The error codes we ran into should be added to the Ingenico error_map and to processReponse.

Mbch331 added a subscriber: Mbch331.Apr 6 2016, 7:52 AM

Change 281866 merged by jenkins-bot:
Remove Knab from iDEAL options

https://gerrit.wikimedia.org/r/281866

This morning @Pcoombe re-enabled iDEAL. According to the server logs, we got responses with status OK for almost all banks. Only Knab had mostly NOK ("not OK") statuses--the same error described here in the task description. @Cdentinger deployed the above patch to remove Knab around 16:30 UTC today.

AndyRussG added a comment.EditedApr 6 2016, 9:09 PM

Closing, since the deployed patch seems to have effectively removed Knab. We can wait for word from GlobalCollect about re-enabling it.

AndyRussG closed this task as Resolved.Apr 6 2016, 9:09 PM
AndyRussG moved this task from Doing to Done on the Fundraising Sprint Ghostbusting board.

Thanks for ignoring my message btw. It's almost impossible to discuss with the donation departement of the WMF.

@Sjoerddebruin
Hi, thank you for your initial constructive message, and your interest in solving the communication problems.

The situation is that iDEAL availability fluctuates wildly, I can count 50 downtime notifications from various banks over the past two months. On top of that, we have multiple legacy code issues as you can see from T92699. We prioritized deploying the technical fixes to get the method back up, and while it was down we hid the iDEAL method from donors.

Your suggestion that we communicate this sort of outage is worth pursuing... I'm curious how you imagine this working, though. Would we have a placeholder on the donation pages, with a disabled iDEAL button perhaps? Would we put messages on the banners explaining that iDEAL was down for maintenance, come back in 24 hours? Perhaps we would let donors click on iDEAL but explain the outage on the final payments page? Which community do you suggest we communicate outages to? Are there questions coming into the nl village pump or somewhere else, where Fundraising staff are not responding to FAQs about the method outage?

@Sjoerddebruin
Hi, thank you for your initial constructive message, and your interest in solving the communication problems.
The situation is that iDEAL availability fluctuates wildly, I can count 50 downtime notifications from various banks over the past two months. On top of that, we have multiple legacy code issues as you can see from T92699. We prioritized deploying the technical fixes to get the method back up, and while it was down we hid the iDEAL method from donors.
Your suggestion that we communicate this sort of outage is worth pursuing... I'm curious how you imagine this working, though. Would we have a placeholder on the donation pages, with a disabled iDEAL button perhaps? Would we put messages on the banners explaining that iDEAL was down for maintenance, come back in 24 hours? Perhaps we would let donors click on iDEAL but explain the outage on the final payments page? Which community do you suggest we communicate outages to? Are there questions coming into the nl village pump or somewhere else, where Fundraising staff are not responding to FAQs about the method outage?

Hi! As I said, iDeal is by far the most used online payment method. Most people don't have a creditcard and don't want anything like PayPal.

I'm a volunteer of the Dutch Wikipedia OTRS helpdesk and we now get daily e-mails about donations. Most are asking if the donation banner is real (probably due to the different design) and the other e-mails are about issues with paying. A error page with information about manual transfer via IBAN would be the best thing to do if iDEAL is not working, people actually ask us all the time about just a IBAN. All this will benefit the WMF, of course.

Most people in the Netherlands only use Wikipedia, a message in our village pump will be enough.

Thanks.

@Sjoerddebruin, please feel free to move any OTRS messages related to donating to the foundation into the folder called wm-donations in OTRS. They are automatically forwarded from there to Wikimedia donor services. Thank you!

@Sjoerddebruin

We understand that Ideal is very popular. I have added a task to our backlog: T132372

We may be able to implement text directly on the form that gives context to the issue and when it will be corrected.

mmodell removed a subscriber: awight.Jun 22 2017, 9:44 PM