Machine translation in Content translation from nowiki to nnwiki broken
Closed, ResolvedPublic

Description

Machine translation from nowiki to nnwiki is broken, note that the mid column use "er en kirke", while it should read "er ei kyrkje".

Note also the text in the right pane which reads "Maskinomsetjing Ikkje tilgjengeleg for norsk (nynorsk)", that is "Machine translation isn't available for Norwegian (nynorsk)".

Note also that "Brattahlíð" use characters that are unusual in Norwegian, and that could possibly create trouble.

Timeboxed to 20th May 2016

jeblad created this task.Apr 8 2016, 9:59 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 8 2016, 9:59 PM
jeblad edited the task description. (Show Details)Apr 8 2016, 10:02 PM
Amire80 changed the title from "Content translation from nowiki to nnwiki broken" to "Machine translation in Content translation from nowiki to nnwiki broken".Apr 10 2016, 6:51 PM
Amire80 triaged this task as "High" priority.
Amire80 added a project: WorkType-Maintenance.

https://cxserver.wikimedia.org/v1/#!/Machine_translation/post_v1_mt_from_to_provider from no->nn / Apertium / Er en kirke so issue is not in cxserver I think.

The issue is that your source language is nb (which is not selectable) instead of no. How did you start translating this article?

Work-around is to start new translation with no as the source language.

Checking again the counts in the database, this might be a widespread issue:

mysql:wikiadmin@db1029 [wikishared]> select count(*) from cx_translations where translation_source_language = 'nb';
61

mysql:wikiadmin@db1029 [wikishared]> select count(*) from cx_translations where translation_target_language = 'nb';
3132

mysql:wikiadmin@db1029 [wikishared]> select count(*) from cx_translations where translation_target_language = 'no';
89

mysql:wikiadmin@db1029 [wikishared]> select count(*) from cx_translations where translation_source_language = 'no';
662

Started from "In other languages" where the link for "norsk (nynorsk)" is https://no.wikipedia.org/w/index.php?title=Special:ContentTranslation&page=Tjodhilds+kirke&from=no&to=nn

It seems like the service point @Nikerabbit posted in T132217#2194246 gives a correct answer, the text "Er en kirke" should translate as "Er ei kyrkje".

Upon landing at the special page it is https://nn.wikipedia.org/w/index.php?title=Spesial:Innhaldsomsetjing&page=Tjodhilds+kirke&from=nb&to=nn&targettitle=Tjodhilds+kyrkje&campaign=interlanguagelink Note the change of "from=nb" It is whatever rewrites the first URL into the second that is the problem.

When changing the "from=nb" into "from=no" I get a nearly blank page in Firefox, but putting the cursor in the address field and hitting return the page reload, I get the dialog as if I did not click the link, and gets the usual translation page.

Seems like I can't recreate the blank page, not sure why.

Another problem T132435 is that clicking on the first paragraph with text the throbber starts flashing, but it never finishes. Clicking on it once more replaces it with the translated text.

Inside the translation page when it is forced to reload it seems like everything works as it should. (Except for the double-click-thingy.)

Okay maybe the rewrite to nb is intentional, but then the backend should support it as well. @santhosh do you remember what we did last time?

jeblad added a comment.EditedApr 14 2016, 9:24 PM

Before anyone starts complaining; this blocks contribution to Wikidata:Europeana Art History Challenge/Norway.

Why aren't we translating the URL from and to params in in ext.cx.dashboard.js using ContentTranslationDomainCodeMapping / SiteMapper?

Arrbee added a subscriber: Arrbee.May 9 2016, 7:12 AM

@Amire80 will create a patch for review

I could reproduce it on Wednesday, but now I tried again I cannot. Did anything change since Wednesday? @jeblad, is it still broken?

Change 289009 had a related patch set uploaded (by Amire80):
Use SiteMapper to normalize the language code in the article selector

https://gerrit.wikimedia.org/r/289009

Arrbee edited the task description. (Show Details)
Arrbee reassigned this task from Amire80 to Nikerabbit.May 25 2016, 8:15 AM
Arrbee added a subscriber: Amire80.

Follow up verifications for T132217, T132435, and T134219 as well

Change 290667 had a related patch set uploaded (by Nikerabbit):
Never allow unsupported source or target languages in the page selector

https://gerrit.wikimedia.org/r/290667

Change 290668 had a related patch set uploaded (by Nikerabbit):
Introduce getLanguageCodeForWikiDomain to SiteMapper

https://gerrit.wikimedia.org/r/290668

Change 290678 had a related patch set uploaded (by Nikerabbit):
Remove "no" from cxserver and replace it with "nb".

https://gerrit.wikimedia.org/r/290678

Change 290669 had a related patch set uploaded (by Nikerabbit):
Use getLanguageCodeForWikiDomain in interlanguage entrypoint

https://gerrit.wikimedia.org/r/290669

Change 290672 had a related patch set uploaded (by Nikerabbit):
Use getLanguageCodeForWikiDomain in MT tool

https://gerrit.wikimedia.org/r/290672

Change 290667 merged by jenkins-bot:
Never allow unsupported source or target languages in the page selector

https://gerrit.wikimedia.org/r/290667

Change 290668 merged by Nikerabbit:
Introduce getLanguageCodeForWikiDomain to SiteMapper

https://gerrit.wikimedia.org/r/290668

Change 290669 merged by jenkins-bot:
Use getLanguageCodeForWikiDomain in interlanguage entrypoint

https://gerrit.wikimedia.org/r/290669

Change 290672 merged by jenkins-bot:
Use getLanguageCodeForWikiDomain in MT tool

https://gerrit.wikimedia.org/r/290672

Change 290678 merged by jenkins-bot:
Remove "no" from cxserver and replace it with "nb".

https://gerrit.wikimedia.org/r/290678

Deployed in Production. Working fine.

Change 289009 abandoned by Nikerabbit:
Use SiteMapper to normalize the language codes

Reason:
Done in other patches.

https://gerrit.wikimedia.org/r/289009

Arrbee closed this task as "Resolved".Jun 14 2016, 7:11 AM

We believe that this issue has now been fixed. Please reopen if you see this happening again. Thanks.