Page MenuHomePhabricator

Enwiki is a wikitext-primary site, and the visual editor is the primary editor for new logged-in editors
Closed, ResolvedPublic8 Story Points

Description

This does not seem to be the intended behavior. It's working correctly for logged-out editors.

Event Timeline

Restricted Application added a project: VisualEditor. · View Herald TranscriptApr 15 2016, 4:48 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Izno added a subscriber: Izno.Apr 15 2016, 6:14 PM
Alsee added a subscriber: Alsee.Apr 26 2016, 3:16 PM

Note: With the Wikitext editor loading first as primary/default, the popup for Continue_Editing/Switch_Editors will need a text-tweak to "Switch to Visual Editor".

I'm not sure that people who load the wikitext editor first are seeing any such pop up.

Elitre added a subscriber: Elitre.May 2 2016, 5:11 AM
Jdforrester-WMF closed this task as Declined.May 10 2016, 7:26 PM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

Yup, sorry about this.

I didn't configure the wiki exactly as I had intended, which indeed had the effect that new users who've never edited before will get the visual editor on first edit (unless their machine is incompatible). The plan was to make that part of change subsequently to the main change, which was to provide only one edit tab (with the editor chosen by the user) instead of having two.

Now that both these changes are deployed, I think going back and then forward would cause confusion and disruption with no benefits for our editors. The benefit for users following the plan would have been a lack of unexpected changes. However, this is not something I can create from the spilt milk we now have, sadly.

Consequently, I won't be undoing this change, as I don't think there is overall value in so doing. In future I'll take more care in writing these kinds of changes, sorry.

Note: User:Fram followed-up this task on-wiki, currently at this page on WP:VPT.

Change 288450 had a related patch set uploaded (by Jforrester):
Follow-up 6dbf876: Move VisualEditor to secondary status on English Wikipedia

https://gerrit.wikimedia.org/r/288450

Elitre changed the task status from Open to Stalled.May 15 2016, 3:38 PM

I wanted to convey the fact that the patch for the blocking task I added needs to land on the wikis first and then we can proceed with fixing this one. This is just my attempt at doing so :)

Change 288450 merged by jenkins-bot:
Follow-up 6dbf876: Move VisualEditor to secondary status on English Wikipedia

https://gerrit.wikimedia.org/r/288450

Mentioned in SAL [2016-05-19T23:25:01Z] <dereckson@tin> Synchronized wmf-config/InitialiseSettings.php: Move VisualEditor to secondary status on English Wikipedia (T132806) (duration: 00m 29s)

Jdforrester-WMF closed this task as Resolved.May 19 2016, 11:28 PM
Jdforrester-WMF claimed this task.
Jdforrester-WMF set the point value for this task to 8.

Should now be working as discussed, from my testing.