Page MenuHomePhabricator

Fix "1 notice" on more wikis
Open, NormalPublic8 Story Points

Description

Like T95822 and T103693, but for these: (some of which may actually be fine, but most won't)

Please update this description if you find any more, and remove any that are false positives.

Steps for migrating at https://phabricator.wikimedia.org/T95822#1469641 (simple case) and https://phabricator.wikimedia.org/T91715#1160062 (advanced case).

Event Timeline

Restricted Application added a project: VisualEditor. · View Herald TranscriptMay 10 2016, 11:01 PM
Restricted Application added subscribers: Zppix, revi, Aklapper. · View Herald Transcript

No false positives that I could find.

Jdforrester-WMF triaged this task as Normal priority.May 16 2016, 9:27 AM
Jdforrester-WMF moved this task from To Triage to TR1: Releases on the VisualEditor board.
Jdforrester-WMF set the point value for this task to 8.
Elitre added a comment.Jul 4 2016, 7:55 AM

Looks fine now? (and TYVM!)

Yep, this helpful user reviewed my vecwiki edits: https://vec.wikipedia.org/wiki/Utente:Vajotwo

AlexMonk-WMF updated the task description. (Show Details)
AlexMonk-WMF updated the task description. (Show Details)
Krinkle removed a subscriber: Krinkle.Jul 12 2016, 5:15 PM
AlexMonk-WMF updated the task description. (Show Details)
Josve05a updated the task description. (Show Details)
Restricted Application added subscribers: Poyekhali, Steinsplitter. · View Herald TranscriptJul 31 2016, 7:38 PM
Josve05a updated the task description. (Show Details)Sep 15 2016, 2:00 AM

I just did both that and MediaWiki:Editnotice-3

Elitre added a subscriber: Krinkle.Jan 23 2017, 9:30 AM

As there are over 25 different notices there, paging @Krinkle in case he can figure out which one should be fixed.

Elitre added a comment.EditedMay 12 2017, 10:53 AM

@Krinkle, da.wp is again displaying it empty, it seems. maybe T153118? PS: must be that. I could reproduce on https://da.wikipedia.org/wiki/Caernarfon_Castle?veaction=editsource but not elsewhere, so...

@Elitre Thanks, I can reproduce this.

Looks like one of the editnotice messages created by users on that wiki always outputs "something" even when there isn't anything really. It defaults to <div id="editnotice-area"></div> with nothing in it. It should be fixed to only wrap the notice in this DIV when there actually is a notice, and if not, then it should output nothing.

(Now if that means I can do anything to help, it should probably get reworded :D )