Welcome to Wikipedia message is shown even if page is protected
Closed, ResolvedPublic1 Story Points

Description

Steps to reproduce this issue

  1. Access https://cs.wikipedia.org/w/index.php?title=Wikipedista:Martin_Urbanec/P%C3%ADskovi%C5%A1t%C4%9B/7&action=edit as non-autoconfirmed user
  2. Welcome on Wikipedia message is shown but the page can be created only by autoconfirmed users

Can showing of the dialog be disabled when page cannot be created?

Thanks.

Urbanecm created this task.Jun 26 2016, 1:38 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 26 2016, 1:38 PM
Esanders renamed this task from Welcome on Wikipedia message is showed even if page is protected to Welcome to Wikipedia message is showed even if page is protected.Jun 27 2016, 1:35 PM

Any progress on this?

Jdforrester-WMF triaged this task as Low priority.
Jdforrester-WMF added a subscriber: Glaisher.
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

Users shouldn't get here unless they're URL-hacking — MW doesn't provide an edit link to pages which users can't edit. Not sure what the best solution for users who are unfortunate enough to have loaded a link to a page that got protected/etc. whilst they were loading it.

Guycn2 added a comment.Sep 6 2016, 7:17 PM

Users shouldn't get here unless they're URL-hacking — MW doesn't provide an edit link to pages which users can't edit. Not sure what the best solution for users who are unfortunate enough to have loaded a link to a page that got protected/etc. whilst they were loading it.

First, I think it should not be "low" priority.

Second, what do you mean by "URL-hacking"? Any protected page has a "View source" tab, that is very accessible.

Restricted Application added a project: User-Urbanecm. · View Herald TranscriptNov 8 2016, 8:18 PM
Urbanecm moved this task from Backlog to Watching on the User-Urbanecm board.Nov 13 2016, 7:48 PM

Any progress here?

Urbanecm updated the task description. (Show Details)Nov 25 2016, 8:28 PM

^ updated link to another page which is semiprotected indefinitely just for this task.

Users shouldn't get here unless they're URL-hacking — MW doesn't provide an edit link to pages which users can't edit. Not sure what the best solution for users who are unfortunate enough to have loaded a link to a page that got protected/etc. whilst they were loading it.

First, I think it should not be "low" priority.

Second, what do you mean by "URL-hacking"? Any protected page has a "View source" tab, that is very accessible.

MW doesn't provide an edit link to pages) This isn't true. The View source link is action=edit.

Copying over one of my comments from one of the merged tasks:

It's very debatable whether this is good behaviour or not. On the one hand, we're telling them "anyone can edit" when they can't actually edit that page. On the other hand, a welcoming friendly introduction the first time someone tries to edit could be appreciated even if they can't actually edit that specific page.

This seems like somewhat of an edge case since, generally, people arrive on articles through search engines or through links on other articles, and the vast majority of articles are editable.

kaldari added a subscriber: kaldari.Jul 6 2017, 6:33 PM

This will need to be fixed before we can do the ACTRIAL experiment, otherwise people are going to be very confused.

@Deskana, @Jdforrester-WMF: Can we up the priority on this?

DannyH added a subscriber: DannyH.Jul 6 2017, 6:35 PM

Here's what this currently looks like for new users.

This will need to be fixed before we can do the ACTRIAL experiment, otherwise people are going to be very confused.

In the article creation workflow, the edit tab is not shown if you can't create a page, so the user should never be shown this message. This is true irrespective of how you end up at an article, whether it's through searching, typing the URL into your bar, or clicking on a red link. Based on that, this dialogue shouldn't interfere with anything, but I'd need more detail to know for sure.

What, specifically, is the ACTRIAL experiment? Can you give me more details?

Here's what this currently looks like for new users.

Whether this happens or not depends on the manner in which the page's creation is blocked. In most cases the user won't be able to see this message because the creation tab won't be there, but there are some ways that it can be. I was able to replicate this scenario with these steps:

  1. Create a new account.
  2. Go to https://en.wikipedia.org/wiki/Title_containing_Epic_fail._in_it. Edit tab is shown.
  3. Click on edit tab.

You'll be shown a message very similar to the one; this happens because the article's creation is blocked at the last second because "Epic fail." is in the title blacklist. Is this the same manner in which article creation would be blocked during your experiment?

Ad in article creation workflow you use edit tab which isn't shown when

article is protected) This isn't the whole truth. What about redlink
pointing to protected page? This is happening during extensive vandalism or
other situations. The URL ends with &action=edit&redlink=1 so welcome
message would be shown.

This isn't the whole truth. What about redlink
pointing to protected page? This is happening during extensive vandalism or
other situations. The URL ends with &action=edit&redlink=1 so welcome
message would be shown.

And in the same comment I said:

In most cases the user won't be able to see this message because the creation tab won't be there, but there are some ways that it can be

So, yes, I am well aware that there are some exceptions. Whether this is relevant or not for the purposes of an ACTRIAL experiment depends on the parameters of the experiment, so I need to wait to hear from @kaldari or @DannyH.

Whether this happens or not depends on the manner in which the page's creation is blocked. In most cases the user won't be able to see this message because the creation tab won't be there, but there are some ways that it can be. I was able to replicate this scenario with these steps:

  1. Create a new account.
  2. Go to https://en.wikipedia.org/wiki/Title_containing_Epic_fail._in_it. Edit tab is shown.
  3. Click on edit tab. You'll be shown a message very similar to the one; this happens because the article's creation is blocked at the last second because "Epic fail." is in the title blacklist. Is this the same manner in which article creation would be blocked during your experiment?

We will be using the title blacklist, yes. This is the easiest way to implement it and will allows us to show a custom message.

Elitre added a subscriber: Elitre.Jul 7 2017, 4:25 PM
DannyH added a comment.Jul 7 2017, 5:47 PM

@Deskana ACTRIAL is an experiment proposed in 2011 by enwiki users to block non-autoconfirmed users from creating new articles. Community Tech has been talking with people who work on New Page Patrol, who are very concerned about the rise in the NPP backlog. There's a bunch of possible changes that could be made to help with this problem, but it looks like we can't really make progress unless we try the ACTRIAL experiment and see how it works.

Right now, we're working on getting a contractor analyst to run the experiment, and we're figuring out a possible technical implementation for what non-autoconfirmed users will see when they try to create a new page.

For non-ac users who go to a non-existent article page, we can use the title blacklist message. If they follow a redlink and go to an &action=edit page, we're thinking about using the Persistent error message. That's where the user would see that "Welcome to Wikipedia" popup from the screenshot.

DannyH renamed this task from Welcome to Wikipedia message is showed even if page is protected to Welcome to Wikipedia message is shown even if page is protected.Jul 7 2017, 5:47 PM
kaldari added a comment.EditedJul 7 2017, 8:31 PM

@Deskana: During the ACTRIAL experiment, the edge case you are describing would become the default experience for all non-autoconfirmed users trying to create a new article (due to ACTRIAL's use of title blacklist). This is why it is now a very important bug for us.

Deskana raised the priority of this task from Low to Normal.Jul 10 2017, 3:17 PM
Deskana moved this task from Backlog to TR1: Releases on the VisualEditor board.

@MusikAnimal @DannyH @kaldari Thanks for letting me know the details. This is a slightly atypical way to prevent page creation for large populations of users, so I wanted to double-check before I asked engineers to spend time on the task.

I'm still unconvinced that showing this dialogue is really a problem for the reasons I gave in T138715#3331718. We don't have any data that suggests one way or the other, so frankly we're all guessing, myself included. That said, if your data analyst has said that removing this dialogue in this specific case is important for reasons of experimental design, then that can definitely be done.

Thanks for letting me know the details. This is a slightly atypical way to prevent page creation for large populations of users, so I wanted to double-check before I asked engineers to spend time on the task.

@Deskana: There's actually still debate on-going about whether we should implement the trial using titleblacklist or a custom extension. If titleblacklist ends up being the preferred option, the community is going to expect quick turn-around on it. You're welcome to wait until that debate has consensus one way or the other, though.

I'm still unconvinced that showing this dialogue is really a problem for the reasons I gave in T138715#3331718. We don't have any data that suggests one way or the other, so frankly we're all guessing, myself included.

I have a hard time believing that this wouldn't be a problem for users. We would give them a dialog with 2 options: "Start editing" and "Switch to visual editor", neither of which actually work. Giving that experience to approximately 100 new users per day would be a terrible introduction to Wikipedia, IMO, but I don't have any data to back that up.

Giving that experience to approximately 100 new users per day would be a terrible introduction to Wikipedia, IMO

Agreed.

@Deskana: There's actually still debate on-going about whether we should implement the trial using titleblacklist or a custom extension. If titleblacklist ends up being the preferred option, the community is going to expect quick turn-around on it. You're welcome to wait until that debate has consensus one way or the other, though.

You made the importance clear, yes. I discussed this in a team meeting yesterday and was told this is practically a one-line code change, so waiting seems fine.

Change 364760 had a related patch set uploaded (by DLynch; owner: DLynch):
[mediawiki/extensions/VisualEditor@master] DesktopArticleTarget.init: only show welcome dialog if page editable

https://gerrit.wikimedia.org/r/364760

Change 364760 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] DesktopArticleTarget.init: only show welcome dialog if page editable

https://gerrit.wikimedia.org/r/364760

Deskana closed this task as Resolved.Jul 13 2017, 9:52 PM
Deskana assigned this task to DLynch.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptJul 13 2017, 9:52 PM
Deskana set the point value for this task to 1.Jul 13 2017, 9:52 PM
Ryasmeen reopened this task as Open.Jul 17 2017, 9:38 PM
Ryasmeen added a subscriber: Ryasmeen.

I can still reproduce it on Beta cluster on this page: https://en.wikipedia.beta.wmflabs.org/w/index.php?title=User:Deskana_(WMF)/Protected

@Ryasmeen: I can't reproduce that. Does your beta cluster account have any special privileges?

No, I created a new user account and tried to reproduce it with that. I also tried to verify it with my regular account after resetting my preferences. In both cases, it shows the welcome dialog when I click on "View Source" tab on that protected page.

Aha, I see what's different. One second.

Change 365867 had a related patch set uploaded (by DLynch; owner: DLynch):
[mediawiki/extensions/VisualEditor@master] DesktopArticleTarget.init: more explicit no-welcome-on-protected-pages

https://gerrit.wikimedia.org/r/365867

Change 365867 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] DesktopArticleTarget.init: more explicit no-welcome-on-protected-pages

https://gerrit.wikimedia.org/r/365867

Ryasmeen closed this task as Resolved.Jul 17 2017, 11:53 PM
Ryasmeen edited projects, added Verified; removed Patch-For-Review.