Page MenuHomePhabricator

Page actions bar not showing on Wikipedia Zero
Closed, ResolvedPublic3 Story Points

Description

On Wikipedia Zero, the page actions at the top of the page are no longer showing. They should show so that Wikipedia Zero users are able to conveniently do things like switch language, watchlist pages, and edit pages.

Non-Wikipedia Zero:

Wikipedia Zero, cached, purged, and URL cache varied page; observed on both iOS Safari 9 and Firefox desktop:

At the end of this task we should have a recommendation on what to do next.

Details

Related Gerrit Patches:
mediawiki/extensions/ZeroBanner : masterAdd basic test for Zero
mediawiki/extensions/ZeroBanner : wmf/1.28.0-wmf.18Display edit icon and page actions
mediawiki/extensions/ZeroBanner : masterDisplay edit icon and page actions
mediawiki/extensions/ZeroBanner : masterAdd basic test for Zero
mediawiki/extensions/ZeroBanner : wmf/1.28.0-wmf.17Update router code
mediawiki/extensions/ZeroBanner : masterUpdate router code
mediawiki/extensions/ZeroBanner : masterMove qunit tests to tests/qunit

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes

This is a regression, as it used to be possible to see and use the edit pencil. I'm not sure when the regression started, though.

The original patch's purpose was reinstating the page actions bar, including the edit pencil, in case the operator zero-rated HTTPS.

Most operators used to not zero-rate HTTPS, but now all of them do. Although that sounds simple the logic through the tiers and this code is a little tricky.

bmansurov moved this task from To Do to Doing on the Reading-Web-Sprint-80-V-for-Vandalism board.

Change 307630 had a related patch set uploaded (by Bmansurov):
Update router code

https://gerrit.wikimedia.org/r/307630

The page actions are hidden at /modules/redux.less#L26 and are shown using JS at /modules/interstitial.js#L38. The test at /modules.interstitial.js#L37 is returning false, as a result of which, page actions stay hidden. The zerodontwarn setting is set at /modules/zerobanner.interstitial/ZeroOverlay.js#L49 when the user clicks on the Zero Overlay don't warn button. So basically, if the user clicks don't warn, we let the user see the page actions. I don't know why this was programmed that way. The solution is probably to show the page-actions on page load.

@jhobs / @dr0ptp4kt / @Yurik, any reason why page actions are hidden in the first place?

Change 307664 had a related patch set uploaded (by Jdlrobson):
Add basic test for Zero

https://gerrit.wikimedia.org/r/307664

I've written a basic test for this to show @bmansurov's patch fixes this and offer us more protection going forward. On the long term we should aim to pull zerobanner apart and get it 100% tested - there is lots of highly outdated code inside that module.

Progress with this patch is likely to be blocked until T144329 can be fixed.

@jhobs / @dr0ptp4kt / @Yurik, any reason why page actions are hidden in the first place?

Back in the day only contributory features required HTTPS. But most W0 operators didn't zero-rate HTTPS back then. However, when operators started adding support for zero-rating HTTPS, the code was structured in https://gerrit.wikimedia.org/r/#/c/113655/ to show the contributory feature icons if the operator zero-rated HTTPS (as well as if the user had at some point on an exit interstitial said don't warn me).

It appears that in https://gerrit.wikimedia.org/r/#/c/296175/4/modules/interstitial.js the check for supportsTLS was removed. @bmansurov, your analysis about the user having to have clicked the "don't warn me" button given that change is spot on. It's true that the page actions should inherit their default visibility from MobileFrontend at this point...although the most surgical fix is called for on this task so that other fine grained logic in the page doesn't break.

Thanks, @dr0ptp4kt.

Spike results:

  • Do not hide the page actions using CSS. Let MF decide what to do.
  • Remove the code to show the page actions with JS. (Since the page actions are not hidden with CSS anymore).
  • Make sure these changes don't affect other fine grained logic in the page.

Change 307630 merged by jenkins-bot:
Update router code

https://gerrit.wikimedia.org/r/307630

https://gerrit.wikimedia.org/r/307664 should be merged before sign off and preferably this test should show up in MobileFrontend as a result of T144412.

Change 307664 merged by jenkins-bot:
Add basic test for Zero

https://gerrit.wikimedia.org/r/307664

Change 307826 had a related patch set uploaded (by Jdlrobson):
Move qunit tests to tests/qunit

https://gerrit.wikimedia.org/r/307826

Change 307826 merged by jenkins-bot:
Move qunit tests to tests/qunit

https://gerrit.wikimedia.org/r/307826

Jdlrobson removed bmansurov as the assignee of this task.Aug 31 2016, 9:07 PM
Jdlrobson removed a project: Patch-For-Review.
Jdlrobson added a subscriber: bmansurov.

Please do not sign off until T144412 is resolved and we can verify this test runs with MobileFrontend so this never happens again.

Change 307970 had a related patch set uploaded (by Jdlrobson):
Update router code

https://gerrit.wikimedia.org/r/307970

QUnit Failure can be seen here:
https://integration.wikimedia.org/ci/job/mwext-qunit-jessie/4015/consoleFull

I'll SWAT this today.
I'm not sure how to verify the page actions are showing again on Zero.
@dr0ptp4kt can you provide guidance?

@Jdlrobson, I'll email you about it.

Change 307970 merged by Dereckson:
Update router code

https://gerrit.wikimedia.org/r/307970

Mentioned in SAL [2016-09-02T00:03:31Z] <dereckson@tin> Synchronized php-1.28.0-wmf.17/extensions/ZeroBanner: Update router code (T143425) (duration: 00m 47s)

phuedx added a subscriber: phuedx.Sep 2 2016, 9:53 AM

@dr0ptp4kt: Is this something that you can email the Reading Web team about so that we're all capable of testing/signing off on these changes?

For later reference, I followed up separately on the access.

Sections are also uneditable now. Can you check if you have the same problem or it's a personal issue please.

I see the same problem. I don't think it's because of the changes we made recently. @Issimo_15 do you think we didn't have this problem up until recently?

Issimo_15 added a comment.EditedSep 2 2016, 10:11 PM

Yes, I met the problem today, few hours before reporting it.

bmansurov claimed this task.Sep 6 2016, 5:44 PM
bmansurov moved this task from To Do to Doing on the Reading-Web-Sprint-80-V-for-Vandalism board.

Change 308802 had a related patch set uploaded (by Bmansurov):
Show edit icon and page actions

https://gerrit.wikimedia.org/r/308802

@dr0ptp4kt @ovasileva should the edit icon / page actions be not showing under any circumstances in Zero right now? Per Adam it sounds like this might be a mistake but it has not explicitly been asked for yet

@bmansurov patch makes them show unconditionally - is this what we want?

From my understanding, we should be displaying the page actions in Zero, @dr0ptp4kt, can you confirm?

Yes, nowadays, the page actions bar and its buttons should show in the same fashion for Wikipedia Zero users as for non-Wikipedia Zero users.

Change 308802 merged by jenkins-bot:
Display edit icon and page actions

https://gerrit.wikimedia.org/r/308802

bmansurov removed bmansurov as the assignee of this task.Sep 7 2016, 6:11 PM

@bmansurov - where can we test this?

@ovasileva, it's a little complicated. I think @dr0ptp4kt needs to give you access to the Zero portal so that you can add you IP address there and test the change.

Derura removed a subscriber: Derura.Sep 8 2016, 5:05 PM

Just to update: @ovasileva and I have a meeting later today to go over how to test Zero tasks, so it should be able to be resolved after that.

Page actions currently still not showing

@ovasileva I don't think the latest patch has been SWAT deployed yet. If we don't SWAT deploy, then you can see page actions in action on Thursday.

This comment was removed by jhobs.

Ignore my previous comment; I hadn't read Baha's latest comment yet and thought the patch had already been deployed.

MBinder_WMF renamed this task from [Spike: 2 hours] Page actions bar not showing on Wikipedia Zero to Page actions bar not showing on Wikipedia Zero.Sep 12 2016, 4:05 PM
MBinder_WMF set the point value for this task to 2.
MBinder_WMF changed the point value for this task from 2 to 3.Sep 12 2016, 4:09 PM

@jhobs could you swat the fix early tomorrow? I'm not setup to test Zero related changes at the current time and it would be great to wrap up this work.

Is this something that needs to be SWATted? I think this should just ride the train. We should avoid SWATs if not UBN or a config change (see: team norm).

Is this something that needs to be SWATted? I think this should just ride the train. We should avoid SWATs if not UBN or a config change (see: team norm).

@Jhernandez: Is this UBN? It does render two stable features – the editor and the language switcher – unusable.

@phuedx - I agree - updating priority.

ovasileva raised the priority of this task from High to Unbreak Now!.Sep 14 2016, 12:28 PM
Restricted Application added subscribers: Jay8g, Luke081515, TerraCodes. · View Herald TranscriptSep 14 2016, 12:28 PM

Change 310601 had a related patch set uploaded (by Jhobs):
Display edit icon and page actions

https://gerrit.wikimedia.org/r/310601

Change 310601 merged by jenkins-bot:
Display edit icon and page actions

https://gerrit.wikimedia.org/r/310601

jhobs reassigned this task from jhobs to ovasileva.Sep 14 2016, 6:56 PM

Scheduled for 18:00 UTC SWAT today.

And subsequently deployed. Can be tested on enwiki (e.g. https://en.m.wikipedia.org/wiki/Dave_Grohl, you may have to add ?action=purge depending on timing). Throwing over to @ovasileva for signoff!

greg added a subscriber: greg.Sep 14 2016, 7:45 PM

Resolved?

ovasileva closed this task as Resolved.Sep 14 2016, 7:47 PM

Resolved.

Change 307662 abandoned by Jdlrobson:
Add basic test for Zero

Reason:
Abandoning old patch

https://gerrit.wikimedia.org/r/307662