Page MenuHomePhabricator

Increase default thumb size to 250px at nowiki
Closed, ResolvedPublic

Description

The default thumb size at nowiki is currently set to 220px. It is consensus on increasing the size to 250px.

Discussion at nowiki can be found at w:no:Wikipedia:Tinget#Standard billedstørrelse.

Details

Related Gerrit Patches:
operations/mediawiki-config : masterIncrease default thumb size to 250px at nowiki

Event Timeline

jeblad created this task.Jan 21 2017, 2:15 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 21 2017, 2:15 PM

Any progress? :)

Urbanecm claimed this task.Jan 28 2017, 3:01 PM
Urbanecm added a subscriber: Urbanecm.

Please add Wikimedia-Site-requests in future requests like this, see https://meta.wikimedia.org/wiki/Requesting_wiki_configuration_changes for more information about requesting such changes so relevant people can be notified about relevant tasks easily. Preparing a patch for it.

Restricted Application added a project: User-Urbanecm. · View Herald TranscriptJan 28 2017, 3:01 PM

Change 334787 had a related patch set uploaded (by Urbanecm):
Increase default thumb size to 250px at nowiki

https://gerrit.wikimedia.org/r/334787

Urbanecm triaged this task as Medium priority.Jan 28 2017, 3:04 PM
Urbanecm moved this task from Backlog to To deploy on the User-Urbanecm board.
Urbanecm moved this task from Working on to To deploy on the Wikimedia-Site-requests board.
greg added a subscriber: greg.Jan 30 2017, 6:26 PM

@Nirzar In my opinion it'd be great to have thumbnails a default size for usage on mobile (320px viewport). Any thoughts on this?

@Volker_E that would be great but we will have to measure the performance impact. is this only for nowiki or all wikis? if it is all wikis, i would highly recommend running through performance team.

This task is just for nowiki.

Gilles added a comment.EditedJan 31 2017, 10:24 AM

250px is more common than 220px, this would actually increase performance.

This is a very complex topic, that was last addressed as a whole (AFAIK) in ~2014.
IIUC (I am not a developer), the performance issue, is that if any large wiki (or many small wikis) request custom sizes, then

  • (A) the thumbnail-generating machines will have to work harder (and might run into hardware limitations, and thus slow responses) - This is especially a problem for the busiest wikis, because if we change the default then it will take hundreds of hours to generate new thumbnails, yet they'll be needed instantaneously. The devs want to pre-emptively generate the desired sizes, en-masse, once we firmly decide on a size.
  • (B) the thumbnail storage/caching requirements will rapidly increase (but not in a way that benefits all Wikimedia users). I.e. If XXwiki requests 260 and YYwiki requests 250 and ZZwiki requests 270, then the storage requirements will more than triple.

Hence, T51357: Increase WMF cluster default image thumb size is the main task,
with further details & discussion in https://www.mediawiki.org/wiki/Requests_for_comment/Standardized_thumbnails_sizes and related tasks (including debate/research of the optimal set of sizes).

We (everyone) want to determine one optimal solution (i.e. one set of available sizes, and one new global wikimedia-default) that works best for the largest number of users (low-bandwidth/high-bandwidth, small-screen/large-screen), whilst remaining feasible given the software/hardware limitations (the more options there are, the more complex everything becomes), and also whilst looking ahead to changes in the near-future or recent-past (e.g. HiDPI) so that we don't have to change our decision within a couple of years.

250px is more common than 220px, this would actually increase performance.

I thought Wikimedia's MediaWiki default is still 220px ? (I confirmed manually with a reset-preferences account, at mw.o and Frwiki. That's also what it says at (the admittedly old) page https://www.mediawiki.org/wiki/Requests_for_comment/Standardized_thumbnails_sizes#Context . I tried looking through InitialiseSettings.php and DefaultSettings.php and CommonSettings.php but got confused...)

Thanks for the comprehensive summary, @Quiddity. I've pasted your comment into T51357 and we should continue there as in possibly re-open.

Thumbnail sizes of 250 px is one of the standard sizes, and thus it is highly likely that they are already generated. If anyone want to generate stats, feel free, but I would be highly surprised if there are any significant discrepancies between the number of generated thumbnails of 220 and 250 px.

There will be an increased load on comlines, as an image of 250 px is slightly larger. The increase would be in the area of 29%, not exactly a showstopper!

I don't know the exact status now. May I process the request? Or should I leave it for somebody else?

hashar removed a subscriber: hashar.Mar 28 2017, 8:14 AM
Zache added a subscriber: Zache.Mar 29 2017, 7:50 PM
jeblad added a comment.Apr 9 2017, 1:20 AM

There is a patch?

Yeah, there is a patch. But I don't know if it is safe to deploy it and I'm asking if this is possible.

It's safe to deploy

It's safe to deploy

Okay, thank you for your information. I'll schedule it for today EU SWAT.

Change 334787 merged by jenkins-bot:
[operations/mediawiki-config@master] Increase default thumb size to 250px at nowiki

https://gerrit.wikimedia.org/r/334787

Mentioned in SAL (#wikimedia-operations) [2017-04-10T13:17:36Z] <hashar@tin> Synchronized wmf-config/InitialiseSettings.php: Increase default thumb size to 250px at nowiki - T155892 (duration: 00m 45s)

hashar closed this task as Resolved.Apr 10 2017, 1:31 PM

The thumbnails width on nowiki now defaults to 250 pixels.