Page MenuHomePhabricator

Increase WMF cluster default image thumb size
Open, LowPublic

Description

The 220px thumbnails are too small considering the great amount of high resolution displays [1] and the growing number of dpi on mobile devices. I think it is mandatory to change this in the next two years or so. Otherwise the user experience will drop significantly.

Currently there are discussions about the technical problems on how to implement this:

  • T43712#469014 states some caching problems when setting the standard thumbnail width for each wiki separately and (possibly) different. Therefore I'd suggest to change the default globally.
  • Another proposal [2] suggests to "store only preferred-size thumbnails indefinitely"

...

In the past a few site requests had community consensus but were closed as "WONTFIX" due to server performance issues. (See bug 47332 for example)
Though community consensus is needed for a possible patch of this bug to be merged the technical details should be discussed first.

[1] http://www.w3schools.com/browsers/browsers_resolution_higher.asp
[2] https://www.mediawiki.org/wiki/Talk:Requests_for_comment/Standardized_thumbnails_sizes#Caching_strategy_23835

See Also:

Details

Reference
bz49357

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 2:02 AM
bzimport set Reference to bz49357.
bzimport added a subscriber: Unknown Object (MLST).
McZusatz created this task.Jun 9 2013, 11:18 AM
hashar added a comment.Jun 9 2013, 7:30 PM

This should be handled through the RFC process, not via a bug request :-)

During the Amsterdam hackaton, we have agreed to review the list of pending RFC to cleanup / assign priorities to them. Hopefully the Standardized Thumbnails Size will receive some focus and have some team "in charge".

(In reply to comment #1)

I guess it's related to [1] in some way?

References

  • [1]

<https://www.mediawiki.org/wiki/Requests_for_comment/
Standardized_thumbnails_sizes>

Related but not identical. The bug request is about the site request "increasing the default thumbnail size" rather than a solution to the caching problems, CPU usage, etc. Though it seems the caching issues etc. have to be solved first.

TTO added a comment.Jul 9 2014, 2:13 AM
  • Bug 67709 has been marked as a duplicate of this bug. ***
greg added a comment.Jul 11 2014, 7:13 PM

Marco, this request is old and was overlooked, it seems, when this newer request was filed here:
https://bugzilla.wikimedia.org/show_bug.cgi?id=67703
"Change default thumbnail size to 300px based on user behavior"

Would a change to 300px be sufficient for closing this bug as well?

Shouldn't this apply to all MediaWiki installations if implemented, meaning not only to Wikimedia projects?

greg added a comment.Jul 11 2014, 11:19 PM

I think that is the ultimate plan, yes

(In reply to Vogone from comment #7)

Shouldn't this apply to all MediaWiki installations if implemented, meaning
not only to Wikimedia projects?

Bug 67703 is the bug for making the change to the default settings of MediaWiki itself, as opposed to the WMF cluster of wikis.

JamesF logged that bug and it got closed as a duplicate of this one. But yes the goal is that it affect wikimedia wikis and or the default on mediaeiki as well

(In reply to Jared Zimmerman (WMF) from comment #10)

JamesF logged that bug and it got closed as a duplicate of this one.

Whoops. I'll reopen.

TTO added a comment.Jul 12 2014, 12:25 PM

Why is bug 67709 not a duplicate? There are two separate issues here:

  • this bug (and bug 67709) - increase thumb size on WMF cluster
  • bug 67703 - increase thumb size for MediaWiki

Let's make this a tracking bug for increasing size and bug 67709 a request for particular size (300px). That's going to be less messy than duping them.

RobLa-WMF set Security to None.
Krenair added a subscriber: Krenair.
Restricted Application added subscribers: Matanya, Aklapper. · View Herald TranscriptAug 22 2015, 6:23 PM
hashar removed a subscriber: hashar.Aug 23 2015, 7:33 AM
Jdforrester-WMF moved this task from Untriaged to Backlog on the Multimedia board.Sep 4 2015, 5:54 PM
Restricted Application added a subscriber: JEumerus. · View Herald TranscriptFeb 2 2016, 12:22 AM
Luke081515 closed this task as Declined.Feb 2 2016, 12:23 AM
Luke081515 added a subscriber: Luke081515.

Declined per T124354. There is no consensus for this change yet. Please reopen the task if consensus reached.

Meno25 removed a subscriber: Meno25.Feb 22 2016, 5:36 PM
He7d3r updated the task description. (Show Details)Apr 6 2016, 8:07 PM
He7d3r added a subscriber: He7d3r.
Phabricator_maintenance renamed this task from Increase WMF cluster default image thumb size (tracking) to Increase WMF cluster default image thumb size.Aug 13 2016, 11:29 PM

In T155892#2997519, @Quiddity gave an insightful, comprehensive statement of the connected challenges:

This is a very complex topic, that was last addressed as a whole (AFAIK) in ~2014.
IIUC (I am not a developer), the performance issue, is that if any large wiki (or many small wikis) request custom sizes, then

  • (A) the thumbnail-generating machines will have to work harder (and might run into hardware limitations, and thus slow responses) - This is especially a problem for the busiest wikis, because if we change the default then it will take hundreds of hours to generate new thumbnails, yet they'll be needed instantaneously. The devs want to pre-emptively generate the desired sizes, en-masse, once we firmly decide on a size.
  • (B) the thumbnail storage/caching requirements will rapidly increase (but not in a way that benefits all Wikimedia users). I.e. If XXwiki requests 260 and YYwiki requests 250 and ZZwiki requests 270, then the storage requirements will more than triple.

Hence, T51357: Increase WMF cluster default image thumb size is the main task,
with further details & discussion in https://www.mediawiki.org/wiki/Requests_for_comment/Standardized_thumbnails_sizes and related tasks (including debate/research of the optimal set of sizes).
We (everyone) want to determine one optimal solution (i.e. one set of available sizes, and one new global wikimedia-default) that works best for the largest number of users (low-bandwidth/high-bandwidth, small-screen/large-screen), whilst remaining feasible given the software/hardware limitations (the more options there are, the more complex everything becomes), and also whilst looking ahead to changes in the near-future or recent-past (e.g. HiDPI) so that we don't have to change our decision within a couple of years.

jeblad added a subscriber: jeblad.Feb 18 2017, 1:27 PM

There are several sizes in use, and 250 px (as the nowiki community want) is one of the existing choices for logged in people. If someone chose one of those choices the thumbs will be generated for visited pages. Hence, when a community start to change to a larger thumbsize the thumbs will be resized anyhow.

A proper solution would be to set the default size according to what the users that has set their thumbsize, as that will reflect the most common screen sizes for the project. I wonder if the screen size would actually be different between geographic areas, even areas pretty close to each other.