Fatal error: Call to undefined method Revision::getText() in extensions/FlaggedRevs/backend/FlaggedRevision.php on line 480
Closed, ResolvedPublic

Description

getting a lot of these in the logs since wmf.9

From T156356:

Pages with pending changes (all these: https://de.wiktionary.org/wiki/Spezial:Seiten_mit_ungesichteten_Versionen) can't be edited or read - a totally blank page is returned.

Workaround is probably to review or reject the revisions before editing.

Repro case:

production https://de.wiktionary.org/w/index.php?title=Sonne&stable=1

beta https://en.wikipedia.beta.wmflabs.org/w/index.php?title=PC1&action=edit (as anonymous user)

mmodell created this task.Jan 25 2017, 9:37 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 25 2017, 9:37 PM
mmodell triaged this task as High priority.Jan 25 2017, 9:40 PM
{
    "fatal_exception": {
        "class": "ErrorException",
        "message": "PHP Fatal Error: Call to undefined method Revision::getText()",
        "code": 16777217,
        "file": "/srv/mediawiki/php-1.29.0-wmf.9/extensions/FlaggedRevs/backend/FlaggedRevision.php",
        "line": 480,
        "trace": [{
            "file": "/srv/mediawiki/php-1.29.0-wmf.9/extensions/FlaggedRevs/backend/FlaggedRevision.php",
            "line": 480
        }, {
            "file": "/srv/mediawiki/php-1.29.0-wmf.9/extensions/FlaggedRevs/frontend/FlaggablePageView.php",
            "line": 1028,
            "function": "getRevText",
            "class": "FlaggedRevision",
            "type": "->",
            "args": []
        }, {
            "file": "/srv/mediawiki/php-1.29.0-wmf.9/extensions/FlaggedRevs/frontend/FlaggedRevsUI.hooks.php",
            "line": 237,
            "function": "addToEditView",
            "class": "FlaggablePageView",
            "type": "->",
            "args": ["EditPage"]
        }, {
            "file": "/srv/mediawiki/php-1.29.0-wmf.9/includes/Hooks.php",
            "line": 186,
            "function": "addToEditView",
            "class": "FlaggedRevsUIHooks",
            "type": "::",
            "args": ["EditPage", "OutputPage"]
        }, {
            "file": "/srv/mediawiki/php-1.29.0-wmf.9/includes/EditPage.php",
            "line": 2602,
            "function": "run",
            "class": "Hooks",
            "type": "::",
            "args": ["string", "array"]
        }, {
            "file": "/srv/mediawiki/php-1.29.0-wmf.9/includes/EditPage.php",
            "line": 642,
            "function": "showEditForm",
            "class": "EditPage",
            "type": "->",
            "args": []
        }, {
            "file": "/srv/mediawiki/php-1.29.0-wmf.9/includes/actions/EditAction.php",
            "line": 59,
            "function": "edit",
            "class": "EditPage",
            "type": "->",
            "args": []
        }, {
            "file": "/srv/mediawiki/php-1.29.0-wmf.9/includes/MediaWiki.php",
            "line": 495,
            "function": "show",
            "class": "EditAction",
            "type": "->",
            "args": []
        }, {
            "file": "/srv/mediawiki/php-1.29.0-wmf.9/includes/MediaWiki.php",
            "line": 289,
            "function": "performAction",
            "class": "MediaWiki",
            "type": "->",
            "args": ["Article", "Title"]
        }, {
            "file": "/srv/mediawiki/php-1.29.0-wmf.9/includes/MediaWiki.php",
            "line": 858,
            "function": "performRequest",
            "class": "MediaWiki",
            "type": "->",
            "args": []
        }, {
            "file": "/srv/mediawiki/php-1.29.0-wmf.9/includes/MediaWiki.php",
            "line": 519,
            "function": "main",
            "class": "MediaWiki",
            "type": "->",
            "args": []
        }, {
            "file": "/srv/mediawiki/php-1.29.0-wmf.9/index.php",
            "line": 43,
            "function": "run",
            "class": "MediaWiki",
            "type": "->",
            "args": []
        }, {
            "file": "/srv/mediawiki/w/index.php",
            "line": 3,
            "function": "include",
            "args": ["string"]
        }]
    },
    "exception_id": "5581f8a7",
    "caught_by": "mwe_handler"
}

None of the recent changes to the FlaggedRevs extension seem relevant to this error. May be a symptom of something else?

Change 334206 had a related patch set uploaded (by EBernhardson):
Enable deprecation logging in prod

https://gerrit.wikimedia.org/r/334206

Change 334206 merged by jenkins-bot:
Enable deprecation logging in prod

https://gerrit.wikimedia.org/r/334206

Change 334223 had a related patch set uploaded (by MaxSem):
Fix fatal in prod caused by deprecated function removal

https://gerrit.wikimedia.org/r/334223

faidon added a subscriber: faidon.Jan 26 2017, 10:47 AM

getting a lot of these in the logs since wmf.9

If we were getting these a lot after the wmf.9 deploy, why didn't we roll it back?

Change 334277 had a related patch set uploaded (by Hashar):
Revert "group1 wikis to 1.29.0-wmf.9"

https://gerrit.wikimedia.org/r/334277

Change 334277 merged by jenkins-bot:
Revert "group1 wikis to 1.29.0-wmf.9"

https://gerrit.wikimedia.org/r/334277

Mentioned in SAL (#wikimedia-operations) [2017-01-26T11:12:16Z] <hashar@tin> rebuilt wikiversions.php and synchronized wikiversions files: FlaggedRevs is broken in wmf.9 causing blank pages. T156356 T156310

hashar updated the task description. (Show Details)Jan 26 2017, 11:24 AM
hashar updated the task description. (Show Details)Jan 26 2017, 11:28 AM

Change 334296 had a related patch set uploaded (by Hashar):
Fix fatal in prod caused by deprecated function removal

https://gerrit.wikimedia.org/r/334296

Change 334223 merged by jenkins-bot:
Fix fatal in prod caused by deprecated function removal

https://gerrit.wikimedia.org/r/334223

@MaxSem patch ( https://gerrit.wikimedia.org/r/334223 ) fix it on beta. Will push it to wmf.9 so we can confirm on group0 then I guess we can move group1 back to wmf.9.

Change 334296 merged by jenkins-bot:
Fix fatal in prod caused by deprecated function removal

https://gerrit.wikimedia.org/r/334296

Mentioned in SAL (#wikimedia-operations) [2017-01-26T12:17:04Z] <hashar@tin> Synchronized php-1.29.0-wmf.9/extensions/FlaggedRevs/backend/FlaggedRevision.php: Fix fatal in prod caused by deprecated function removal T156310 (duration: 00m 41s)

Change 334328 had a related patch set uploaded (by Hashar):
group1 wikis back to 1.29.0-wmf.9

https://gerrit.wikimedia.org/r/334328

Change 334328 merged by jenkins-bot:
group1 wikis back to 1.29.0-wmf.9

https://gerrit.wikimedia.org/r/334328

Mentioned in SAL (#wikimedia-operations) [2017-01-26T13:05:50Z] <hashar@tin> rebuilt wikiversions.php and synchronized wikiversions files: group1 back to 1.29.0-wmf.9 T156310

hashar closed this task as Resolved.Jan 26 2017, 1:06 PM
hashar claimed this task.

Should be good now and group1 wikis are back to 1.29.0-wmf.9