Page MenuHomePhabricator

[Regression] Paragraph-insert slug in a block context in a table cell instead inserted at start of document in Chrome
Closed, ResolvedPublic8 Story Points

Description

If you have a list in a table cell VE offers to insert a paragraph before the list.

The expected behaviour is that if you click + Insert paragraph the paragraph would be inserted at the top of the list, inside the same cell.

The actual behaviour is that the paragraph gets inserted at the start of the page.

Note that this affects Chrome but seems to work fine in Firefox

See recording below illustrating what this looks like on the page :wmse:Användare:André Costa (WMSE)/Bugg new section

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 16 2017, 10:57 AM
Samtar added a subscriber: Samtar.Feb 16 2017, 12:01 PM

@Lokal_Profil Hej! Could you just confirm which version of Google Chrome you're running?

  • To find the version please click this icon ≡ in the upper right hand corner of your browser and then click "About Google Chrome."

tack :)

@Lokal_Profil Hej! Could you just confirm which version of Google Chrome you're running?

The version I used in the screen recording was 55.0.2883.87 (64-bit) [Chrome on Ubuntu]

Ping @Jopparn who first encountered the issue and might have been running a different version.

This is a regression. Bisect blames OOjs UI 0.18.0.

Jdforrester-WMF renamed this task from VE sometimes inserts paragraph in wrong place to {Regression] Paragraph-insert slug in a block context in a table cell instead inserted at start of document in Chrome.Feb 16 2017, 9:03 PM
Jdforrester-WMF triaged this task as High priority.
Jdforrester-WMF set the point value for this task to 8.
Jdforrester-WMF moved this task from To Triage to TR0: Interrupt on the VisualEditor board.

Probably caused by the ButtonWidget focus changes in 56c5a9352bcf1825cf99c73f630057de99b4b66d / T76636.

Change 338275 had a related patch set uploaded (by Esanders):
Don't allow slug buttons to take focus

https://gerrit.wikimedia.org/r/338275

Change 338275 merged by jenkins-bot:
Don't allow slug buttons to take focus on click

https://gerrit.wikimedia.org/r/338275

Change 338167 had a related patch set uploaded (by Jforrester):
Update VE core submodule to master (e94169400)

https://gerrit.wikimedia.org/r/338167

Esanders renamed this task from {Regression] Paragraph-insert slug in a block context in a table cell instead inserted at start of document in Chrome to [Regression] Paragraph-insert slug in a block context in a table cell instead inserted at start of document in Chrome.Feb 17 2017, 6:53 PM

Change 338167 merged by jenkins-bot:
Update VE core submodule to master (e94169400)

https://gerrit.wikimedia.org/r/338167

Jdforrester-WMF closed this task as Resolved.Feb 17 2017, 7:55 PM
Jdforrester-WMF assigned this task to Esanders.
Jdforrester-WMF removed a project: Patch-For-Review.
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

Sorry about this. Fix will be released on Tuesday->Thursday next week.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptFeb 22 2017, 10:53 PM
Ryasmeen moved this task from To be Verified to Verified on the User-Ryasmeen board.