Page MenuHomePhabricator

Allow filtering user contributions by minor/not minor
Closed, ResolvedPublic

Description

In Recent Changes, we have "show small changes", "show bots"... Is it possible to implement this in Special:Contributions? This way, it will be easier for a user to filter his contributions.

Details

Reference
bz14086
Related Gerrit Patches:

Event Timeline

bzimport raised the priority of this task from to Low.Nov 21 2014, 10:13 PM
bzimport set Reference to bz14086.
bzimport added a subscriber: Unknown Object (MLST).
Chenzw created this task.May 11 2008, 8:55 AM

Umm, how would that be useful?

My RC shows this: Hide minor edits | Show bots | Hide anonymous users | Hide logged-in users | Hide my edits
Only the first one makes sense here. And it's not like there isn't an "m" or whatever next to each minor revision.

(In reply to comment #1)

Umm, how would that be useful?
My RC shows this: Hide minor edits | Show bots | Hide anonymous users | Hide
logged-in users | Hide my edits
Only the first one makes sense here. And it's not like there isn't an "m" or
whatever next to each minor revision.

Oops, only the first one makes sense. But it would be nice for a user to track all the pages that he has created.

demon added a comment.Sep 20 2009, 8:17 AM
  • Bug 16682 has been marked as a duplicate of this bug. ***

Clarified the summary. Page moves have their log so it doesn't seem the same.
This was discussed before but I don't remember why; the answer was that b, m, N tags are not stored in the database in a way that allows such filtering, if I remember correctly.

Page creations option was done in gerrit change 115189

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 23 2015, 9:14 PM
TTO claimed this task.Oct 7 2015, 11:01 AM
TTO added a subscriber: TTO.

This is already possible from the API, it just needs a UI checkbox.

I think a single checkbox

  • Hide minor edits

will be enough. After all, this is the extent of the filtering functionality provided by RecentChanges and friends (show/hide minor edits), and anything more complex than this would clutter the UI.

Change 244139 had a related patch set uploaded (by TTO):
Allow minor edits to be filtered out of Special:Contributions

https://gerrit.wikimedia.org/r/244139

Scott added a subscriber: Scott.Nov 12 2015, 11:30 AM
Meno25 removed a subscriber: Meno25.Feb 22 2016, 6:10 PM

Change 244139 merged by jenkins-bot:
Allow minor edits to be filtered out of Special:Contributions

https://gerrit.wikimedia.org/r/244139

TTO closed this task as Resolved.EditedJun 9 2016, 8:17 PM

It only took 8 years...

Woohoo! \o/

matej_suchanek updated the task description. (Show Details)
matej_suchanek moved this task from To Triage to Announce in next Tech/News on the User-notice board.
matej_suchanek removed a subscriber: wikibugs-l-list.