Page MenuHomePhabricator

[BUG] User may be directed to unrelated content from the "featured article" widget if device and app language are different
Closed, ResolvedPublic

Description

Steps to reproduce
  1. Set the first language in the app to a different language than the device language
  2. Add the Featured widget.

Expected

The widget shows the featured article of the first app language, and tapping on the widget opens the main page in that app language.

Actual

The widget shows the featured article of the device language, but tapping on the widget opens the main page in that app language.


Original task description

The Featured Article home screen widget shows the Featured Article on the main page for the Wikipedia of the user's device language. Upon clicking it the user is shown the main page of the app language wiki, which may not be the same as the device language. In this way the user is confusingly shown content unrelated to that displayed on the widget.
Note that there's another variant of Featured Article widget misbehavior where the wiki's main page doesn't put the Featured Article at the top of the main page (or doesn't include one at all): T135907: Featured Article widget shows incorrect article.

Event Timeline

Mholloway created this task.Aug 4 2017, 9:06 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 4 2017, 9:06 PM
Mholloway renamed this task from User may be directed to unrelated content from the "featured article widget" to User may be directed to unrelated content from the "featured article" widget.Aug 4 2017, 9:06 PM
RHo renamed this task from User may be directed to unrelated content from the "featured article" widget to User may be directed to unrelated content from the "featured article" widget if device and app language are different.Mar 30 2018, 3:23 PM
Charlotte renamed this task from User may be directed to unrelated content from the "featured article" widget if device and app language are different to [BUG] User may be directed to unrelated content from the "featured article" widget if device and app language are different.May 1 2018, 4:54 PM

Change 431996 had a related patch set uploaded (by Dbrant; owner: Dbrant):
[apps/android/wikipedia@master] Explicitly update widgets when changing app language.

https://gerrit.wikimedia.org/r/431996

Change 431996 merged by jenkins-bot:
[apps/android/wikipedia@master] Explicitly update widgets when changing app language.

https://gerrit.wikimedia.org/r/431996

RHo updated the task description. (Show Details)May 14 2018, 2:15 PM
RHo added a subscriber: RHo.

LGTM on Pixel 2 (8.1), Wikipedia v2.7.232-alpha-2018-05-10. Moved to QA for further testing

ABorbaWMF added a subscriber: ABorbaWMF.

This is one looks fixed in one scenario, but slightly off in another. If the user changes the language after installing and completing onboarding, then the explore feed items seem to be in the desired language, including the featured widget. However, if the user adds a language and sets it in the first position during onboarding, then everything is displayed in the device language until the explore feed is refreshed.

Steps:

  1. Installed on a device set to english
  2. Added another language (german) and drag it to the first position in the list
  3. Complete the remainder of onboarding, view the explore feed

Language setting


First time on explore feed

After refresh (pull down)

Setting to did not pass, for now, perhaps this is a separate issue.

@ABorbaWMF it is expected behavior when we change app language that it will update the feed only on refresh. However, I can create a ticket for this specific case, so we can triage on it. This is not related to the widget issue we are trying to resolve here. If that particular scenario is met, could you please move this to the right column. @RHo lmk if you feel differently.

RHo added a comment.May 22 2018, 4:33 PM

@ABorbaWMF it is expected behavior when we change app language that it will update the feed only on refresh. However, I can create a ticket for this specific case, so we can triage on it. This is not related to the widget issue we are trying to resolve here. If that particular scenario is met, could you please move this to the right column. @RHo lmk if you feel differently.

Hey @Sharvaniharan - it is not expected behavior per se, since it is a bug that the Explore feed requires a refresh to show the languages in order of the user that the user has updated in preferences. However, you are right that we can consider this is independent of this widget task, so @ABorbaWMF please feel free to move this one along if there are no other issues, and I've just added this as a second scenario to test in T141587 once that task ready for QA.

Dbrant closed this task as Resolved.Jun 27 2018, 8:05 PM