Page MenuHomePhabricator

Translation editor shows a gap between header and content
Closed, ResolvedPublic

Description

ContentTranslation editor has a header with options above the translation content, currently there seems to be an unnecessary gap that pushes content down and makes the tool area look disconnected:

The cause seems to be a <fieldset> element:

Either the empty fieldset should not have any height (display: none; for example) ot not be there at all when there is message.

Details

Related Gerrit Patches:
mediawiki/extensions/ContentTranslation : masterFix gap between header and content

Event Timeline

Nikerabbit added a subscriber: Nikerabbit.

This seems quite simple task which I can mentor. Either the empty fieldset should not have any height (display: none; for example) ot not be there at all when there is message.

Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptOct 27 2017, 6:48 AM
divadsn claimed this task.Dec 17 2017, 12:12 AM
divadsn added a subscriber: divadsn.

I think it's better to remove the element completely in my opinion :)

Sorry, but sadly I can't reproduce the bug on the Wikipedia ContentTranslation page and my local vagrant had problems running the contenttranslation role.

Please check my screenshot below.

If it comes to the gap between, the cause isn't the fieldset anymore, it's a wrong CSS rule here:

Change 398691 had a related patch set uploaded (by Divadsn; owner: Divadsn):
[mediawiki/extensions/ContentTranslation@master] Fix gap between header and content

https://gerrit.wikimedia.org/r/398691

Change 398691 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Fix gap between header and content

https://gerrit.wikimedia.org/r/398691

Nikerabbit moved this task from Backlog to QA on the Language-2017-Oct-Dec board.

Thanks to @santhosh for his help in reviewing the task :)

I will need to check it in production to make sure that the additional messages can be displayed there.
wmf.12

Checked per my previous comment - in testwiki (wmf.15) I saw that the additional message does not quite fit anymore:

@divadsn - can your fix accommodate the case when there is some additional messages need to be displayed?

I filed the issue from my previous comment as T184130: [wmf.15-regression] ContentTranslation page: the additional message not displayed correctly and closing this ticket as Resolved.

Etonkovidova closed this task as Resolved.Jan 3 2018, 10:57 PM
Nikerabbit moved this task from QA to Done on the Language-2017-Oct-Dec board.Jan 4 2018, 8:39 AM