Deploy new Wikidiff2 version on beta-cluster
Closed, ResolvedPublic

Description

WMDE's Technical Wishes Team and especially @jkroll were working on wikidiff2 for the past year to make it possible to visualize changes in moved paragraphs. See T146781.
The necessary changes in wikidiff2 were finally merged yesterday and the next step would be to deploy this new version of wikidiff2 on the beta-cluster to test it before it goes into production.

@Lea_WMDE spoke already to @Legoktm and @greg about our deployment plan AFAIK, but here's a brief overview of what we had in mind

  • Introduce config variable in MediaWiki to be able to switch the new behavior on or off. See T166571.
  • merge necessary changes in wikidiff2.
  • deploy new version of wikidiff2 on the beta-cluster and set $wgWikiDiff2MovedParagraphDetectionCutoff = 25; for beta wikis. That's what this ticket is about.
  • after testing the new behavior on beta, deploy the new version of wikidiff2 in production but leave $wgWikiDiff2MovedParagraphDetectionCutoff = 0; to not enable it yet. Ticket will be created by WMDE's Technical Wishes Team as soon as we are finished with testing.
  • set $wgWikiDiff2MovedParagraphDetectionCutoff = 25; for certain wikis only (e.g. dewiki) to test the new behavior in production. Ticket will be created by WMDE's Technical Wishes Team as soon as we are at this point.
  • set $wgWikiDiff2MovedParagraphDetectionCutoff = 25; for all wikis to finally have the new behavior everywhere. Ticket will be created by WMDE's Technical Wishes Team as soon as we are at this point.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 13 2017, 11:02 AM
Tobi_WMDE_SW triaged this task as Normal priority.Sep 13 2017, 11:25 AM
Tobi_WMDE_SW updated the task description. (Show Details)
Tobi_WMDE_SW added subscribers: Lea_WMDE, jkroll, Legoktm and 7 others.

@Legoktm @greg, adding the teams Operations and Release-Engineering-Team as I'm not sure who exactly would be in charge of this. Since @Lea_WMDE is currently on leave, please poke me, @Bmueller or @Addshore if you have any questions.

Addshore moved this task from Backlog to Watching on the User-Addshore board.

We need to update the package on apt.wikimedia.org, then it's available on the beta cluster and can be upgraded there. Initially it'll be added to the experimental component.

Which wikidiff2 commits need to be cherrypicked (a1d711ebb5ce6bde66b2e4b1e650318a166895d6 ?, but that one's from 2016?) ? Or will there be a 1.4.2 release?

I believe you need both 410ab2ff636eed296206b80a3c89aa75a50b0f8a and a1d711ebb5ce6bde66b2e4b1e650318a166895d6.
The dates are from 2016 as that is when the patches were started but they were only merged in the past days!

This should definitely be a new version, 1.5.

I tagged 1.5.0, and prepared packaging changes:

I cherrypicked the two commits into a 1.4.1+wmf2 package, uploaded that to the experimental section of apt.wikimedia.org/jessie-wikimedia.

deployment-mediawiki04-deployment-mediawiki06 in the Beta cluster have been upgraded along with an HHVM restart. Let me know if there's other systems relavent to your tests which need to be upgraded in deployment-prep.

When your tests are successful and have been confirmed to work fine, we can bump the package to the 1.5.0 release for the rollout in production (starting with the canary app servers first).

@MoritzMuehlenhoff great, thanks!
I think what's still missing is setting $wgWikiDiff2MovedParagraphDetectionCutoff = 25; for the beta wikis to actually see the new behavior. With that set to 0 (default) the diff will just work as before.

@MoritzMuehlenhoff great, thanks!
I think what's still missing is setting $wgWikiDiff2MovedParagraphDetectionCutoff = 25; for the beta wikis to actually see the new behavior. With that set to 0 (default) the diff will just work as before.

I should be able to do that today :)

Change 378235 had a related patch set uploaded (by Addshore; owner: Addshore):
[operations/mediawiki-config@master] beta: $wgWikiDiff2MovedParagraphDetectionCutoff = 25

https://gerrit.wikimedia.org/r/378235

Change 378235 merged by jenkins-bot:
[operations/mediawiki-config@master] beta: $wgWikiDiff2MovedParagraphDetectionCutoff = 25

https://gerrit.wikimedia.org/r/378235

Now set on beta!

Tobi_WMDE_SW closed this task as Resolved.Sep 15 2017, 1:35 PM
Tobi_WMDE_SW moved this task from Watching/External to Done on the WMDE-QWERTY-Team-Board board.
Addshore moved this task from Watching to Done on the User-Addshore board.Sep 15 2017, 2:33 PM

@Tobi_WMDE_SW : The task description mentions "after testing the new behavior on beta, deploy the new version of wikidiff2 in production but leave $wgWikiDiff2MovedParagraphDetectionCutoff = 0; to not enable it yet. Ticket will be created by WMDE's Technical Wishes Team as soon as we are finished with testing." When that's ready, you can assign the ticket for the rollout to me.